1
LucaNet
Upgrade from PHP 4.x to PHP 5.x. Is it convenient?
  • 2007/1/10 15:53

  • LucaNet

  • Friend of XOOPS

  • Posts: 90

  • Since: 2006/5/25


Hi folks,

My server is running PHP 4.3.11 and so, I asked the server support staff for upgrading to PHP 5.x

Here their reply:

System administration will not upgrade current provisioning servers, as the risk to other customers is just too great. They may used the newer php version on future provisioning servers when they feel it is stable. However, we do currently have one server set up for customers such as yourself that require it at this time. If you would like, we can move the site to that server. However, please note, we can provide very limited support for problems that arise from the version change.


Before I decide, I would like to know if it is convenient or not and what problems I could encounter.


Luca



Xoops 2.0.16


Modules:

WF-Channel 1.07
CBB 3.08
XOOP DB backup & restore 3.00
Xoops Protector 2.57
Evennews 2.10
Liaise 1.26
Smartpartner 1.02
Xdonations 1.90
Xoopsfaq 1.10
Polls 1.10
AVAMAN 0.21
News 1.50
SecurityImage 1.00
XOOPS Info 2.12
Sitemap 1.30
Membership 2.00
Smartsection 2.12

2
m0nty
Re: Upgrade from PHP 4.x to PHP 5.x. Is it convenient?
  • 2007/1/10 16:44

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


i would say yeah it's convenient if you are using scripts that require php 5.

more & more developers now are developing using PHP 5.

PHP 5 as been stable for a long while now (as long as you use the latest versions)

if your servers are using PHP versions such as 5.04 or some of the older versions, then you may have a few issues.. but the latest versions of PHP 5 are stable & indeed faster than PHP 4.

the few issues you may get with modules on PHP 5 are usually quickly fixed (ok depending on the actual issues)

but i think it's about time hosts started supporting PHP 5. afterall it's the future and only supporting PHP 4 is kind of restricting new developments.

3
LucaNet
Re: Upgrade from PHP 4.x to PHP 5.x. Is it convenient?
  • 2007/1/10 17:27

  • LucaNet

  • Friend of XOOPS

  • Posts: 90

  • Since: 2006/5/25


Hi m0nty,

now my server is using PHP 4.3.11 and MySQL 4.0.27 so, I would like it be improved.

New PHP version is 5.1.4 and MySQL 5.0.24


Quote:
the few issues you may get with modules on PHP 5 are usually quickly fixed (ok depending on the actual issues)


Do you think that I could encounter some problems with installed XOOPS modules and new PHP and MySQL versions?

In that case, how to fix them?

4
Dave_L
Re: Upgrade from PHP 4.x to PHP 5.x. Is it convenient?
  • 2007/1/10 18:01

  • Dave_L

  • XOOPS is my life!

  • Posts: 2277

  • Since: 2003/11/7


I suggest installing XAMPP on your computer. The latest version (1.55) uses PHP 5.2.0 and MySQL 5.0.27.

Then you can test whether XOOPS and all your modules work properly under those versions of PHP and MySQL.

There are older versions of XAMPP available at sourceforge.net - XAMPP, if you want to try to match the PHP and MySQL versions more precisely.

5
LucaNet
Re: Upgrade from PHP 4.x to PHP 5.x. Is it convenient?
  • 2007/1/11 16:37

  • LucaNet

  • Friend of XOOPS

  • Posts: 90

  • Since: 2006/5/25


I'm trying XOOPS 2.0.16 on Easyphp 2.0 beta1 (PHP 5.2.0 - MySQL 5.0.27) and all seems OK, absolutely faster than on Easyphp 1.8 (PHP 4.x - MySQL 4.x).

Finally, I have decided to move my site to a new server.


Thank you very much, guys!!!

Login

Username:
Password:

Lost Password? Register now!

Who's Online

66 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 66


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits