1
awarrior
Catads Problem x2
  • 2006/10/12 10:59

  • awarrior

  • Just popping in

  • Posts: 48

  • Since: 2006/10/9


Xoops 2.0.15 version 1.02
Catads 1.4

Problem 1
With a new copy of XOOPS and a new copy of Catads, I started my test site on a spare bit of space on my main host. On testing Catads, the only problem was that once an Ad is submitted, I can publish it or delete it, but I can't edit it.

When I click on the 'Edit' link, I get a blank page in the lower half of the admin section with just ' contact 2' showing as text in the top left corner.

Upon using the debug, I get this come up below the ' contact 2' on the page.
Fatal errorCall to a member function on a non-object in /www.weduk.com/test/htdocs/class/xoopsform/form.php on line 193


Also this link shows up in a module on all pages as well.
Parse errorparse errorunexpected in /www.weduk.com/test/htdocs/class/xoopsblock.php(146) : eval()'d code on line 1



Problem 2
A bit of my own making but just need some expert advice to achieve the end result...

I needed to have extra 'Fields' on the Catads submission form with the results also showing in the final Ad, well the 'hack' I did worked [and I'm not a coder], but the end result is just slightly off the mark and I'm not too sure where I went a little bit wrong.

To get a tidy looking end result, I had to put a 2 x 8 row table into the 'templates/catads_item.html' page and duly placed the headings on the left with the 'tags' for the results on the right. On testing this, from submitting an Ad to previewing it, everything looks as it should be and in the right place. That is until the Ad is published, then the results don't quite tie up with the headings.

Not too sure where I'm missing something and I am guessing it is in the 'print.php' or 'adsitem.php' pages or both of them?? I do have a copy of the changes I made, but didn't put them on here as it is a long list.

Advanced thanks
Malcolm
I'm smarter than the average bear boo boo......

2
jeffgr
Re: Catads Problem x2
  • 2006/10/12 12:55

  • jeffgr

  • Quite a regular

  • Posts: 263

  • Since: 2004/2/22


for your first issue, not being able to edit your ads, this is probably because you haven't updated the form.php file, a fix that is needed to get some modules to work with the latest XOOPS version...search on this forum for 2.0.15 form and you will find the link, or maybe someone else will post it here. That fixed this issue for me.

3
awarrior
Re: Catads Problem x2
  • 2006/10/12 18:44

  • awarrior

  • Just popping in

  • Posts: 48

  • Since: 2006/10/9


A scholar and a gentleman sir - Thank you for that jeffgr, found the new form.php file on the forum and replaced it on my test site, then gingerly went for the edit link AND IT WORKED............. It has partly cured problem no2, but not completely. A first Ad submission places the details wrongly, but a re-edit gets them in the right place, so it has to be a bit of code in the wrong place, so I still need a bit of help with this.

On the re-edit I did on Catads, to get the extra fields in place, I did notice a few mistakes in the coding and if anybody has found this program does not work to well, it's because previous coders have not been too meticulous in their work.
I.E.... There is a confusion in the code to do with CITY and TOWN and vica versa, which probably wasn't working for a lot of people. Also a confusion with zipcode, which is entered as ZIPCODE, zipcode, zip code and codposts, not quite sure what the last term had to do with it, but I fixed all that and put in 8 more fields.

Once I get this working correctly, I'll have to submit a better working version with extra field options. That'll be a first for me !!

Cheers
Malcolm
I'm smarter than the average bear boo boo......

Login

Who's Online

595 user(s) are online (398 user(s) are browsing Support Forums)


Members: 0


Guests: 595


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits