11
tl
Re: copyright symbol
  • 2006/5/23 21:50

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


If you look carefully at the source of your homepage, you will notice that the two footers were rendered differently:

& copy; 2005 Patrick Craig

by XOOPS 2.0 © 2001-2003 (or XOOPS 2.0 © 2001-2003 under mozilla)


It is a problem related to XOOPS textsanitizer. XOOPS "sanitizes" header and footer before rendering them in html. It converts & copy; into © then uses © directly in html. I think that is where the problem arises.
Xoops Tips - Tip It and Use It

12
spankee
Re: copyright symbol
  • 2006/5/23 23:31

  • spankee

  • Just popping in

  • Posts: 89

  • Since: 2005/11/13


I just checked one of the default themes that also uses <{$xoops_footer}> and I get the same thing.
So, maybe I have a corrupt file? Which one? I will check later.

I moved hosts the other day and I still get the same problem.
Thought I would throw that out there.

13
tl
Re: copyright symbol
  • 2006/5/24 0:37

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


No, there are no corrupt files. It is just the way how XOOPS textsanitizer works. To get rid of the problem, you will have to avoid using <{$xoops_footer}>.

I have an ampersand in a site description. XOOPS sextsanitizer would convert & amps; into & every time I made a change to the site description. Because of this, I could not get my theme pass the W3C CSS Validator.
Xoops Tips - Tip It and Use It

14
spankee
Re: copyright symbol
  • 2006/5/24 5:37

  • spankee

  • Just popping in

  • Posts: 89

  • Since: 2005/11/13


What is the purpose of the footer.php?
And why would there be a footer.php if it does not even work correctly?

15
Chris03
Re: copyright symbol
  • 2006/5/24 6:21

  • Chris03

  • Quite a regular

  • Posts: 372

  • Since: 2004/2/22


I couldnt get it to work for the longest time either then i tried

in the XOOPS system footer config blank

Hold down Alt and type 0169 on the number pad (right hand side of your keyboard) Alt+0169

puts in the symbol and loads fine now :)
KickassAMD

16
Quest
Re: copyright symbol
  • 2006/5/24 12:01

  • Quest

  • Friend of XOOPS

  • Posts: 1034

  • Since: 2005/11/19


Look in your XOOPS administration/system/preferences/general settings/Meta Tag & Footer. Scroll down to Footer. See what is there. You may be getting two because you have in someway enter it in the .php file and it is also in the settings mentioned above.
The footer is most easily controled for many in the settings mentioned above. The <{$xoops_footer}> allows for quick and easy placement of the desired footer information as typed in the settings above.

Hope that makes some sense.

Quest

17
spankee
Re: copyright symbol
  • 2006/5/24 17:37

  • spankee

  • Just popping in

  • Posts: 89

  • Since: 2005/11/13


Thanks everyone for your help. It is now fixed

I took a look in administration/system/preferences/Meta Tag & Footer and the problem was right there. © was actually showing in the Footer section which is weird because I never changed those settings.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

62 user(s) are online (37 user(s) are browsing Support Forums)


Members: 0


Guests: 62


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits