61
chlockett
Re: Database problem
  • 2005/9/21 20:35

  • chlockett

  • Just popping in

  • Posts: 29

  • Since: 2005/9/10


XOOPS for dummies at http://www.macambridge.com/dummies/ has very detailed installation instructions. When I set my site up online, I had to install XOOPS myself because I didn't have a C panel, but the Admin panel provided a way to create a database, and that's really all you need to do -- create one. XOOPS will do the rest by creating required tables in that database.

Unfortunately, when I tried to install the program on my home computer to set up my own server, all I get is a blank screen! So it's back to XOOPS for DUmmies for me, or find a more reliable product.

Good luck.

62
snake1k
Re: Database problem
  • 2005/12/15 7:37

  • snake1k

  • Just popping in

  • Posts: 3

  • Since: 2005/12/14


Are you sure?
Because ver 2.0.7 does not come with an installer folder. Your information sounds incorrect.

63
nshlan
Re: Database problem
  • 2005/12/20 0:08

  • nshlan

  • Just popping in

  • Posts: 13

  • Since: 2005/12/17


*removed by poster*

64
Xeon_DP
Re: Database problem
  • 2006/1/7 13:10

  • Xeon_DP

  • Just popping in

  • Posts: 25

  • Since: 2005/12/11


hmm i had the same problem, but i found it. don't give it 'localhost' but 'any host' and it works fine
(that fixed my problem)

65
nni123
Re: Database problem
  • 2006/1/25 10:41

  • nni123

  • Just popping in

  • Posts: 17

  • Since: 2004/12/17


Problem solved by
A: going into mysqladmin and changing the password
B: making sure I'm actually using the right password

66
vinceo11
Re: Database problem
  • 2006/1/26 20:03

  • vinceo11

  • Just popping in

  • Posts: 2

  • Since: 2006/1/26


I followed every single instruction that was written out in this thread, but for some reason I keep getting those failing errors when it creates the mainfile.php. Not sure if this has something to do with it, but im using AppServ which installs MySQL, PHP, PHPMyAdmin and Apache. Would it be best if I install everything seperate?

67
ddewilt
Re: Database problem
  • 2006/2/9 19:03

  • ddewilt

  • Just popping in

  • Posts: 14

  • Since: 2006/2/4 1


I have a W2k Pro machine and installed IIS4, Php4 en mysql4. At my place, the same f*cking problem! i'm over 2 a 3 months busy solving the problems with my server!

this is what i get by installing XOOPS 2.2:

page 1

Checking file and directory permissions..
Directory uploads/ is writable.
Directory cache/ is writable.
Directory templates_c/ is writable.
File mainfile.php is writable.


No errors detected.


page 3
General configuration

Please confirm the following submitted data:
Database MySQL
Database Hostname localhost
Database Username root
Database Password root
Database Name XOOPS
Table Prefix jd8Gf
Use persistent connection? No
XOOPS Physical Path C:/Inetpub/wwwroot/html
XOOPS Virtual Path (URL) http://ddewilt-des85

page 4

Saving configuration data..
File ../mainfile.php overwritten by ../mainfile.dist.php.
Constant XOOPS_ROOT_PATH written to C:/Inetpub/wwwroot/html.
Constant XOOPS_URL written to http://ddewilt-des85.
Constant XOOPS_DB_TYPE written to mysql.
Constant XOOPS_DB_PREFIX written to jd8Gf.
Constant XOOPS_DB_HOST written to localhost.
Constant XOOPS_DB_USER written to root.
Constant XOOPS_DB_PASS written to root.
Constant XOOPS_DB_NAME written to xoops.
Constant XOOPS_DB_PCONNECT written to 0.
Constant XOOPS_GROUP_ADMIN written to 1.
Constant XOOPS_GROUP_USERS written to 2.
Constant XOOPS_GROUP_ANONYMOUS written to 3.
Constant XOOPS_CHECK_PATH written to 1.


Configuration data has been saved successfully to mainfile.php.

page 5

check path & URL
Physical path is correct.
Virtual path is a valid URL.


The server path to your XOOPS root directory: C:/Inetpub/wwwroot/html
URL to your XOOPS root directory: http://ddewilt-des85


If the above setting is correct, press the button below to continue.


page 6
confirm database settings
Database Hostname localhost
Database Username root
Database Name XOOPS
Table Prefix jd8Gf


If the above setting is correct, press the button below to continue.


page 7: And THEN!*&$^%%@*&:

check database
Could not connect to the database server.


Please check the database server and its configuration.


As u can see, i used Root as user.

what is the problem here?

68
Khepri
Re: Database problem
  • 2006/2/11 23:21

  • Khepri

  • Just popping in

  • Posts: 35

  • Since: 2005/8/25


Quote:

ddewilt wrote:

As u can see, i used Root as user.

what is the problem here?


Is there a database called XOOPS in mySQL? If not you need to create it so that XOOPS can then create the tables it needs within the database...AFAIK, XOOPS will not create a database for you, only add the tables it needs to an already existing database...
Moo.

69
ddewilt
Re: Database problem
  • 2006/2/14 8:22

  • ddewilt

  • Just popping in

  • Posts: 14

  • Since: 2006/2/4 1


Yeah i did create a database, or, in the MySQL administrator called (if i'm right) schemes or something...

i tried again, but with no succes

i reinstalled all components(mysql, php & iis) but it doesn't work either...

70
wunderdog
Re: Database problem
  • 2006/4/22 23:20

  • wunderdog

  • Just popping in

  • Posts: 7

  • Since: 2006/4/22


1.I have next problem...I have download latest version of XOOPS and upload it to my remote host server.Then I try to install it but I get this eror

Warning: copy(): open_basedir restriction in effect. File(../mainfile.dist.php) is not within the allowed path(s): (/home/freehost/scripts/:.) in /home/freehost/t35.com/w/u/wunderdog/xoops/html/install/class/mainfilemanager.php on line 52

...can someone please tell me what this means?

2.Can you tell me how can I get a remotly hosted page on xoops?(if it is posible)?

Thanks.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

72 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 72


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits