1
baiki
automatically added dot after e-mail address
  • 2005/11/22 21:10

  • baiki

  • Just popping in

  • Posts: 12

  • Since: 2005/1/14


(sorry for the most probably wrong posting. i am lost. i even didn't find with the local search engine something.)

i realised that if i enter a simple e-mail adress in a custom block then a dot '.' will be added automatically.

i do like this:
1. create a custom block
2. write simple text in it and an e-mail address without any tags!
3. save it, give access rights and make it visible
4. go to the page and i see the correct e-mail as a link now but with an additional dot at the end!
5. i use XOOPS 2.2.3 on linux (hosted)

maybe someone can help me. thank you anyway for reading about the small problems we have from time to time absolutely xoopsAdelic.

.baiki

2
CiberEspia
Re: automatically added dot after e-mail address

very peculiar what you wish!!!
Mario Burga
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>Adictoshp.org|Web Blog<<
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

3
Tobias
Re: automatically added dot after e-mail address
  • 2005/11/23 16:24

  • Tobias

  • Not too shy to talk

  • Posts: 172

  • Since: 2005/9/13


I don't have a solution, but I would like to second this question. I had this issue in several modules, wiwimod among them, and also SmartFAQ. I believe it's probably somewhere in the editors? Or perhaps it's some anti email harvesting feature? A mailto link in a href tag does also not prevent the period from showing up.

4
Bananadude
Re: automatically added dot after e-mail address
  • 2005/11/24 9:42

  • Bananadude

  • Not too shy to talk

  • Posts: 155

  • Since: 2005/9/16


It's because you use Autoformat, edit your custom block and change Content Type to HTML.

Best Regards,
Bananadude
--- censored by Bananadude ---

5
Tobias
Re: automatically added dot after e-mail address
  • 2005/11/24 21:52

  • Tobias

  • Not too shy to talk

  • Posts: 172

  • Since: 2005/9/13


Ok, but it doesn't only happen in custom blocks, at least on my installation. Should I tell my users to post only in HTML if they want to include an email? Anyway, is this by design, or is there a way to fix it?

6
minkoilman
Re: automatically added dot after e-mail address
  • 2005/12/3 5:20

  • minkoilman

  • Just popping in

  • Posts: 17

  • Since: 2004/8/7 1


This also happens in the content module. Using the following tag fixes it.

[e mail]username@domain.com[/e mail] (take the space out of "e mail". I had to do that so it would show the code instead of the actual link.)

For a custom block you need to use the following HTML email link...

<a href="mailto:username@domain.com?subject=howdy">text to click on</a>

One of those two solution should fix the problem in most situations. I hope that helps.

7
Bananadude
Re: automatically added dot after e-mail address
  • 2005/12/3 10:09

  • Bananadude

  • Not too shy to talk

  • Posts: 155

  • Since: 2005/9/16


Quote:

Tobias wrote:
Ok, but it doesn't only happen in custom blocks, at least on my installation. Should I tell my users to post only in HTML if they want to include an email? Anyway, is this by design, or is there a way to fix it?


mailaddress@test.com <- gets reported as
[!SCRIPT FILTERED!] at your site if HTML is enabled..

[ email]mailaddress@test.com[ /email] <-works fine :)

< a href="mailto:mailaddress@test.com">My mailaddress< /a> works fine too.

If HTML is not enabled then mailaddresses written in this type:
" mailaddress@test.com " shows up, but as you said..with a dot at the end.

I have no clue at all, but maybe CBB and Content use Autoformat as default (and it can't be changed in the Admin CP). You may want to contact the developers and ask, you can find the CBB-crew here

You don't have to get your visitors to post in HTML, just make sure that those who do it in the "wrong" way click on the email-button to add an email-adress so the forum-codes
[ email] and [ /email]) is used.

Nice site BTW!

Edit AMS is affected too
--- censored by Bananadude ---

8
Tobias
Re: automatically added dot after e-mail address
  • 2005/12/4 22:27

  • Tobias

  • Not too shy to talk

  • Posts: 172

  • Since: 2005/9/13


Thanks for trying it out, also thanks for the flowers re my site Not too much community participation, though. But that should hopefully come at some point.

My people are unlikely to use email clients, and therefore, mailto links aren't so terribly important. And then, I'm not even sure the dot at the end poses any problem in terms of sending the mail. But somehow, it looks fancy.

I'll look for some place to report it. Thanks for the link to the CBBers, I still think it might have to do with the editors

9
baiki
Re: automatically added dot after e-mail address
  • 2005/12/17 10:38

  • baiki

  • Just popping in

  • Posts: 12

  • Since: 2005/1/14


hi there.

well i agree (almost) to this solution:
[e mail]

but is this the meaning? i ask because it wasn't before like this. however, [e mail] works fine for me.

thank you xoopies
.baiki

10
Tobias
Re: automatically added dot after e-mail address
  • 2006/1/4 23:15

  • Tobias

  • Not too shy to talk

  • Posts: 172

  • Since: 2005/9/13


So it is the textsanitizer! Look at snakes's post in the hacks forum for cause and solution. Just in case: I haven't verified it myself, but it makes sense to me.

Login

Who's Online

72 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 72


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits