xoops forums

AWDMolitov

Just popping in
Posted on: 2005/9/7 10:36
AWDMolitov
AWDMolitov (Show more)
Just popping in
Posts: 23
Since: 2005/8/14
#21

Re: Could not register new user.

got this fix from looking through comments,

"Sorry, your password must be at least 3 characters long." - FIX

modules/profile/register.php
line #75

if (!empty($xoopsModuleConfig['minpass']) && strlen($_POST['pass']) <$xoopsModuleConfig['minpass']) {

change whateva is in after the && replace with strlen.

works for me.

libervis

Not too shy to talk
Posted on: 2005/9/7 15:23
libervis
libervis (Show more)
Not too shy to talk
Posts: 183
Since: 2004/7/4 1
#22

Re: Could not register new user.

I know about that fix as I applied it. It fixes the problem I had before this one, not accepting passwords longer shorter than three characters even when user enters longer.

That fix solved that "three characters" problem, but also introduced this new "can't register new user" problem.

Is it only me having this problem after that fix? What, libervis is a ghost site?

Hah..
XOOPS Site: Libervis.com :: For a Free World

-- Libervis Network --

gravies

Not too shy to talk
Posted on: 2005/9/7 15:52
gravies
gravies (Show more)
Not too shy to talk
Posts: 119
Since: 2004/8/18
#23

Re: Could not register new user.

I am having the same problem. You try and register a new user and it says 'Could not register new user.' There are no errors in any of the debug windows. I have edited the user registration form. I am fairly sure that the registration process worked after I updated to 2.2.2 but I think that i must have broken since editing the user fields. I have 2 new fields that are text fields. I deleted some of the base fields from the user field table: eg. YIM, MSN, AIM etc.

I am using 2.2.2 on a Linux server with all permissions correct. There are no firewall issues becuase the problem occurs if you connect to the machine directly. I will try update to cvs version to see if that fixes the problem.

The error message is not completely correct since the user does get entered in the database but they are inactive and no email is sent. The date of registration is also null. This also highlights a bug in the user editing system because inactive users cannot be edited or deleted by the administrator in 2.2.x.
Join the xoops chat lounge on irc.freenode.net #xoops or use this java client http://www.hyperpod.net/modules/ircmod

jaquita

Just popping in
Posted on: 2005/9/7 15:56
jaquita
jaquita (Show more)
Just popping in
Posts: 22
Since: 2005/9/4 1
#24

Re: Could not register new user.

Quote:

libervis wrote:

That fix solved that "three characters" problem, but also introduced this new "can't register new user" problem.


Is it possible you made a typo in register.php when you made that change? You also might want to make sure your editor didn't put any extra spaces or linefeeds AFTER the closing php bracket "?>" in that file.

jaquita

gravies

Not too shy to talk
Posted on: 2005/9/7 16:11
gravies
gravies (Show more)
Not too shy to talk
Posts: 119
Since: 2004/8/18
#25

Re: Could not register new user.

I updated to 2.2.3, retried registration - encountered password bug, fixed with s/trim/strlen/ at line 75 of modules/profile/register.php, got past password problem, clicked finish button.....

Could not register new user.

I have another site running 2.2.2 where none of the custom fields have been edited. I just checked this site and it registers users perfectly.
Join the xoops chat lounge on irc.freenode.net #xoops or use this java client http://www.hyperpod.net/modules/ircmod

DeZ125

Just popping in
Posted on: 2005/9/7 16:28
DeZ125
DeZ125 (Show more)
Just popping in
Posts: 26
Since: 2005/3/29
#26

Re: Could not register new user.

I thought i had this one sussed, our disclaimer was not active so we switched it on and tried a new registration, that worked for one user but the error has arisen again. This is NOT a http_refferer issue, as i have tried with za blocking private header information and received the page telling me howto switch the block off.

An update or some help from the XOOPS dev team would be greatly appreciated from quite a few users on here.

DeZ

gravies

Not too shy to talk
Posted on: 2005/9/7 18:51
gravies
gravies (Show more)
Not too shy to talk
Posts: 119
Since: 2004/8/18
#27

Re: Could not register new user.

FIXED

I added back the YIM, MSN, AIM, ICQ fields to the extended profiles module and it now works again.

I will file this as a bug.

EDIT: You also need to rm -f templates_c/*.php !!!

I only found this out after updating to 2.2.3 RC so I can't tell if you need to upgrade for the fix to work.
Join the xoops chat lounge on irc.freenode.net #xoops or use this java client http://www.hyperpod.net/modules/ircmod

libervis

Not too shy to talk
Posted on: 2005/9/7 19:10
libervis
libervis (Show more)
Not too shy to talk
Posts: 183
Since: 2004/7/4 1
#28

Re: Could not register new user.

Quote:

jaquita wrote:
Quote:

libervis wrote:

That fix solved that "three characters" problem, but also introduced this new "can't register new user" problem.


Is it possible you made a typo in register.php when you made that change? You also might want to make sure your editor didn't put any extra spaces or linefeeds AFTER the closing php bracket "?>" in that file.

jaquita


I use Kate to edit those files and it is known not to add any "garbage" to the file being edited. I also checked for the spaces you mentioned and everything is as it's supposed to be.

Quote:
gravies wrote:
FIXED

I added back the YIM, MSN, AIM, ICQ fields to the extended profiles module and it now works again.

I will file this as a bug.


You're lucky, but that fixes nothing, at least for me. I never deleted those fields and the only change I actually did was to add Jabber text field and enable disclaimer on the registration page. Well, I disabled both now and the problem stays.

We're all playing guessing games inhere. Some are lucky like gravies (for reason beyond understanding) and some are still running in circles like us waiting for one of the Gods (read: core developers) to show up and bless us all.

Hope it'll be soon.

Thank you
Daniel
XOOPS Site: Libervis.com :: For a Free World

-- Libervis Network --

DeZ125

Just popping in
Posted on: 2005/9/7 20:01
DeZ125
DeZ125 (Show more)
Just popping in
Posts: 26
Since: 2005/3/29
#29

Re: Could not register new user.

Quote:

gravies wrote:
FIXED

I added back the YIM, MSN, AIM, ICQ fields to the extended profiles module and it now works again.

I will file this as a bug.

EDIT: You also need to rm -f templates_c/*.php !!!

I only found this out after updating to 2.2.3 RC so I can't tell if you need to upgrade for the fix to work.



Seems to be working for me "so far",time will tell...
Thanks gravies...

gravies

Not too shy to talk
Posted on: 2005/9/7 20:35
gravies
gravies (Show more)
Not too shy to talk
Posts: 119
Since: 2004/8/18
#30

Re: Could not register new user.

You might also try updating the Profile module from modules administration. This update seems to check for missing fields and it may restore any fields that are missing.

I went through each of the fields in a working database and the broken one and only when I added those specified above (+ user_interest) did I see the fix.

You might also need to check the user permissions for each of the fields for edit / view etc. Try adding permissions for the YIM/AIM etc...

I filed the bug report so hopefully Mith will look into it soon.
Join the xoops chat lounge on irc.freenode.net #xoops or use this java client http://www.hyperpod.net/modules/ircmod