1
tedsmith
Membership Module not listing Groups
  • 2005/8/5 19:07

  • tedsmith

  • Home away from home

  • Posts: 1151

  • Since: 2004/6/2 1


I am using the new Membership Module, version 1 and XOOPS 2.0.13

I have 4 groups (including Registered Users and Webmasters). But whenever I go to the module using the site, where it says 'Select Group To Search' there is a drop down menu that only holds the Webmasters and Registered Users groups. My other 2 are not listed at all.

However, when I go to 'Manage Group Membership' all the groups are listed in the drop down menu.

So why do they show up in one, but not the other?

There is at least one user in all 4 groups by the way.

I've tried logging out then back in without any change. For testing purposes all the permissions have been granted to all the user groups. But still no joy?

Any thoughts?

Thanks

Ted

2
dheltzel
Re: Membership Module not listing Groups
  • 2005/8/5 20:44

  • dheltzel

  • Not too shy to talk

  • Posts: 164

  • Since: 2003/1/8 1


The problem is that the user is only a member of the 2 groups. If you add yourself into all the groups they will appear for the search. The manage group page is smart enough to knwo that since you are in the webmaster group you can be trusted to see all the groups, but the search page assumes you are a mere mortal even though you are a webmaster (it just doesn't check). You could probably fix this yourself if it's a big deal, by comparing the code for the 2 pages and making them consistent.

My main focus right now is getting my modules ported to XOOPS 2.2. I have integrated the membership module into the new profiles and am going to submit the changes to Mith for possible inclusion in the next release. When you switch to 2.2, PM me and update you on my progress with those changes.

Dennis
The software industry is the only industry where selling goods known to be defective is perfectly legal, and then you can charge extra for fixing the defects.

3
tedsmith
Re: Membership Module not listing Groups
  • 2005/8/6 9:00

  • tedsmith

  • Home away from home

  • Posts: 1151

  • Since: 2004/6/2 1


Thankyou Dennis - I did as you suggested and at first it made no difference, but when I logged out and then back in again it works.

Thanks a lot for your explanation.

Regards

Ted

Login

Who's Online

72 user(s) are online (48 user(s) are browsing Support Forums)


Members: 0


Guests: 72


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits