1
asche
Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 14:31

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


On www.mobilfunk-volksbegehren.de/html it happens that a registered/loggedin user tries to call a posting in a private forum from window "most recent themes" and the following error occurs (sorry, I dont know the exact wordig of this error in English):
"you dont have the privileges to enter this forum".

I am sure that the user is logged in allright (I remember seeing the username allright, but I cant check now, because it is working for a change).

This error occurs quite often when using a multibrowser (I tried firefox and irider), so maybe it is a refresh problem. With internet explorer it usually works (I am not sure if it happened once).

Weird thing is that the user can access the forum from window "most recent themes" without a problem (the forum is listed on the left side to the posting). Also the user can navigate to the forum directly and open the posting allright. So this error occurs only when calling a posting from window "most recent themes" (and that is the way my users enter the forum and they keep on complaining).

I'll be back to be more specific. Do other users have the same problem? Somebody knows how to handle this?

2
asche
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 15:14

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


I checked again and the error occurs as described above (user has permissions and is logged in).

Because this error annoyes the users and the website supporting a referendum shall be introduced to the press next monday this problem is really serious.

For checking out, I created a user test/test who can see a posting test in the window "most recent themes" on http://www.mobilfunk-volksbegehren.de/html/index.php. Dont be mad at me if it works. Please believe me that users really complain and theer is a problem.

Glad if you have any hints, asche

3
Herko
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 16:06

  • Herko

  • XOOPS is my life!

  • Posts: 4238

  • Since: 2002/2/4 1


Not Found
The requested URL /~vobe/html/index.php. was not found on this server.

this is a 404 error on the link you posted.

Herko

4
m0nty
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 16:28

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


works for me when using firefox and IE

but not from the link you provided!

i used the link on your profile here and i can't see any probs..

http://66.195.17.52/~funkpau/html/index.php

5
m0nty
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 16:32

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


ok remove the . from the end of the url in your previous link

http://www.mobilfunk-volksbegehren.de/html/index.php


i now see that's a different site??

6
asche
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/14 17:51

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


sorry for the dot at the end of the url, you can test the system with following urls:
http://www.mobilfunk-volksbegehren.de/html
http://66.195.17.52/html
http://66.195.17.52/~vobe/html
http://66.195.17.52/%7Evobe/html
http://66-195-17-52.dimenoc.com/~vobe/html/
whatever (this was a problem for me until solved 10 minutes ago by german XOOPS community, because http://66.195.17.52/html was in mainfile.php and was therefore displayed in the url).

allright, anyhow there is still this problem with "missing privileges" as described above and I'll be back if problem occurs again or if I can describe any better. Thanks a lot for your support.

7
asche
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/15 15:39

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


As stated in my last post my problem of ip address showing up in url (which I thought is not related to this thread) was just solved by changing ip-address to domainname in mainfile.php.

Now I found a posting, that info in mainfile not fitting to url can also cause login problems.

posting where I found the info
Quote:
It may be a conflict problem between the registered XOOPS Site URL and your browsers actual URL at logon time.


So this may be an answer to my login problem as well and I think my problem is solved now.

8
asche
Re: changing XOOPS_URL to domainname causes notification error
  • 2005/6/16 13:55

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


it is me again, still struggeling with xoops_url ...
After changing XOOPS_URL to 'http://www.mobilfunk-volksbegehren.de/html' the ip address vanished from the url allright, but the domainname as XOOPS_URL causes a new problem:

When I try to set notification options I get this error now:
Undefined offset: 2 in file include/notification_update.php line 77
The requested URL /~user/~user/html/modules/newbb/viewtopic.php was not found on this server.

When I change XOOPS_URL back to 'http://66.195.17.52/~user/html' everything is allright again.

Anybody has a clue for this confusing behaviour?

9
m0nty
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/16 15:34

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


change back to the domain name instead of url,

after doing so.. empty the contents of templates_c and cache folder.. this will clear all compiled templates and cache that may still reference the ip instead of the url..

hope this helps :)

10
asche
Re: Multibrowserproblem ? - "you dont have the privileges to enter this forum".
  • 2005/6/16 16:10

  • asche

  • Not too shy to talk

  • Posts: 116

  • Since: 2004/4/5 9


thanks monty, I really appreciate yours and everybodys support, but this tip didnot solve my problem nevertheless it is a great feeling not to be left alone with such awful stuff on a nice summerday )). I'll keep on working on this problem and will be back with more details.

Login

Who's Online

52 user(s) are online (30 user(s) are browsing Support Forums)


Members: 0


Guests: 52


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits