1
corbett
browser cache not invalidated on login or logout
  • 2005/1/7 7:36

  • corbett

  • Just popping in

  • Posts: 4

  • Since: 2005/1/7 4


xoops-2.0.9, PHP/4.3.10-2, Apache/2.0.52 (Debian GNU/Linux)

Anonymous user visits a few pages, then decides to login. So far so good. After logging in, user returns to a page previously visited anonymously. Page is fetched from the browser cache, so it appears user isn't logged in anymore.

Same problem happens when the user logs out. If they visit a page they first visited when logged in, they appear logged in again. Shift-Reload fixes the problem, but it is unreasonable to make the users do this.

As far as I can tell, XOOPS isn't succeeding in telling the browser that the cached pages are no longer valid or preventing the browser from caching them in the first place.

The problem occurs in Mozilla 1.7, Firefox 1.0, but does not occur in IE 6.

The various debug modes didn't tell me anything. All the module caching options are set to 'No Cache'. I've tried General Settings > Update module template [...] with both Yes and No. I've tried with and without gzip. I'm using the default theme....

Any help appreciated.

2
Herko
Re: browser cache not invalidated on login or logout
  • 2005/1/7 7:58

  • Herko

  • XOOPS is my life!

  • Posts: 4238

  • Since: 2002/2/4 1


Odd, as we don't have this problem here on XOOPS.org, or any of the other XOOPS powered sites I visit. That makes me think this might be a theme related issue? Whaich theme do you use? Have you made many modifications?

Herko

3
brash
Re: browser cache not invalidated on login or logout
  • 2005/1/7 8:11

  • brash

  • Friend of XOOPS

  • Posts: 2206

  • Since: 2003/4/10


What about block caching? Are the menu blocks, or the user login block cached at all?

4
corbett
Re: browser cache not invalidated on login or logout
  • 2005/1/7 17:50

  • corbett

  • Just popping in

  • Posts: 4

  • Since: 2005/1/7 4


Thanks for the quick reply!

I'm using the default theme. I've changed some styles and removed the XOOPS the branding. I'm attempting to add XOOPS to an existing site and we want to keep our existing look.

All the blocks have caching turned off.

The only funky module I'm using is the phpWiki module. It has some problems. At first, it was emitting complete html pages that were being embedded in the XOOPS page, so the <html> tag would appear twice, etc. It also had the default adminstrator account active and had it's own caching problem. I fixed those things by editing its templates and changing its config file. It's also based on an old version of phpWiki, but hey, I'm not complaining. It's very nice to have all this work to start from!

In the next day or so, I'll try reinstalling.

I haven't seen the problem on the main XOOPS site so either it's version related or something I touched.... I was hoping there was an obvious config option I missed.

Say, any ideas what I could have done that would only break firefox and mozilla, but not IE6?

Thanks again,
John

5
Mithrandir
Re: browser cache not invalidated on login or logout

Is the problem in all modules or only in the phpWiki module?

6
corbett
Re: browser cache not invalidated on login or logout
  • 2005/1/8 5:48

  • corbett

  • Just popping in

  • Posts: 4

  • Since: 2005/1/7 4


Great question! When I turned off the phpWiki module, I wasn't able to reproduce the problem. The main clue I have that there is a problem is whether or not the login form appears and whether or not the logout menu option is available.

So, it seems there is a problem with the phpWiki module or my "fixes".

Now, I still don't understand why the problem, but we're narrowing it down!

Thanks again!
John

7
corbett
Re: browser cache not invalidated on login or logout
  • 2005/1/9 23:00

  • corbett

  • Just popping in

  • Posts: 4

  • Since: 2005/1/7 4


As a matter of fact, you do have this problem on other XOOPS sites... dev.xoops.org has this problem. To reproduce it, just login using firefox or mozilla, go to the dev wiki, visit a few pages, logout, then visit those pages again. It will appear is if you are still logged in.

If I find the cause, I'll let you know.

8
lubdub
Re: browser cache not invalidated on login or logout
  • 2005/2/15 8:01

  • lubdub

  • Just popping in

  • Posts: 64

  • Since: 2002/2/28


I have the same problem with my own site (but never with Xoops.org or FrXoops)... Did anybody find anything relating to this?

9
RipTorn
Re: browser cache not invalidated on login or logout
  • 2005/4/25 14:51

  • RipTorn

  • Just popping in

  • Posts: 9

  • Since: 2005/4/25


Hi yes I have this same problem, I thought it was just a bug with XOOPS but it is just this mod, the mod works great aside from these small problems.

Ive turned on the site debug and it spits out all sorts of problems.

*

Notice [PHP]: Undefined index: dbhost in file modules/phpwiki/index.php line 784
Notice [PHP]: Use of undefined constant path - assumed 'path' in file modules/phpwiki/index.php line 808
Notice [PHP]: Undefined index: path in file modules/phpwiki/index.php line 808
Notice [PHP]: Constant DEFAULT_LANGUAGE already defined in file modules/phpwiki/index.php line 817
Notice [PHP]: A session had already been started - ignoring session_start() in file modules/phpwiki/lib/Request.php line 403
Notice [PHP]: Undefined variable: LANG in file modules/phpwiki/lib/Template.php(124) : eval()'d code line 14
*

Cheers
Rip

Login

Who's Online

51 user(s) are online (25 user(s) are browsing Support Forums)


Members: 0


Guests: 51


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits