1
Shelia
newbb2 error
  • 2005/1/31 12:56

  • Shelia

  • Not too shy to talk

  • Posts: 140

  • Since: 2003/6/22


I posted this in another message but I think it may have gotten lost in the fix for something else.

An Error Occured
SELECT t.*, u.name, u.uname,u2.name as last_post_name, u2.uname as last_poster, p.post_time as last_post_time, p.poster_name as last_poster_name, p.icon, p.post_id, p.post_karma, p.require_reply, pt.post_text FROM xoops_bb_topics t LEFT JOIN xoops_users u ON u.uid = t.topic_poster LEFT JOIN xoops_bb_posts p ON p.post_id = t.topic_last_post_id LEFT JOIN xoops_bb_posts_text pt ON pt.post_id = t.topic_last_post_id LEFT JOIN xoops_users u2 ON u2.uid = p.uid WHERE (p.post_time > 1020729304 OR t.topic_sticky=1) AND t.forum_id = AND t.approved = 1 AND p.approved = 1 ORDER BY t.topic_sticky DESC, p.post_time DESC

My visitors can't post and neither can I. MySQL Debug shows nothing wrong. Anyone have any idea what's going on? It says the post has already been submitted.

2
darlington
Re: newbb2 error
  • 2005/1/31 17:26

  • darlington

  • Just popping in

  • Posts: 4

  • Since: 2005/1/31


I'm having the same problem! I updated to NewBB2 last week, everything seemed fine until this morning I try to enter a forum and I get that error. I can post replies, but as I can't enter a forum I cannot post a new topic. I tried updating to newbb 2.02, but that makes no difference. PHP and mySQL debug modes show no errors.

3
irmtfan
Re: newbb2 error
  • 2005/1/31 17:43

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


do you run the upgrade script in newbb/upgrade/ ?

4
darlington
Re: newbb2 error
  • 2005/1/31 19:07

  • darlington

  • Just popping in

  • Posts: 4

  • Since: 2005/1/31


I ran the update script, and everything seemed to work fine for five days. That's what has me puzzled...

I get the error whenever I try to enter a forum. I can view individual topics, but not forums. Doesn't matter if I'm logged in or not.

5
darlington
Re: newbb2 error
  • 2005/1/31 21:39

  • darlington

  • Just popping in

  • Posts: 4

  • Since: 2005/1/31


I disabled posting excerpts in the forum page and that got rid of the error. Not sure why. I'm no php expert but it seems the code in the error has something to do with excerpts and whether or not they are displayed. A bug maybe? I dunno.

6
Anonymous
Re: newbb2 error
  • 2005/1/31 22:07

  • Anonymous

  • Posts: 0

  • Since:


The excerpts is added since 2.0.1 and i run this several weeks without a problem, send me a URl and a Temp access to PM and I will look into it tomorrow everning.

7
Shelia
Re: newbb2 error
  • 2005/2/1 0:00

  • Shelia

  • Not too shy to talk

  • Posts: 140

  • Since: 2003/6/22


First, let me say that I've beening using XOOPS on several sites for over a year. I have "never" had a problem with a module. Granted some didn't work the way I wanted them to but they installed correctly and never gave php errors.

Now.......The Newbb2 was a bear from the very beginning. I ran the upgrade script which I assume updated the tables. Setting the XOOPS permissions was not enough to set forum permissions (I had to delve deep into the module for that).

I tried again today and managed to post and the post never showed up in the forum. When I tried to post again I got the error I mentioned in my first post.

So why the error? I'm clueless and more than ready to find out how to go back to the previous version.

Shelia

8
DeZ125
Re: newbb2 error
  • 2005/4/26 6:54

  • DeZ125

  • Just popping in

  • Posts: 26

  • Since: 2005/3/29


I too am having the same problem on my site, error comes up intermittently and isn't easily replicated. Most of the time when this happens, it's replying to a post, but not all the time, can happen on a new post as well.

At first, I thought it was only myself, but other user's are reporting the same issue, so that rules out any Internet security, firewall that may be running.

Yesterday, on hope it would clear this error up, I updated the site to 2.0.10, and updated NEWBB to 2.02(was 2.01 as far as I knew)But the problem still remains.

Also, alot of posts already sub,itted popping upLike This


DeZ

9
RipTorn
Re: newbb2 error
  • 2005/4/26 7:42

  • RipTorn

  • Just popping in

  • Posts: 9

  • Since: 2005/4/25


Yes I have the same problem but after turning on the MySQL debug I get this error showing up in the newbb2

I seem to only have problems since i updated the core of XOOPS to 2.0.10 stable

but heres the debug

SELECT submenuitem, titlelink FROM xoops_wfslinktous
SELECT submenuitem , titlerefer FROM xoops_wfsrefer
SELECT * FROM xoops_modules WHERE dirname = 'spaw'
-300
Error number: 1064
Error message: You have an error in your SQL syntax near '-300' at line 1
DELETE FROM xoops_online WHERE online_updated < 1114497825
SELECT COUNT(*) FROM xoops_online WHERE online_uid=1
UPDATE xoops_online SET online_updated=1114498125, online_module = 11 WHERE online_uid = 1


but after I post and get the error page this is the debug

SELECT * FROM xoops_config WHERE (conf_modid = 0 AND conf_catid = 1) ORDER BY conf_order ASC
SELECT sess_data FROM xoops_session WHERE sess_id = 'c08e31ba9b29b5b2aedbc78f96a0ef4e'
SELECT * FROM xoops_users WHERE uid=1
SELECT * FROM xoops_modules WHERE dirname = 'newbb'
SELECT * FROM xoops_config WHERE (conf_modid = 11) ORDER BY conf_order ASC
SELECT forum_type, forum_name, forum_access, allow_html, allow_sig, posts_per_page, hot_threshold, topics_per_page FROM xoops_bb_forums WHERE forum_id = 1
Error number: 1054
Error message: Unknown column 'forum_access' in 'field list'

any ideas or help would be great thanks


Cheers
Rip

10
m0nty
Re: newbb2 error
  • 2005/4/26 7:52

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


SELECT * FROM xoops_modules WHERE dirname = 'spaw'
-300
Error number: 1064
Error message: You have an error in your SQL syntax near '-300' at line 1


i'm presuming you have got spaw installed? if not then that maybe the cause of that problem.. try setting to use default editor in preferences of newbb2 instead of using the other editors..

Error message: Unknown column 'forum_access' in 'field list'

when u updated to 2.0.10 did u also update the newbb as the newbb included in the patch and 2.0.10 packs are for newbb 1 and not newbb2..

either that or maybe u haven't ran the upgrade script..

Login

Who's Online

221 user(s) are online (198 user(s) are browsing Support Forums)


Members: 0


Guests: 221


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Feb 29
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits