xoops forums

Cavan

Friend of XOOPS
Posted on: 2005/1/27 16:50
Cavan
Cavan (Show more)
Friend of XOOPS
Posts: 218
Since: 2004/11/28
#11

Re: AMS 2.2 *again*

Here is the step-by-step results of uninstalling/reinstalling AMS 2.2, Part I:

1. Logged in as Admin, I deactivated AMS 2.2 in the system admin menu.

2. Next, I uninstalled AMS 2.2 from the system admin menu.

3. Via FTP (Cute FTP), I deleted the AMS index.html file (the only one listed for this module) in the templates_c folder.

4. Next, I reinstalled AMS 2.2 via admin system menu.

5. In the AMS 2.2 Topics Manager menu, I created two topics, "News" and "Events".

6. In the AMS 2.2 Submit/Approve Permissions menu, I checked the boxes for "News" and "Events" in "Approve Permissions" for both Webmasters and Registered Users (I did not check the "All" box) and clicked submit.

7. In the AMS 2.2 Submit/Approve Permissions menu, I checked the boxes for "News" and "Events" in "Submit Permissions" for both Webmasters and Registered Users (I did not check the "All" box) and clicked submit.

8. In the AMS 2.2 Submit/Approve Permissions menu, I checked the boxes for "News" and "Events" in "View Permissions" for both Webmasters and Registered Users (I did not check the "All" box) and clicked submit.

9. In the AMS 2.2 Preferences menu, I changed only two settings:

Auto approve articles without admin intervention? Yes
Comment Rules: Comments by registered users are always approved

Now here's where things get strange (at least, to me)...

Part II:

1. Still logged-in as Admin, I navigated to where modules/AMS/submit.php is on my site. In the title and article text boxes, I entered the words "ams 2.2 test" leaving the topic set to "News" and selecting no other options, I scrolled down and clicked "preview". I previewed my post and clicked "post", and the post was submitted.

2. I repeated step #1 exactly, only this time I selected "Events" as the topic, and the post was submitted.

3. Next, in the title and article text boxes, I entered the words "ams 2.2 preview post test", leaving the topic set to "News" and selecting no other options, I scrolled down and only clicked on "post". The error "Article saving failed" appeared and the post was not submitted.

4. I repeated step #3 exactly, only this time I selected "Events" as the topic, and again the error "Article saving failed" appeared and the post was not submitted.

5. I logged-out as Admin an logged-in as one of my registered users. I repeated steps #1, 2, 3 and 4 and received the exact same results.

So, there it is...And I haven't a clue as to why I can now submit with previewing a post and not without. Is this a sessions or cache issue, or is it something else? Any ideas?

I'd sincerely appreciate some input. Thank you.

FYI, I was able to rate and comment on the articles that were submitted without issue.

Cavan

Friend of XOOPS
Posted on: 2005/1/27 17:35
Cavan
Cavan (Show more)
Friend of XOOPS
Posts: 218
Since: 2004/11/28
#12

Re: AMS 2.2 *again*

I still need to know where to delete the following fields from the submit form:

Display Topic Image?
Position
Publish in Home?
Audience
Banner/Sponsor

And in the article view (article.php) itself (bottom right side across from 'rate article'):

Edit
Links

I don't need nor do I want any of these options available for users.

brash

Friend of XOOPS
Posted on: 2005/1/27 21:20
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#13

Re: AMS 2.2 *again*

This is definatley a bug, I've tested it myself. It's very time consuming to tes all functionality with all possible option combinations, and this seems to be just one that has slipped under the radar during testing.

I aggree with your idea of uninstalling and reinstalling, as the orphaned article that is in your database may well be causing issues. When you have it reinstalled, I'd suggest that at first you do not change any of the preference settings until you get used to the way topics, permissions and audience levels hang together.

malexandria

Quite a regular
Posted on: 2005/1/27 21:49
malexandria
malexandria (Show more)
Quite a regular
Posts: 281
Since: 2001/12/23
#14

Re: AMS 2.2 *again*

I was having the same trouble and it turned out to be a simple permsissions problem on my template and theme directory which was set to 755 instead of 777.

brash

Friend of XOOPS
Posted on: 2005/1/27 22:29
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#15

Re: AMS 2.2 *again*

Whoops, missed your other posts there Cavan.

Thanks for the detailed report, there are obviously some issues there with a bug when you have the "Auto approve articles without admin intervention" set to yes. I suggest uninstalling, reinstalling and not using this option. I'll have a look at getting this fixed for a future version of AMS.

As for you request of removing items from the submit and article views, you should be able to do what you want with the article view by editing the ams_article.html template. However, the submit form is not templated, and what is displayed there depends on the user permission levels so you won't be able to alter that without modifying code.

m0nty

XOOPS is my life!
Posted on: 2005/1/27 22:35
m0nty
m0nty (Show more)
XOOPS is my life!
Posts: 3337
Since: 2003/10/24
#16

Re: AMS 2.2 *again*

this works on mine :S

i have auto approve turned on, and can submit articles without errors.. both for admin groups and registered users groups..

but maybe was i always set preferences 1st after installing a module, then i configure the topics and category's etc and then do the rest.. but preferences i always configure 1st of all.. i dunno if that makes a difference..

brash

Friend of XOOPS
Posted on: 2005/1/27 22:54
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#17

Re: AMS 2.2 *again*

Really ? I did test this on my testing system which mightn't have a 100% clean install of AMS. I might start it again from scratch and see how I go.

m0nty

XOOPS is my life!
Posted on: 2005/1/27 23:05
m0nty
m0nty (Show more)
XOOPS is my life!
Posts: 3337
Since: 2003/10/24
#18

Re: AMS 2.2 *again*

yup very strange.. have had no errors whatsoever using it, apart from i just discovered i can't add any new audience levels..

i have 1 that says everyone and is all groups enabled..

but i can't find an add new audience level link anywhere.. :S i'm sure i saw something on the site i setup for a friend tho.. but i can't see it on mine..

brash

Friend of XOOPS
Posted on: 2005/1/28 0:02
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#19

Re: AMS 2.2 *again*

There is no add link as such, all you should have to do is type in the name of the new audience level you want in the "Manage Audience Levels" section, set the groups and hit save.

m0nty

XOOPS is my life!
Posted on: 2005/1/28 1:35
m0nty
m0nty (Show more)
XOOPS is my life!
Posts: 3337
Since: 2003/10/24
#20

Re: AMS 2.2 *again*

ok, yep that worked.. cheers :)