xoops forums

scorpian

Just popping in
Posted on: 2004/11/2 6:51
scorpian
scorpian (Show more)
Just popping in
Posts: 34
Since: 2004/11/2
#1

Does xoops support MySql 4.1.7?

Hi everybody,

Does XOOPS support MySql 4.1.7? I have my own computer set up with WinXP Pro SP1, PHP 5.0.2, Apache 2.0.52, MySql 4.1.7 and phpMyAdmin 2.6.0-pl2, they are all working fine, then I install XOOPS 2.0.9 beta and after I clicked "Next" on the "confirm database settings" page, XOOPS generated a blank page.

Does anyone with the same problem and How to fix it?

Thanks in advance.

scorpian

Just popping in
Posted on: 2004/11/2 18:14
scorpian
scorpian (Show more)
Just popping in
Posts: 34
Since: 2004/11/2
#2

Re: Does xoops support MySql 4.1.7?

Nobody use MySql 4.1.7?

mCity

Just popping in
Posted on: 2004/11/4 2:37
mCity
mCity (Show more)
Just popping in
Posts: 52
Since: 2003/3/31
#3

Re:Does xoops support MySql 4.1.7?

I try to setup today. when I try to seach anyone tried. I found you.
Well, have you compiled PHP with mysqli extension?
have you checked http://php.net/mysqli

Chris03

Quite a regular
Posted on: 2004/11/4 2:59
Chris03
Chris03 (Show more)
Quite a regular
Posts: 372
Since: 2004/2/22
#4

Re:Does xoops support MySql 4.1.7?

i currently host about 10 XOOPS sites on 4.1.7 and 3 on 5.0.1 have had no issues what so ever!!

scorpian

Just popping in
Posted on: 2004/11/4 14:36
scorpian
scorpian (Show more)
Just popping in
Posts: 34
Since: 2004/11/2
#5

Re:Does xoops support MySql 4.1.7?

Thanks for you guys' replies, my computer is running on Windows platform so I just edit php.ini to use the extension=php_mysqli.dll extension, with this extension enabled and modify the config file of phpmyadmin to use mysqli then phpmyadmin is working fine. However I don't know is there any config file need to be modified for XOOPS to use mysqli. I just keep getting blank page.

Chris03

Quite a regular
Posted on: 2004/11/12 5:44
Chris03
Chris03 (Show more)
Quite a regular
Posts: 372
Since: 2004/2/22
#6

Re:Does xoops support MySql 4.1.7?

why do you need MySQLi support as PHP 4.3.9 has support for MySQL already.. 5 series needs the DLL loaded...

onokazu

XOOPS Founder
Posted on: 2004/12/10 7:57
onokazu
onokazu (Show more)
XOOPS Founder
Posts: 617
Since: 2001/12/13
#7

Re:Does xoops support MySql 4.1.7?

You don't need the mysqli extension for running xoops.

tedsmith

Home away from home
Posted on: 2004/12/10 8:16
tedsmith
tedsmith (Show more)
Home away from home
Posts: 1151
Since: 2004/6/2 1
#8

Re:Does xoops support MySql 4.1.7?

On my work Intranet site I use MySQL 4.0.2 and php 4.3.6, but on 2.0.7 (not gone to 2.0.73 yet and I don't use Betas on live sites. On my personnal site, well that's hosted for me so I expect they use the latest (or near to latest) versions of both and it's OK for me.

To resolve your blank page try turning your php Debug on (if you can access System, Admin - if not you have to do it from the database - do a search in XoopsFAQ to find out how). That will then tell you (error wise) why you are getting a blank page. Others may then be able to help.

DrLui

Just popping in
Posted on: 2005/2/10 21:44
DrLui
DrLui (Show more)
Just popping in
Posts: 1
Since: 2005/2/10
#9

Re: Does xoops support MySql 4.1.7?

Hi

I think that from some version (4.1.4g or something), MySQL uses encryptet password access. The problem is that XOOPS supports only MySQL connector and you'll need mysqli.
You have two choices
1. Put your mysql/users table into unhashed pasword form, so You could use MySQL extension. See the MySQL help how to do it.
2. What I would appreciate more too. To rebuild the base database class to support mysqli connector. I wouldn't be happy to send plaintext passwords espacially in these days of security freaks. I actually don't know why this base class was not rewritten yet to support (actually only wrap)PEAR:B class.

Hope this help.

Dr. Lui