1
Trener
Re: Bottom blocks are not visible
  • 2008/3/7 1:22

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Can anyone help, please?



2
Trener
Re: Bottom blocks are not visible
  • 2008/3/4 14:28

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Well I decided to follow phppp and Quest advise. To use default theme from 2.0.18.1 and transfer all themes to new default theme.

As it's obvious I don't have any idea how to do that it would be very helpful to give me the directions what do do with the old themes and new default theme. If anyone is ready and have a will to teach "us" how to do this I would be very gratefull. Everybody is welcome to post his knowledge here.

You can think that this thread could be a good tutorial for other users who has also problems with themes and would like to transfer the old theme into new one.



3
Trener
Re: Bottom blocks are not visible
  • 2008/2/28 16:28

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Quote:

Burning wrote:
hi,

A small tutorial about what you can do with blocs in center column here

@+


I have checked it but it's French. And I couldn't find version in English. So it's helpless for me.

Anyway it seems it's going to be quite a task to repair all themes. Because I'm using 15 of them on the site and I have another 15 on testings to include them into the site. That means a lot of work. I think I will need to check forum for some help and tutorial about what and where to change. Because I don't have any idea what to do with the default theme and what to change and where to implement old theme into new default theme from 2.0.18.

But, I will try. As I see it can't be very hard to do.



4
Trener
Re: Bottom blocks are not visible
  • 2008/2/28 12:53

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


I used all the informations you gave me and made some improvements. I have been playing with 2 themes and it looks I managed to get them to work. I copied that giben part of code and removed one line from original. The first line after the line: <!-- End display center blocks --> was removed (this is the line => <div id="content">). Because it is alreday included in a given code. This line was the problem. It was there twice and showed default module twice on a top page.

You can check it on website:

www.javnomnenje.com

It's Slovenian and you wil probabla not understand a thing since it's translated.

I was playing with themes: cslite, foliage and default

But still one thing bothers me. If I compare position of blocks with default theme and with the situation from before I notice that blocks are not positioned symetrical. Their width are not the same. One is wider then the other.

If I change position of the blocks again back to top, width becomes equal for left and right block.

I don't need to do anything with default theme. It shows blocks correctly (even the width) all the time no matter what is the position of blocks.

I'm sure there is something I should change or set in theme.html. But without your help I will never find what to change.



5
Trener
Re: Bottom blocks are not visible
  • 2008/2/28 9:12

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Quote:

phppp wrote:
The themes are old, check default theme in 2.0.18.1


I know themes are old. But I would still like to use them since there is no new themes. At this time I can chose between few hundred themes. If it's possible I'll try to fix them so I can use them on my site.

Your solution to check default theme in XOOPS 2.0.18 is not good for me because it's only one theme. And who knows if I like it?

I'd like to use more themes on my site. At this time I have 15 of them avaliable for users. your solution would give me only one theme avaliable.

Quote:

Burning wrote:
hi,

That's not difficult. Just copy these lines (at the right place ) in theme.html



Thanks for your help and solution.

The code you gave me did the trick. But we would need to do one correction. If you have time of course. Because I don't have any knowlidge in programming or PHP or HTML.

Now I have on my top site what I want. Firs the default module (content) and below bottom blocks. At that point this should be the end of the site. BUT, after the bottom blocks, below them, once again default theme is shown. That means I have now first default theme, then bottom blocks and after them once again default theme.

Can we remove somehow the bottom default theme? Hehe, one on top is enough for me!!!



6
Trener
Bottom blocks are not visible
  • 2008/2/28 2:16

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


I read 2 posts about this problem. But there was no real solution. So I'm asking now same question.

How to make bottom blocks visible in a theme?

For some unknown reason bottom blocks are not visible. If I all put them on top and set weight, then is ok. But if I want to put them on bottom, below one module (content) on top site, blocks are not visible.

It looks it's something wrong with themes because I found 2 themes shown the blocks right way. I tried some 40 themes and all of theme don't show bottom blocks. Except those 2 off course.

So, is there any solution how to fix other themes to show bottom blocks?

Thanks for any answer.



7
Trener
Re: Using translated files on another site
  • 2008/1/31 22:34

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Thanks very much for this. This is tge answer I really needed. Now I can use translated files on other site which I have set recently. And I don't need to translate everything ones again.

The second thing I will be able is use files for the Slovenian language for certain modules.

I appricciate this really. Thank you very much again.



8
Trener
Re: Using translated files on another site
  • 2008/1/31 19:20

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Hm, it's strange noone knows the answer.



9
Trener
Re: Can't see installed modules in System Admin
  • 2008/1/21 21:59

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


Delete the existed XOOPS instalation and instll new one. Probably everything will start to work.

I'm using XOOPS now for quite a long time. I also have done a lot of testing. I set the test page locally and put my self into testing of some modules which I supposed to use in a future. This task required many installing and uninstalling different modules. And always when I do such testing I get the same problem. Some modules stop to work, white screen starts to appear, sometimes I can't see installed module in Module admin area or I can't see new modules ready to install. Or some problems come up on a page. Different strange things happens.

When the test page gets so much not working I simply delete it and install fresh XOOPS installation. And suddenly everything starts to work.

By my opinion XOOPS have some problems when a lot of installing and uninstalling of modules happens. And also when a lot of modules is installed at the same time. I don't know if anyone is aware of this fact but the truth is this could be the problem for some users of Xoops.

And finally. When I set my new REAL internet page I installed only those modules which I found they would be the right one. Only one installation of each module. No installing and uninstalling. By now it works for me.



10
Trener
Re: Using translated files on another site
  • 2008/1/21 20:26

  • Trener

  • Just popping in

  • Posts: 18

  • Since: 2007/2/16


I understand everything you wrote. I do this all the time. Change something in PHP files and reflects strait on the page.

What I need to know is if the files are the same all the time. Before installing the XOOPS and after. The same question for modules. Are files unchanged after the module is installed?

I'd like to use translated PHP files from existing already installed site on another not translated site. Is it OK to do this?

And the answer about publishing translated core and modules. Me and one other guy are talking about setting Slovenian XOOPS site. We are still counseling. I can't promise anything. Maybe we will succeed.




TopTop
(1) 2 »



Login

Who's Online

70 user(s) are online (48 user(s) are browsing Support Forums)


Members: 0


Guests: 70


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Oct 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits