1
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 14:12

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Checked the .htaccess files. There was only one in my webspace (something to do with frontpage extensions, I don't us them...)

Only thing I'm not sure about is the possibility that this error could be linked to the php config of the server. Maybe the group management module does something that isn't allowed on the server...

Are there any parameters for php (in php.ini)that I should/could check?



2
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 8:19

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Ok, here's what I've tried in the meantime...
I do have some experience with LAMP and I've installed many blogs, bulletin boards, etc... So...

I checked all the permissions, I can see nothing irregular there. (I have a local install to compare with).
I checked the database tables, no difference between local and remote db.
I tried to re-upload XOOPS and reïnstall. I even tried to upload parts of it (ex.: the modules folder...)
I chmod-ed everything under admin folder to 777.
Nothing gets the group-management module working.
I tried uploading everything and reïnstalling under a different folder (not in the roorfolder) with a new database. Again, I cannot access the group administration.

I'm running out of ideas here. Anyone?

I'd really like to get this working. I don't feel like searching for another system as it's working fine for my local install.



3
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 15:02

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


...

And that didn't work out...
Deleted all the XOOPS files on the server as well as the database and I started from scratch, this time without the Dutch languagepack.
Again, everything works, every administration link, except for the groups administration... Still the same error...

So, it wasn't the language pack...

What now?



4
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:55

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Well, I did a local install with EasyPHP and without using the Dutch language pack. Everything works fine, even the groups administration. So, you're probably right, the error is probably related to the Dutch language pack... I'll do some more testing and a fresh (remote server) install without the language pack.



5
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:30

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Server generated.

In the installation guide it says to change the permissions on the folders upload, cache and templates_c and on the file mainfile.php. Nothing on /modules/system directories, and /modules/system/admin.php file in the installation guide... should I change permissions on this?

Firewall = ZoneAlarm. I have the same error when the firewall is disabled, btw...

Xoops is on remote server (never had problems there, used it before for Invision Board, Nucleus, etc...)

Default install? Well, yes and no... Did everything according to the instructions in the install guide, except from uploading (and installing) the Dutch language pack...



6
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 12:16

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Xoops: 2.0.7.3
PHP: 4.3.9
MySQL: 4.0.22-standard-log

I should mention that I uploaded the DUTCH language pack before installing (so I could choose dutch during installation). Strange thing is that everything else works fine. It's just the groups-module.



7
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:52

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


I do have a softwarefirewall. But the problem stays, even if I disable it.

All the files are uploaded. Permissions are set as mentioned in the installation guide.



8
guineapig
You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 11:29

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


My installation went fine and everything seems to be ok. However, when I log on as administrator and I click on the link that is supposed to take me to the page to configure groups, I get:

You don't have permission to access /modules/system/admin.php on this server.

Any ideas? Should I change some permissions? All the other administrator pages seem to work...




TopTop



Login

Who's Online

268 user(s) are online (223 user(s) are browsing Support Forums)


Members: 0


Guests: 268


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits