11
JMorris
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/13 15:23

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


Well, since the error is generated by the server and not Xoops, I'm inclined to believe that there is a file permission problem somewhere. You've eliminated XOOPS as the cause by installing a fresh default copy + you said the *server* is giving you the access error.

Really, the only thing that is left to do, IMHO, is go through the affected directories and files one at a time and check to be sure the permissions are set properly. The FAQ article Here gives a very clear explaination of how you should set the file and folder permissions.

Sorry, but I don't know of any other cause for a server access denied error other than file permissions or an .htacess setting. It's highly unlikely that your host is denying access to /modules/system/admin.php, so it stands to reason that it's a file permission problem.

Maybe someone else has an idea?

12
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 8:19

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Ok, here's what I've tried in the meantime...
I do have some experience with LAMP and I've installed many blogs, bulletin boards, etc... So...

I checked all the permissions, I can see nothing irregular there. (I have a local install to compare with).
I checked the database tables, no difference between local and remote db.
I tried to re-upload XOOPS and reïnstall. I even tried to upload parts of it (ex.: the modules folder...)
I chmod-ed everything under admin folder to 777.
Nothing gets the group-management module working.
I tried uploading everything and reïnstalling under a different folder (not in the roorfolder) with a new database. Again, I cannot access the group administration.

I'm running out of ideas here. Anyone?

I'd really like to get this working. I don't feel like searching for another system as it's working fine for my local install.

13
irmtfan
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 10:43

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


i think the only way remains for you is pm to one of the "Officail XOOPS Community Supporter" and give all permissions (ftp/cpanel).maybe the problem solved

14
JMorris
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 13:40

  • JMorris

  • XOOPS is my life!

  • Posts: 2722

  • Since: 2004/4/11


Quote:

irmtfan wrote:
i think the only way remains for you is pm to one of the "Officail XOOPS Community Supporter" and give all permissions (ftp/cpanel).maybe the problem solved


Agreed.

You may also want to check for .htaccess file permissions. You've done some great troubleshooting, but this one is certainly proving to be difficult.

Sorry I couldn't be more helpful.

15
guineapig
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/14 14:12

  • guineapig

  • Just popping in

  • Posts: 8

  • Since: 2004/12/13


Checked the .htaccess files. There was only one in my webspace (something to do with frontpage extensions, I don't us them...)

Only thing I'm not sure about is the possibility that this error could be linked to the php config of the server. Maybe the group management module does something that isn't allowed on the server...

Are there any parameters for php (in php.ini)that I should/could check?

16
waleed
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/19 23:27

  • waleed

  • Just popping in

  • Posts: 57

  • Since: 2004/4/1 5


Quote:

guineapig wrote:
Checked the .htaccess files. There was only one in my webspace (something to do with frontpage extensions, I don't us them...)

Only thing I'm not sure about is the possibility that this error could be linked to the php config of the server. Maybe the group management module does something that isn't allowed on the server...

Are there any parameters for php (in php.ini)that I should/could check?


Hi,
Is it fixed now? I'm having the same problem and really don't know what to do. Please let me know if you've manged to solve this issue. Thanks.

17
jmakovec
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/23 15:40

  • jmakovec

  • Just popping in

  • Posts: 5

  • Since: 2004/12/23


I'm also having the exact same problem. The funny thing is, it worked at one time. I haven't tried to use the Group admin feature in a while, but did yesterday and got the exact same error as original poster.



Installed a fresh copy of XOOPS on a subdomain and same problem. Group Admin feature won't work. I thought it might be similar to the problem that was mentioned on the main page about my host upgrading their PHP to version 4.3.10 (which they did, I checked the PHP version) and not upgrading Zend Optimizer so I sent a support ticket to them verifying this. I'll let you know the results when I find out from them.

Quote:

Forbidden
You don't have permission to access /modules/system/admin.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/1.3.33 Server at
Port 80

[/quote]

18
jmakovec
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/23 17:20

  • jmakovec

  • Just popping in

  • Posts: 5

  • Since: 2004/12/23


OK, my web host got back to me and said they upgraded their Zend Optimizer, but I'm still having the same problem so that isn't the cause like the other common error thats going around. Like I said earlier, what is strange is it used to work fine. I sent a reply back to my web host support asking them to look into it some more.

19
jmakovec
Re: You don't have permission to access /modules/system/admin.php on this server.
  • 2004/12/23 18:30

  • jmakovec

  • Just popping in

  • Posts: 5

  • Since: 2004/12/23


Problem Solved! Response from my web host:

Quote:
Sorry for the trouble. We had installed a software to block attack against the web-server which caused the trouble for you.We have tweaked that to allow the URL format. However the URL http:///modules/system/admin.php?fct=groups is not redirecting to http://
Can you please confirm this link should be working in other way.


From the response, I don't know if the "Groups" admin menu has a redirect problem that sets off this Security Software. But in my case, my web host took care of the problem.

20
mactoeknee
Re: You dont have permission to access /modules/system/admin.php on this server.
  • 2006/12/21 23:51

  • mactoeknee

  • Just popping in

  • Posts: 75

  • Since: 2005/2/26


I had a similar, but slightly different problem today on a new install of Xoops.

I can confirm to anyone who gets this error, check with your webhost-- mine told me that there was a security setting on the server which protected any directory named "system," which XOOPS uses. They turned that off, and it is now working perfectly.

I just wanted to follow up for those who search the forums for help. Happy Xoopsing.

Login

Who's Online

177 user(s) are online (130 user(s) are browsing Support Forums)


Members: 0


Guests: 177


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits