xoops forums

Forum Index


Board index » All Posts (phillipd)




phillipd

Quite a regular
Posted on: 2008/9/25 21:47
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#1

Upgraded from 2.0.7 rto 2.0.18.3, Forums don't work now

Is there a forum module upgrade for the original 1.0 Forums module? Is X-Forums that module? I'm trying not to lose my data. The 1.0 forums module doesn't work after the upgrade. I get a "Error: Forum not Selected" error when entering a forum.

Thanks

Doug P
......


phillipd

Quite a regular
Posted on: 2008/9/25 21:39
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#2

Re: Upgrading from 2.0.7 to 2.0.18

What would be the "Upgraded" module for the original 1.0 Forums module so I don't lose my data?

Doug P
......


phillipd

Quite a regular
Posted on: 2008/9/25 21:35
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#3

Re: Upgrading from 2.0.7 to 2.0.18

Thank you, the upgrade worked but I have lots of problems afterward. My forums don't work and several other modules are bad. I'll look for upgrades to thos modules I guess...

Doug P
......


phillipd

Quite a regular
Posted on: 2008/9/24 17:30
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#4

Upgrading from 2.0.7 to 2.0.18

I need to upgrade to 2.0.18 but don't see a path from 2.0.7. The earliest path I see is from 2.0.13 . Will running the upgrade scripts in 2.0.18 work for my old release?
......


phillipd

Quite a regular
Posted on: 2007/5/7 14:19
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#5

Re: Need help with LDAP authentication

Ah! Thank you so much for interacting with me here! Here is the deal, Are you familiar with the old LDAP hack in Xoops? It never required a password to interact with my OpenLDAP server. I would like to get exactly the same functionality with the officially supported LDAP auth. Here is what I needed with the LDAP hack to authenticate to my OpenLDAP:

var $uid_attr = "uid";
var $mail_attr = "mail";
var $name_attr = "cn";
var $surname_attr = "sn";
var $givenname_attr = "givenname";
var $location_attr = "l";
var $office_attr = "physicaldeliveryofficename";
var $ldap_server = "hq-net1.oem.doe.gov";
var $ldap_port = 389;
var $base_dn = "ou=People,dc=oem,dc=doe,dc=gov";

These are all I had to set. Is the new LDAP auth based on the old hack?

Also, what is your email address? Our mail server must be black holing you, Ill put it in my white list...

Thanks
Doug P
......


phillipd

Quite a regular
Posted on: 2007/5/3 15:53
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#6

Re: Need help with LDAP authentication

The Xoopspro site appears dead, or no one is watching for users requesting help. I've emailed pemen@frxoops.org but gotten no response.

How can I get some help with LDAP in 2.0.16? The LDAP hack used to work fine in 2.0.7. Should I put the hack back in 2.0.16? The problem is I recently took over this site and I can no longer find the LDAP hack the originator of the site used.

Thanks for any help

Regards

Doug P
......


phillipd

Quite a regular
Posted on: 2007/4/24 19:36
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#7

Re: Need help with LDAP authentication

I tried to subscribe to xoopspro but I never got a confirming email to activate my subscription. I can't try again because it says my email address is in use. I'm in limbo!


Doug P (Still no resolution to LDAP problems)
......


phillipd

Quite a regular
Posted on: 2007/4/11 17:41
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#8

Has anyone got LDAP working in 2.0.16?

I'm having a real problem making LDAP work in 2.0.16. Is anybody out there using this new authentication mechanism in Xoops?

thanks

Doug P
......


phillipd

Quite a regular
Posted on: 2007/4/11 17:27
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#9

Re: Need help with LDAP authentication

Is there a way to specify a "simple" query in the config? Also using TLS???

Doug P
......


phillipd

Quite a regular
Posted on: 2007/4/11 15:43
phillipd
phillipd (Show more)
Quite a regular
Posts: 219
Since: 2004/4/20
#10

Need help with LDAP authentication

Was using the ldap hack in 2.0.7 which worked. The new LDAP auth in 2.0.16 doesn't work. The result I get in the slapd log is:

Apr 11 12:16:07 hq-net1 slapd[638]: conn=55904 op=0 BIND dn="ou=People,dc=oem,dc=doe,dc=gov" method=128
Apr 11 12:16:07 hq-net1 slapd[638]: send_ldap_result: err=13 matched="" text="confidentiality required"
Apr 11 12:16:07 hq-net1 slapd[638]: conn=55904 op=0 RESULT tag=97 err=13 text=confidentiality required

Does "confidentiality required" infer some encryption is required?

The setup of the old LDAP hack did not require any password to search the DB. The new one gives me an error message if there is no password in the config? Why the difference?

Any help is greatly appreciated...

Doug P
......



TopTop
(1) 2 3 4 ... 22 »