"MySQL support: Not available"

I've successfully installed XOOPS on two servers at $DAY_JOB, and I want to migrate from Windows/Apache (no PHP/no MySQL) to LAMP at my own business. So, Friday night last week I started a setup, using Debian Sarge on a new machine.

First go-round, I used the base-config to choose Web server and Database server. I ended up with Apache2 and PostgreSQL, which are very nice but not what I wanted, so I re-ran base-config and removed them, then used apt to install Apache 1.3.something, PHP4, and MySQL. Everything *seemed* to work until I tried to access XOOPS in a browser. No results worth noting.

To shorten a long tale of woe, I flatlined and reinstalled everything several times over the weekend, using both apt and source builds, without success. Finally, in desperation, I tried Mambo server, and it informed me that mySQL support is "not available."

So I started over again (and again... And again...) with the same (non-)results.

Telephoned my son, the linux guru, in Albuquerque (I *knew* I should have made that left turn!) and discovered that this is a common problem. Apparently, there's a line in php.ini that may be commented out by default, or not, depending on the mood of the package maintainer, or the phase of the moon, or something.

Look for the following line and make sure it's *not* commented out if you want your XOOPS installation to work:



Ben Jenkins
21-Dec-2004 10:23
This took me all day to figure out, so I hope posting it here saves someone some time:
Your PHP-CLI may have a different php.ini than your apache-php. For example: On my Debian-based system, I discovered I have /etc/php4/apache/php.ini and /etc/php4/cli/php.ini
If you want MySQL support in the CLI, make sure the line
is not commented out.
The differences in php.ini files may also be why some scripts will work when called through a web browser, but will not work when called via the command line.

(Reference: PHP's official forums)

Re: Document Management System (DMS) and Swish


rifraff wrote:
Ok, try upgrading to version 0.98 and go to the DMS Configuration/Search Configuration screen and click on the "Write Configuration Files" button.

Yep, did that before the last post.

Then, go to the repository directory and execute "swish-e -c swish-e.conf". See if that works.

The data is there, but it's not being displayed. If I comment out enough of the "if" statements, I can get a raw list of documents; it's just not printing the "massaged" data.

Also, what version of SWISH-E are you using? It is possible that they changed the format of the output enough to break compatibility.

It's 2.4.3


Re: Document Management System (DMS) and Swish


rifraff wrote:

MorelyDotes wrote:
how can I set permissions for the results? I don't see anything in the administration section for the module, nor in blocks.

By results, I am assuming that you are refering to having the permissions automatically change depending which lifecycle stage the document is in?

Actually, no. I am getting a blank list of documents, even though the degugger says there are 36 hits. Since I don't understand the code that is (presumably) supposed to generate the list of documents, I can't figure out what I need to change to make it possible to see the results.

We haven't implemented lifecycles yet, and ATM it's a much lower priority than being able to find a given document easily with a full-text search.

Re: Document Management System (DMS) and Swish

Thanks much to both peekay and Brain. I have a company meeting in about 20 minutes at which I wil lbe able to demonstrate the level of support for this module specifically, and XOOPS in general, because of you guys!

I forgot to ask - how can I set permissions for the results? I don't see anything in the administration section for the module, nor in blocks.

Re: Document Management System (DMS) and Swish


rifraff wrote:
The next release (0.98) will create both the _binfilter.sh and swish-e.conf files for you. I hope to be releasing the next version tomorrow.

I look forward to that.

However, I still have the problem of a lack of printed results. I uncommented the line (somewhere around line 171) in search_ft.php which prints the number of results retrieved, but there are still no actual results listed below the "Document(s) - Version" header.

Is there something I can do to fix this? I don't understand enough PHP yet to find the problem myself.

Incidentally, except for this (and the total lack of "lifecycles" definitions that make any sense to me), this module is ideal for my company's need to manage documents.

Re: Document Management System (DMS) and Swish

Right, I've done all that, and the index.swish-e that's generated is about 3 megabytes in size. However, when I do a full-text search, I either get "no results" or the headers for a document list with no documents listed in it.

Obviously, I'm doing somethign wrong - but what?

Re: Document Management System (DMS) and Swish

Sorry, duplicate post caused by the "back" button.

« 1 ... 4 5 6 (7)


Who's Online

168 user(s) are online (45 user(s) are browsing Support Forums)

Members: 0

Guests: 168



Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits