21
Hasanibrahim
Re: Hello / SmartFaq

i have fixed some of questions, there were some spam message i think. But now;

When i try to enter as a guest or as a user to smartfaq, there is nothihg wrong. But after i login as admin, i'm getting this error:

Fatal error: Call to a member function setVar() on a non-object in /home/X/public_html/X.com/modules/smartfaq/index.php on line 137



22
Hasanibrahim
Re: contact module with customizable to address?

I advice using liaise module.



23
Hasanibrahim
Re: Hello / SmartFaq

Mamba, i have inactivated all blocks on smartfaq page. but yet it's blank page. I have deleted some of questions, too. but it didn't work.

i have avtivated debugging on. But it's not working (because it's blank :) )

Also only smartfaq/index.php is problem. For eexample when i try to enter smartfaq/faq.php?faqid=38 or any id number, page is opening clearly



24
Hasanibrahim
Re: Hello / SmartFaq

I'm now uploading SmartObject Framework 1.0.1 Final. I hope it will fix it..



25
Hasanibrahim
Re: Hello / SmartFaq

i will install it but i'm confused about this "White Page". only modules/smartfaq/index.php has a blank page after i accept a question from a visitor.




26
Hasanibrahim
Hello / SmartFaq

Hello all, my smartfaq module has been completely white page. (only index.php)

My SmartFaq module version is 1.08 and xoops version is 2.3.3.

Thank you




27
Hasanibrahim
Re: SmartFAQ Problem & bug

The answer is below. If somebody get this problem, he/she need to hack open_index.php on 167 line.

Thank you very much @myboyden

Quote:
Don't know what's causing those notices.

Just ran into this one: Fatal error: Cannot use object of type sfCategory as array in D:\XAMPP\xampp\htdocs\impresscmsfinal\modules\smartfaq\open_index.php on line 167

I replaced in open_index.php

$xoopsTpl->assign('xoops_pagetitle', $module_name . ' - ' . $category['name']);


by

$xoopsTpl->assign('xoops_pagetitle', $module_name . ' - ' . _MD_SF_OPENED_QUESTIONS);





28
Hasanibrahim
Re: SmartFAQ Problem & bug

$xoopsTpl->assign('xoops_pagetitle'$module_name ' - ' $category['name']);


This is open_index.php , line 167



29
Hasanibrahim
Re: SmartFAQ Problem & bug

Fatal error: Cannot use object of type sfCategory as array in /home/XXX/public_html/XXX.com/modules/smartfaq/open_index.php on line 167
None All errors (200) queries (61) blocks (8) extra (2) timers (5)
Errors
Notice: Undefined index: gallery in file /class/module.textsanitizer.php line 184
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in file /class/module.textsanitizer.php line 422

Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 665
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in file /class/module.textsanitizer.php line 422



30
Hasanibrahim
SmartFAQ Problem & bug

hello, i am using smartfaq modules (last version on xoops.org). and i am using xoops 2.3.3.

when i try to enter smartfaq/open_index.php There is a blank page nothing is loading. What's the possible cause do you think ?




TopTop
« 1 2 (3) 4 5 6 ... 8 »



Login

Who's Online

53 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 53


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits