1
Hasanibrahim
SmartFAQ Problem & bug

hello, i am using smartfaq modules (last version on xoops.org). and i am using xoops 2.3.3.

when i try to enter smartfaq/open_index.php There is a blank page nothing is loading. What's the possible cause do you think ?

2
Burning
Re: SmartFAQ Problem & bug
  • 2010/4/13 20:09

  • Burning

  • Theme Designer

  • Posts: 1163

  • Since: 2006/8/22


hi'

You should enable Debug mode (General settings) and post Errors here.

3
Hasanibrahim
Re: SmartFAQ Problem & bug

Fatal error: Cannot use object of type sfCategory as array in /home/XXX/public_html/XXX.com/modules/smartfaq/open_index.php on line 167
None All errors (200) queries (61) blocks (8) extra (2) timers (5)
Errors
Notice: Undefined index: gallery in file /class/module.textsanitizer.php line 184
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in file /class/module.textsanitizer.php line 422

Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 665
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in file /class/module.textsanitizer.php line 422

4
Hasanibrahim
Re: SmartFAQ Problem & bug

$xoopsTpl->assign('xoops_pagetitle'$module_name ' - ' $category['name']);


This is open_index.php , line 167

5
mboyden
Re: SmartFAQ Problem & bug
  • 2010/4/15 14:46

  • mboyden

  • Moderator

  • Posts: 484

  • Since: 2005/3/9 1


Not sure this will help, but it might. Went to SmartFactory's site and then went to their forums (now on the site of a XOOPS fork) and found a related post.

Maybe that helps.
Pessimists see difficulty in opportunity; Optimists see opportunity in difficulty. --W Churchill

XOOPS: Latest | Debug | Hosting and Web Development

6
Hasanibrahim
Re: SmartFAQ Problem & bug

The answer is below. If somebody get this problem, he/she need to hack open_index.php on 167 line.

Thank you very much @myboyden

Quote:
Don't know what's causing those notices.

Just ran into this one: Fatal error: Cannot use object of type sfCategory as array in D:\XAMPP\xampp\htdocs\impresscmsfinal\modules\smartfaq\open_index.php on line 167

I replaced in open_index.php

$xoopsTpl->assign('xoops_pagetitle', $module_name . ' - ' . $category['name']);


by

$xoopsTpl->assign('xoops_pagetitle', $module_name . ' - ' . _MD_SF_OPENED_QUESTIONS);



Login

Who's Online

64 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 64


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits