21
jdseymour
Problem with view account page

When I am logged onto my site and I click the view account link on my home page I get just a blank page with a 1 in the upper left hand corner. If I enable debug mode (looking for an error) all I get is a completely blank page. Not sure how long I have been having this problem. I am running XOOPS 2.4.3 now. Apache 2.2 - php 5.2.10 - MySQL 5.0.81

Any idea what I can look for to fix this?



22
jdseymour
Re: New to XOOPS - Need Help Installing

Although these tutorials were made with XOOPS 2.0x - the method of installation is still the same (I will get around to updating them when I get the time).

http://www.warpigw2.com/modules/smartsection/category.php?categoryid=1

See if they can help you.



23
jdseymour
Re: Moving a site, keeps logging out

Just looked over the last page here, so sorry if already mentioned. One of the biggest problem causing things when moving a site is also moving the cached files in the xoops_data, templates_c and cache folders. Make sure you clear all these out either when moving or right after transferring files to the new site.



24
jdseymour
Re: Permissions

File and folder permissions of 777 is an issue with security. However, some server setups require it for a CMS with any kind of cache to run.

A properly setup server should allow it to run at 755 or at the very least 775. The files and folders should be owned by the user the web server runs as.

The numbers stand for:

7 - read, write and execute
5 - read and execute
4 - read only

The order of the numbers mean:

7/7/7

Owner/Group/Other

The other in the above is anyone in the world. Not a good idea to give them write access to your site.

If the owner of the files is the one that the web server runs as, and the group ownership is the group that the web server user runs as it will work with 775.

If the files are owned by, for instance, root, and the server runs as apache 775 will not work as the apache user would need the "Other" permissions to write and with 775 "Other" only has read and execute.

Most servers now use suEXEC. This allows apache to run as different users on different virtual host accounts, usually under the username of the owner of the account.

Ask your host for more detail in setting the permissions on your site.



25
jdseymour
Re: Problem with Protector

Trabis, your great. That fixed it. Did I miss that documented somewhere?



26
jdseymour
Re: Problem with Protector

Thanks Trabis,

I just deleted everything in the class/database folder. I still have the same error (blank page with the fatal error). I am using files from the 2.4 tar.gz archive - if that helps.

Any other ideas? The rest of protector works fine, this is just on the security advisory tab.



27
jdseymour
Re: Problem with Protector

That is what I have installed, but I still have this error.

Should I uninstall it and reinstall?



28
jdseymour
Re: Problem with Protector

Thanks Burning,

Perhaps, since this module is included with the core, the patch should be included also.



29
jdseymour
Problem with Protector

Hello All,

My XOOPS 3.4 upgrade whent quite smoothly. All seems to be working properly except one problem I found with protector module. When I access the security advisory tab I get:

Fatal error: Class 'XoopsDatabaseFactory' not found in /home/xxxx/xxxx/xxxx/public_html/class/database/database.php on line 127


Also inline debug mode shows 69 errors (well warnings) most to do with protector. I redownloaded and uploaded to make sure all files were good.

My server is:

Apache 2.2
php 5.2.10
mysql 5.0.81
CentOS 5.4



30
jdseymour
Re: hacked sites and file permissions

644 which is -rw-r--r-- is the correct permissions for files. Only the owner of the files have write permissions, and the owner should be the user that the server runs as (usually apache). If the server itself runs suphp then the owner should be the owner of the home directory the files reside.

755 is definately not right for file level permissions (however still does not allow write for group or others). I think I reported this at one time as another forum post.

mainfile.php should be 444.




TopTop
« 1 2 (3) 4 5 6 ... 330 »



Login

Who's Online

82 user(s) are online (53 user(s) are browsing Support Forums)


Members: 0


Guests: 82


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits