XOOPS: XOOPS 2.0.5 Released!

Posted by: onokazuon 2003/10/8 13:23:00 7471 reads XOOPS Team is pleased to announce the release of XOOPS 2.0.5. XOOPS 2.0.5 is a bug-fix release fixing a few critical issues in XOOPS 2.0.4, as well as some other minor bug fixes and changes.

Changes
========
- Fixed template files not being updated even when the 'allow update from themes directory' option was enabled in preferences
- Fixed RSS channel title being cutoff at special characters
- Minor bug fix in pagenav.php
- Fixed blocks disappearing from the block admin page on certain occasion
- Additional fixes to work with register_globals off
- Fixed problem with XoopsCode Img button not working on certain occasion
- Added missing SQL query in kernel/avatar.php
- Fixed problem with the newbb module where users could post without a thread title on certain occasion
- Fixed problem in banner admin page where banner edit form not being displayed on certain occasion
- Fixed group selection option in the blocks admin page not being selected on certain occasion
- Fixed poll option textbox forms not displaying the correct values
- Fixed show all link in user profile page not working in 2.0.5RC
- Additional phrases in language/english/global.php(_NOTITLE), language/english/search.php(_SR_IGNOREDWORDS), modules/system/language/english/admin/blocksadmin.php(_AM_UNASSIGNED), install/language/english/install.php(_INSTALL_L128, _INSTALL_L200)
- Added check in install/index.php to read $HTTP_ACCEPT_LANGUAGE on initial load

Lang file changes
========
- /language/english/global.php
- /language/english/search.php
- /install/language/english/install.php

Requirements
========
PHP 4.1.0 or later (on IIS, 4.3.1 or later)
MySQL 3.23.xx or later

Install
========
Download the full package, unpack it and upload all files included. Point your browser to /install/index.php to start the installer. Please read docs/INSTALL.html for details on installation and/or read the Install and Upgrade sections of the Wiki ( http://wiki.xoops.org ).

Upgrade
========
Upgrade from XOOPS 2.0.4/2.0.5RC
1. From the download page, download XOOPS 2.0.4 »» 2.0.5 Patch and upload all files included (files will be overwritten).

Upgrade from XOOPS 2.0.3
1. From the download page, download XOOPS 2.0.3 »» 2.0.5 Patch which includes both 2.0.3-2.0.4 and 2.0.4-2.0.5 patches and upload all files included (files will be overwritten).

Upgrade from XOOPS 2.0.2
1. From the download page, download XOOPS 2.0.2 »» 2.0.3 Patch and upload all files included (files will be overwritten).
2. Now that you have upgraded to 2.0.3, follow the upgrade instruction above for XOOPS 2.0.3.

Upgrade from XOOPS 2.0.1
1. From the download page, download XOOPS 2.0.1 »» 2.0.2 Patch and upload all files included (files will be overwritten).
2. Now that you have upgraded to 2.0.2, follow the upgrade instruction above for XOOPS 2.0.2.

Upgrade from XOOPS 2.0.0
1. From the download page, download XOOPS 2.0.0 »» 2.0.1 Patch and upload all files included (files will be overwritten).
2. Point your browser to http://path_to_xoops/upgrade/xoops2_0_to_2_0_1.php and follow the instruction displayed.
3. Now that you have upgraded to 2.0.1, follow the upgrade instruction above for XOOPS 2.0.1.

Upgrade from XOOPS 2.0 RC3
1. From the download page, download XOOPS 2.0 RC3 »» 2.0.0 Patch and upload all files included (files will be overwritten).
2. You have now upgraded to 2.0.0. Follow the upgrade instruction above for XOOPS 2.0.0.

Upgrade from XOOPS 2.0 RC2
1. Read this article and upgrade to XOOPS 2.0 RC3 first. Then follow the upgrade instruction above for XOOPS 2.0 RC3.

Upgrade from XOOPS 1.3.x
1. Download the full package, unpack it and upload all files included (some files will be overwritten).
2. Point your browser to /install/index.php to start the installer. The installer will automatically detect your 1.3.x and upgrade to 2.0.4. Please read docs/INSTALL.html for details on installation and/or read the Install and Upgrade sections of the Wiki (wiki.xoops.org).

Language
========
Language files can be (or will be) downloaded from the SourceForge site or our partner sites.