xoops forums

GlemBell

Just popping in
Posted on: 11/11 18:20
GlemBell
GlemBell (Show more)
Just popping in
Posts: 5
Since: 11/5 11:16
#1

Error in animal pedigree software Error : Handler does not exist

Hello. I have an issue and need help:

I am first time XOOPS user, just installed the XOOPS and put the Pedigree module in it. First time, without modification and nothing. I get the following error:

A problem has occurred on our server!

Page is currently unavailable

We are working on a fix
Please come back soon ...

Error : Handler does not exist
Module: pedigree-master
Name: trash


I have XOOPS 2.5.9
My module is the totally newest updated version: 1.31 Alpha 6
PHP version 7.2.10 (trough wamp server)

How to solve this problem? Thank you!!

geekwright

Quite a regular
Posted on: 11/12 2:18
geekwright
geekwright (Show more)
Quite a regular
Posts: 251
Since: 2010/10/15
#2

Re: Error in animal pedigree software Error : Handler does not exist

I suspect the clue is in the module name, "pedigree-master".

That is the name GitHub assigns to the download, and unfortunately it is wrong. The directory name for the module should be just "pedigree".

- Uninstall the module pedigree-master
- Rename the directory from pedigree-master to pedigree
- Install the module pedigree

That should solve the issue. Mamba is the expert on pedigree, and I'm sure he will chime if there are any further issues..

Mamba

Moderator
Posted on: 11/12 2:36
Mamba
Mamba (Show more)
Moderator
Posts: 10631
Since: 2004/4/23
#3

Re: Error in animal pedigree software Error : Handler does not exist

renaming the "pedigree-master" folder to "pedigree" would be the first step.

If there are still problems, please let us know.

FYI - I am working on an small update, but it is a very slow process, due to time constraints
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

GlemBell

Just popping in
Posted on: 11/14 21:53
GlemBell
GlemBell (Show more)
Just popping in
Posts: 5
Since: 11/5 11:16
#4

Re: Error in animal pedigree software Error : Handler does not exist

Thank you. It solved the problem!