xoops forums

Mamba

Moderator
Posted on: 2016/1/6 17:55
Mamba
Mamba (Show more)
Moderator
Posts: 10406
Since: 2004/4/23
#1

About Us 1.04 Beta 1 released for testing

Resized Image

The "About" module is for adding "About Us" section to your Website. It allows adding a multi-page section, as well as external links.

It was originally developed by Susheng Yang (ezsky) and Mengjue Shao (magic.shao).

It is a simple module, but it could be quite useful, since it is very easy to use.

REQUIREMENTS:

- PHP 5.5+ (the new official minimum PHP version for XOOPS. It might work on PHP 5.3.7+, but we don't test anymore on it)

- XOOPS 2.5.8 (if you don't have it, you should start testing your modules on in TODAY)


DOWNLOAD: About repository on GitHub


CONTRIBUTING: please fork About module on GitHub and submit your improvements there


BUGS/ISSUES:GitHub Issues


Resized Image

TUTORIAL: Available on GitBooks. It is in the early stages, and we need your help to make useful

To help, you can fork the Tutorial from GitHub and provide you submissions there

To check out other XOOPS Tutorials, please visit XOOPS section on GitBooks

Happy Xoopsing and May the Source be with You!
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

Zap_English

Quite a regular
Posted on: 2016/5/30 19:44
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 343
Since: 2016/5/24
#2

Re: About Us 1.04 Beta 1 released for testing

Is there a version of this that will run on 2.5.7.2?

I know this post says it will, but when you install it, it says it requires 2.5.8

zyspec

Module Developer
Posted on: 2016/5/30 20:46
zyspec
zyspec (Show more)
Module Developer
Posts: 1016
Since: 2004/9/21
#3

Re: About Us 1.04 Beta 1 released for testing

Zap_English,

Here's a duplicate of the comment I posted in reply to to your comment on the About module news release....
Quote:

I looked over the latest changes on github and although the module now claims it requires 2.5.8 there were no changes made that actually require 2.5.8. At this point (ver 1.04 RC 1) will run on 2.5.7.2 as well.

Just be forewarned that future revisions of the About module may not work on 2.5.7.x - but for now all that will happen is that the module "screams at you" that it needs 2.5.8.

Mamba

Moderator
Posted on: 2016/5/31 0:17
Mamba
Mamba (Show more)
Moderator
Posts: 10406
Since: 2004/4/23
#4

Re: About Us 1.04 Beta 1 released for testing

Quote:
I looked over the latest changes on github and although the module now claims it requires 2.5.8 there were no changes made that actually require 2.5.8. At this point (ver 1.04 RC 1) will run on 2.5.7.2 as well.

All the modules that I am working on, will "scream" to use XOOPS 2.5.8 and PHP 5.5+

We need to test all of them on XOOPS 2.5.8 to make sure that both the modules and XOOPS 2.5.8 work well together on the current PHP versions. Due to very limited time, I won't be able to test any modules on older versions of XOOPS. However, if somebody wants to do it, and fix any potential issues related to an older version, then please free to do it.

In the future, we'll add a checker at each module installation, that will fail if we try to install a "2.5.8" module on an older version of XOOPS. This way we'll avoid user confusion and disappointments.

IMHO we need to focus our very limited resources on making sure that XOOPS 2.5.8, which runs on the latest version of PHP (i.e. PHP 7) is as solid as possible, and we have all key modules running on it without any problems ASAP.
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs