1
voltan
report content module bug
  • 2011/2/27 8:19

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


Please report new version of content module bug:

more info at here : https://xoops.org/modules/news/article.php?storyid=5819

2
tatane
Re: report content module bug
  • 2011/2/27 9:17

  • tatane

  • Just can't stay away

  • Posts: 649

  • Since: 2008/5/6 1


What should we add. htaccess to activate the url rewtring? because is not file extra or readme

3
voltan
Re: report content module bug
  • 2011/2/27 16:59

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


I don't have this module .htaccess . I hope one person can send it for us

4
Mamba
Re: report content module bug
  • 2011/2/28 5:31

  • Mamba

  • Moderator

  • Posts: 11245

  • Since: 2004/4/23


I have updated the ForContent to the "XOOPS Standard Module GUI".

Please download it from here

There is a difference between the "Help" screen here, and the one I used in the other recently updated modules (like the XoopsPoll)

Which one should we use?

Can somebody come up with something better?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

5
Mamba
Re: report content module bug
  • 2011/2/28 5:48

  • Mamba

  • Moderator

  • Posts: 11245

  • Since: 2004/4/23


There are following errors when installing:

Quote:
Notice: Undefined variable: reservedTables in file /xoops_lib/modules/forcontent/admin/action.module.php line 75
Warning: in_array() expects parameter 2 to be array, null given in file /xoops_lib/modules/forcontent/admin/action.module.php line 75

The code is:

// check if the table name is reserved
if (!in_array($prefixed_query[4], $reservedTables)) {
// not reserved, so try to create one


I am not sure where the "reservedTables" should be defined. Anybody has any idea?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

6
voltan
Re: report content module bug
  • 2011/2/28 14:17

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


I add some changes in module templates . any one can help us to test?

7
pacho
Re: report content module bug
  • 2011/3/1 23:19

  • pacho

  • Quite a regular

  • Posts: 235

  • Since: 2005/6/7 2


Great job! Congrats.

Some basic tests I made:
* Using Xoops 2.5.0
* editor used tinymce, no problem
* Choose friendly url mode = Standard Mode, very simple but useful
* Choose friendly url mode = Rewrite mode, do not work, expecting htaccess file but does not exist
* Metas Keywords and Metas Description, would be great if the module can generate them from short text.
* edit in place, just wow
When I use edit in place with tinymce editor, and click Ok, the result content do not display images but " instead.
Internally the content is updated sucessfully because I refresh the page and content shows updated.

Some typos
In preferences form:
Image upload pach -> Image upload path
Image upload pach for upload content images -> Upload path for images content
You can use Social network and bookmark icone for ecah content -> You can use Social network and bookmark icons for each content

In Topic form:
Columes* -> Columns*

8
zyspec
Re: report content module bug
  • 2011/3/2 15:37

  • zyspec

  • Module Developer

  • Posts: 1093

  • Since: 2004/9/21


Mamba,

Looks to me like $reservedTables just needs to be defined near the top of the file. It should be an array with the XOOPS core tables defined in ./install/sql/mysql.structure.sql as the values. Something like:
$reservedTables = array('avatar',
                        
'avatar_user_link',
                        
'banner',
                        
'bannerclient',
                        
'bannerfinish',
                        ... );

9
voltan
Re: report content module bug
  • 2011/3/3 7:00

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


@pacho
thank you for test module . I change language files .

I don't have htaccess for Rewrite mode . perhaps Nicolas snd it for me .

10
voltan
Re: report content module bug
  • 2011/3/4 9:34

  • voltan

  • Theme Designer

  • Posts: 724

  • Since: 2006/12/5


Nicolas send for me .htaccess and I add it to module in modules/forcontent/docs/

please test

Login

Username:
Password:

Lost Password? Register now!

Who's Online

56 user(s) are online (29 user(s) are browsing Support Forums)


Members: 0


Guests: 56


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits