1
par14h
Current version of Frameworks
  • 2010/8/22 14:48

  • par14h

  • Just popping in

  • Posts: 41

  • Since: 2010/2/24


I know there's a massive discussion dated for August about the inclusion of a universal Frameworks for Xoops in the Dev Forums, and I've real them all, and there's about a gajillion references to the word "Framework" throughout the forums. I just have a simple question:

What is the current version of Frameworks? I have the version that came with my xoops install, I have one that is packaged as 1.22, one that is packaged as frameworks-art, and one that is packed as 1.60 (currently installed on my site in the xoops root directory). In the module repository, I see modules such as x-Forums 5.46 which lists a certain version of Frameworks as a prerequisite for operability, and forum posts for modules like cbb that mention frameworks, but don't tell me what version to be using.

All that being said, can someone please either tell me what version I should be using and where can it be downloaded, or who do I find out what version I need for my site and where to get it?

I swear, I need to learn to read and program in php so I can understand half of these forums.

2
ghia
Re: Current version of Frameworks
  • 2010/8/22 18:19

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


In the early days there was no Frameworks included in the XOOPS core and modules dating from that time specify to download a Frameworks archive.
As is the case for NewBB/CBB 3.08. For this module there is no need anymore to do that. As from XOOPS 2,3.x and later, all you need is already included.

I'm not sure for xForms, but I assume that this would also run with what is standard provided.
Try to install it and when you get some messages (set debug on) as can't include /Frameworks/xxxx/yyy.php etc, then you are missing something.

In case of installing a later version of Frameworks, upload only the missing directories. Avoid to overwrite the standard Frameworks directories that came with your XOOPS.

3
redheadedrod
Re: Current version of Frameworks

To answer your question 1.22 is the latest frameworks and should be available online here in the repository.

And to the generic/universal framework. It will be a while. I am going through some documentation right now trying to get that sorted out.

My understanding is if you are running 2.4.x or newer I wouldn't replace the directories with what is in 1.22. Older then you may need to. Not sure when 1.22 came into being.

But last time I looked I don't think all of the framework came with the 2.4.5 that I have so if your program required the whole 1.22 framework you may have to install portions of it. But as Ghia said.. I wouldn't install anything unless you see a problem.

Attending College working towards Bachelors in Software Engineering and Network Security.

Login

Who's Online

57 user(s) are online (26 user(s) are browsing Support Forums)


Members: 0


Guests: 57


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits