1
antifmradio
importing database info from 2.18 to 2.3.x

I have CBB installed on XOOPS 2.3.x
i already had it running on XOOPS 2.18

can i import the database info
(Posts, attachments, etc)
from 2.18 into the new empty 2.3.x ?

If i do this, ill probably have to move all the attached files from
xoopsroot/uploads/newbb/
into the new root location of
xoopsroot/NEW_FOLDER/uploads/newbb/
so attachements can actually show up and such

Plus ill probably need to get all my USERS
and import them to the new DATABASE tables as well right?

well there is my querry and im sure its a long winded on ( or it can be )

Im basically trying to import XOOPS 2.18 info
into XOOPS 2.3.x

I want to see if its going to work
befure completely just trying to upgrade the entire site

2
ghia
Re: importing database info from 2.18 to 2.3.x
  • 2009/10/24 22:29

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


(After the users table, there are also the permissions, preferences, notifications, ...)

Why so complicated?
Restore your entire site to your local PC.
Do the upgrade to 2.3.3 as described in the release notes.
Done!


3
antifmradio
Re: importing database info from 2.18 to 2.3.x

but wouldnt i loose message board comments
and replies on other modules as well?

Also, for example
if there are modules im using which are NOT computable
(PDdownloads for example)
id loose all the content from them as well no?

which brings up a different question that doesn't need to be answered here unless you know the answer

i need a module built for allowing ONE uer group to add downloads to the site
and the other visitors to go in an download things

Since i currently use PDdownloads
that wont work with XOOPS 2.3.3
but what would?


4
antifmradio
Re: importing database info from 2.18 to 2.3.x

other reason i asked is
is there a method easy enough to roll back the website if i cant get things working the way i need?

5
ghia
Re: importing database info from 2.18 to 2.3.x
  • 2009/10/24 23:23

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


Quote:
but wouldnt i loose message board comments
and replies on other modules as well?
No, because you restore and use the entire site (= files + database).
Quote:
Also, for example
if there are modules im using which are NOT computable
(PDdownloads for example)
id loose all the content from them as well no?
Are you sure it is not compatible?
Most problems with older modules arise from being not compatible with the latest PHP or MySQL version or their current settings.
If it is not, deinstall the module before upgrade.
Quote:
which brings up a different question that doesn't need to be answered here unless you know the answer
i need a module built for allowing ONE uer group to add downloads to the site
and the other visitors to go in an download things
I don't know, but assumed all download modules could do that by setting the category permissions.
Quote:
other reason i asked is
is there a method easy enough to roll back the website if i cant get things working the way i need?

Best is to test it on a local PC with eg XAMPP.
On the server you can roll back the upgrade by restoring the site with your backup.

6
antifmradio
Re: importing database info from 2.18 to 2.3.x

well this didnt work at all for me hhahahhahahah
i have NO idea what went wrong

i did as instructed in the steps

-----------------------
7. Access /upgrade/ with a browser, and follow the instructions
8. Follow the instructions to update your database
------------------------------

but there are no instructions to follow because the entire page is blank white
and im on a URL ending with
"www.SITEURL.com/ XOOPS ROOT / user.php?op=login "



WHen i goto do the upgrade it asks for a USERNAME + PASSWORD
but which is it looking for?
My administrative one for use on the site?
Just to ensure i am who i am?

7
antifmradio
Re: importing database info from 2.18 to 2.3.x

incause it comes up late in question

i wanted to test it so i copied all the files from my current LIVE site
to a sub directory
This way i can work on things without anyone knowing or being disturbed

ok so the files are copied EXACTLY as the main direectory

I also went ot MAINFILE.php and made the proper path changes there to include the sub directory

... and now.....
then i went to the copied site location and all shows up correctly as OLD 2.0.18

Now i uploaded the 2.3.3 files over the sub directory files
i included the /UPGRADE/ folder as instructed
checked the write permissions on mainfile.php
then i went to the UPGRADE directory as instructed
it asked for log in details
i used my common ones
click GO
and the page is blank white

8
ghia
Re: importing database info from 2.18 to 2.3.x
  • 2009/10/25 15:20

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


Did you create a copy of your database, or are you using the same credentials in /test/mainfile.php as in the site its manifile.php?
If the latter is the case, you are modifying your 2.0.18 database, which may stop the main site from working.

On the test site clear the cache and template_c directory.

9
antifmradio
Re: importing database info from 2.18 to 2.3.x

ok i got past the white screen
i found out what was going wrong
i wasnt click the final NEXT button but instead clicking the
VIEW YOUR WEBSITE HERE link

ok.... i have all my modules installed (almost anyway )
but i hit a snag

im attempting to use the YOGURT module
but of course i need to have FRAMEWORKS installed for it

Ok im not looking for help with Yogurt
but i do have a problem with the FRAMEWORKS module

i see FRAMEWORKS is already in my package for XOOPS
and i see the error telling me its NOT installed

WOW strange cause its not sitting anywhere saying its uninstalled

ok so i downloaded a fresh copy
looks lke the one i have

then i went to my OLD XOOPS 2.0.18 version
i see FRAMEWORKS has other files in it
quite a lot of other files

i took that one out of my old xoops
uploaded it to my NEW XOOPS 2.3.3
and then tried to goto my homepage

i see this message

Fatal error: Class 'XoopsLocal' not found in /home/virtual/antifm/public_html/world2/modules/newbb/include/functions.ini.php on line 145


ok so i wanted to check out the file at that location but
that location does NOT exsit
not in my OLD or NEW version of frameworks
nor does it exist in my CBB module

but the CBB mod works when i DONT have Frameworks installed


what the story here?

10
antifmradio
Re: importing database info from 2.18 to 2.3.x

ok i removed the framework folder
now i cant even get to the admin section

i think this is why i didnt go with the latest version of XOOPS a while ago

A) i cant get yogurt to work on it and it had become a large part of the website

b) error locking me out of admin section after hours of work

C) a few more hours of work and no one replied to my help message of getting me back in

d) few days went by and the site was still offline with no help

Login

Username:
Password:

Lost Password? Register now!

Who's Online

54 user(s) are online (30 user(s) are browsing Support Forums)


Members: 0


Guests: 54


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits