xoops forums

MikeShane

Community Support Member
Posted on: 2008/1/11 0:15
MikeShane
MikeShane (Show more)
Community Support Member
Posts: 144
Since: 2008/1/5 2
#1

not logging in using IE 7

Having problems with several computers that are running IE7 not logging in. Screen says thank you for logging in but is not logged in (no menus)I can log in with these computers using firfox or opera but we need to find out how to solve problem as most of the clients we will have using our site will ne using IE of some sort. Any suggestions on where to look. Is log in script asking for ID from user and something blocking or any other sugestions
Musicians for musicians entertaining the world, what starts as a dream can live in reality!

bubuche93

Just popping in
Posted on: 2008/1/11 2:56
bubuche93
bubuche93 (Show more)
Just popping in
Posts: 25
Since: 2006/11/19
#2

Re: not logging in using IE 7

i had the same problem, i had to desactivate protector...

irmtfan

Module Developer
Posted on: 2008/1/11 3:19
irmtfan
irmtfan (Show more)
Module Developer
Posts: 3419
Since: 2003/12/7
#3

Re: not logging in using IE 7

some people tell me they have problems with IE7.but i have not any problem
could everybody see my post please test it in "Iran Mobile" test website? and drop a note about it here?
http://www.irmob.com/irmob
you can register or use my test account:
user: irmtfan2
pass: 54321

irmob

Just popping in
Posted on: 2008/1/12 6:57
irmob
irmob (Show more)
Just popping in
Posts: 25
Since: 2005/10/2
#4

Re: not logging in using IE 7

Hello,
I'm tested irmob.com/irmob with 5 user from different PC and with IE7.
All them say's that view welcome message then logout from site.

phppp

XOOPS Contributor
Posted on: 2008/1/12 14:05
phppp
phppp (Show more)
XOOPS Contributor
Posts: 2857
Since: 2004/1/25
#5

Re: not logging in using IE 7

Quote:

bubuche93 wrote:
i had the same problem, i had to desactivate protector...


Did that fix your problem?

phppp

XOOPS Contributor
Posted on: 2008/1/12 14:09
phppp
phppp (Show more)
XOOPS Contributor
Posts: 2857
Since: 2004/1/25
#6

Re: not logging in using IE 7

check XOOPS/kernel/session.php

Line #78

var $enableRegenerateId = true;

change to

var $enableRegenerateId = false;

To see if it fixes your problem.

bubuche93

Just popping in
Posted on: 2008/1/12 15:00
bubuche93
bubuche93 (Show more)
Just popping in
Posts: 25
Since: 2006/11/19
#7

Re: not logging in using IE 7

yes it seems to have fixed the problem disabling protector (last version), at least on my laptop. my company is using mac and I don't receive anymore complaints from my users.

irmob

Just popping in
Posted on: 2008/1/12 15:31
irmob
irmob (Show more)
Just popping in
Posts: 25
Since: 2005/10/2
#8

Re: not logging in using IE 7

Hello PHPPP

I can't find var $enableRegenerateId = true; on session.php.

phppp

XOOPS Contributor
Posted on: 2008/1/12 15:36
phppp
phppp (Show more)
XOOPS Contributor
Posts: 2857
Since: 2004/1/25
#9

Re: not logging in using IE 7

which version do you use?
line 78
http://xoops.svn.sourceforge.net/view ... revision=1204&view=markup

irmob

Just popping in
Posted on: 2008/1/12 15:50
irmob
irmob (Show more)
Just popping in
Posts: 25
Since: 2005/10/2
#10

Re: not logging in using IE 7

Hello PHPPP
I changed this line and I can login in my site with IE7
are this is a bug for XOOPS 2.0.18?