xoops forums

Shine

Just can't stay away
Posted on: 2007/10/25 21:42
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#1

Which modules are php5 compatible?

To get a good idea what module(s) are php5+ compatible,.. please share it within this thread to inform the XOOPS users community.
Not everybody has already php5 to test it out, those who do,..share the information.

Modulename: _______ Version: .________
Php5: yes/no/not completely
SQL version: _______
Xoops version: ________

Known problems: _______


Thanks in advance

Grtz., Shine

Catzwolf

Home away from home
Posted on: 2007/10/25 23:32
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#2

Re: Which modules are php5 compatible?

Thank you shine for bringing an important issue to the forefront.

I can state that the current version of WF-Channel is this:

Modulename: WF-Channel Version: v2.00
Php5: Will work on both PHP4 and PHP 5
SQL version: 5
Xoops version: 2.17

Known problems: In current RC status and has some bugs that are currently being worked on. Don't use on a production website at the moment.

WF-Channel was developed on the following system

Windows-Xp XP2
Apache v2.2.4
PHP v5.2.4 Build date:Aug 30 2007
MYSQL v5+

php Vars:
magic_quotes_gpc: on
magic_quotes_runtime: off
register_globals: off
safe_mode: off

ATB

Catz

davidl2

XOOPS is my life!
Posted on: 2007/10/25 23:33
davidl2
davidl2 (Show more)
XOOPS is my life!
Posts: 4843
Since: 2003/5/26
#3

Re: Which modules are php5 compatible?

.

Shine

Just can't stay away
Posted on: 2007/10/26 7:27
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#4

Re: Which modules are php5 compatible?

The standard mylinks module has been made php5 compatible.
See and download:
https://xoops.org/modules/news/article.php?storyid=3968

Runs in every xoopsversion.
No known problems.

instantzero

Module Developer
Posted on: 2007/10/26 10:08
instantzero
instantzero (Show more)
Module Developer
Posts: 232
Since: 2006/11/29
#5

Re: Which modules are php5 compatible?

ALL our modules are fully Php5 AND Mysql5 compatibles since a long time.

The next versions of our modules will only run with Php 5 and some recent versions of Mysql.

Shine

Just can't stay away
Posted on: 2007/10/26 12:38
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#6

Re: Which modules are php5 compatible?

Quote:
Thanks Shine. You is welcome for contributor too

Yes I know and I wish I could, but I dont have php5 on my webshost server yet. I think this will change on 1 january 2008.
Until then I and other users depend on information given by others.

Ronaldus

Friend of XOOPS
Posted on: 2007/10/26 22:03
Ronaldus
Ronaldus (Show more)
Friend of XOOPS
Posts: 389
Since: 2004/5/8 1
#7

Re: Which modules are php5 compatible?

What are you doing on graveyard Shine??

Shine

Just can't stay away
Posted on: 2007/10/29 22:37
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#8

Re: Which modules are php5 compatible?

^Bump ^

Please report!

Northern

Just can't stay away
Posted on: 2007/10/29 23:46
Northern
Northern (Show more)
Just can't stay away
Posts: 420
Since: 2004/12/26
#9

Re: Which modules are php5 compatible?

Modulename: XGarage
Version: .0.5b
Php5: Yes
SQL version: 5.+
Xoops version: 2.0.+

Known problems: Its beta, there are many problems and they are being fixed and upgraded at the same time

Cerrently the main site www.xgarage.org is up to date on php5 and sql5 and we run the latest version of XOOPS and our module.



Marc

Shine

Just can't stay away
Posted on: 2007/10/31 23:19
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#10

Re: Which modules are php5 compatible?

^Bump ^

I'll keep bumping this topic...

To get a good idea what module(s) are php5+ compatible,.. please share it within this thread to inform the XOOPS users community.
Not everybody has already php5 to test it out, those who do,..share the information.
Also developers of modules


Modulename: _______ Version: .________
Php5: yes/no/not completely
SQL version: _______
Xoops version: ________

Known problems: _______


Thanks in advance