xoops forums

guardian2k1

Not too shy to talk
Posted on: 2004/12/30 2:39
guardian2k1
guardian2k1 (Show more)
Not too shy to talk
Posts: 114
Since: 2004/12/23
#1

AMS 2.2 *again*

I'm still unable to view/submit articles using AMS 2.2. I've set all the user permissions via submit/approve, checked Manage Audience levels. Even cleared the cache and templates.

Still unable to view anything, except the notification box. PHP debug returns no errors or MySQL debug. Anyone have any further suggestions? http://www.linuxportal.org/modules/AMS/

m0nty

XOOPS is my life!
Posted on: 2004/12/30 3:33
m0nty
m0nty (Show more)
XOOPS is my life!
Posts: 3337
Since: 2003/10/24
#2

Re: AMS 2.2 *again*

weird, i don't have that problem..

could you possibly create a temp admin account so can take a look at the settings? sometimes a 2nd eye on things can spot somethin..

brash

Friend of XOOPS
Posted on: 2005/1/3 22:34
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#3

Re: AMS 2.2 *again*

It seems to be working now. What did you do to correct the problem?

guardian2k1

Not too shy to talk
Posted on: 2005/1/3 22:50
guardian2k1
guardian2k1 (Show more)
Not too shy to talk
Posts: 114
Since: 2004/12/23
#4

Re: AMS 2.2 *again*

Updated the templates and turned caching off the main menu off.

brash

Friend of XOOPS
Posted on: 2005/1/3 22:54
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#5

Re: AMS 2.2 *again*

Ah, cool

Cavan

Friend of XOOPS
Posted on: 2005/1/27 4:44
Cavan
Cavan (Show more)
Friend of XOOPS
Posts: 218
Since: 2004/11/28
#6

Re: AMS 2.2 *again*

After much frustration with News modules 1.1 and 1.21 and not getting much help solving the problems I was having with them, I thought I'd give the AMS 2.2 module a go...Well, after setting all three permissions separately, as I've read you're supposed to do, I'm having the same problem as explained above: I can't post an article and keep getting the message "Article saving failed".

Why is getting any any of these news modules to work so frustrating? In News 1.1, after clearing my templates_c folder (as per XOOPS suggestion), I couldn't post anything. After installing News 1.21, one day I can post and the next, forget about it. And now...Having the news module feature was one of the most important parts of my deciding to even use XOOPS but if I can't get it to work on my site, well...maybe it's time to go back to the drawing board.

I could really use some help.

brash

Friend of XOOPS
Posted on: 2005/1/27 5:21
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#7

Re: AMS 2.2 *again*

In AMS you first need to a) create a topic, and b) set each of the three permissions on that topic. It sounds like you have done this much, so the trouble might be elsewhere. Can you give us info on your XOOPS environment (OS, Webserver, PHP version, XOOPS version, etc). Also can you detail what options you selected when submitting your article, and turn on PHP debug and list the messages (if any) given when submitting?

Cavan

Friend of XOOPS
Posted on: 2005/1/27 5:47
Cavan
Cavan (Show more)
Friend of XOOPS
Posts: 218
Since: 2004/11/28
#8

Re: AMS 2.2 *again*

brash:

I installed the module, set config options, set the permissions, created two topics (news and events---not much but all we need for the site) and I'm still not able to post articles to either of the topics.

Here's the information...I hope it helps:

Environment:

Operating system: Linux
Kernel version: 2.4.28
Machine Type: i686
Apache version: 1.3.33 (Unix)
PERL version: 5.8.4
PHP version: 4.3.10
MySQL version: 4.0.22 (standard-log)
Xoops version: 2.0.7.3

AMS 2.2 Config Options: (ones that I suspected may be cause but don't seem to be)

Auto approve articles without admin intervention? Yes
Authorized groups to upload: Approvers only
Restrict Topics on Index Page? No

AMS 2.2 Permissions:

Approve: Webmasters, All (do Registered Users need permission here even with 'auto approve' set to 'yes'?)
Submit: Webmasters, All; Registered Users, All
View: Webmasters, All; Registered Users, All

(AMS 2.2) PHP Debug Errors: No errors generated at modules/AMS/index.php or modules/AMS/submitnews.php

(AMS 2.2) MySQL/Blocks Debug: No errors generated at modules/AMS/index.php or modules/AMS/submitnews.php

(AMS 2.2) Smart Templates Debug: No errors generated at @modules/AMS/index.php or modules/AMS/submitnews.php

Cache is turned OFF for this module.

I selected no options when submitting the article, just the words "ams 2.2 test" in 'title' and 'article text'.

Edit: On a side note, I have no need for the 'banner/sponsor' box in submit.php but I cannot find which template to remove it from.

brash

Friend of XOOPS
Posted on: 2005/1/27 9:11
brash
brash (Show more)
Friend of XOOPS
Posts: 2206
Since: 2003/4/10
#9

Re: AMS 2.2 *again*

Seems you may have stumbled on a bug. If you have set the auto approve without adminintervention option, but the user submitting the article does not have approve permissions, the article goes into cyberspace. It is physically there in the database, you just can't do anything with it through the AMS interface.

Cavan

Friend of XOOPS
Posted on: 2005/1/27 15:45
Cavan
Cavan (Show more)
Friend of XOOPS
Posts: 218
Since: 2004/11/28
#10

Re: AMS 2.2 *again*

brash:

I cannot post logged-in as Admin or logged-in under a Registered User account---I can't determine if this is indeed a bug, but whether it is or isn't, I have yet to find a news module that works consistently.

Any suggestions?

(FYI, I'm going to uninstall and reinstall AMS 2.2 today to see what happens...)