1
matangi
Could not register new user.
  • 2004/9/30 12:16

  • matangi

  • Just popping in

  • Posts: 31

  • Since: 2002/4/13


Does anyone has the same problem.

I am using Version

Powered by XOOPS 2.0.7.1

I tried to register from the frontend and within the admin area, but without success.

Any help any ideas.

Thanks

Matangi

2
Mithrandir
Re: Could not register new user.

Firewall blocking HTTP Referer

3
matangi
Re: Could not register new user.
  • 2004/9/30 12:35

  • matangi

  • Just popping in

  • Posts: 31

  • Since: 2002/4/13


Quote:

Mithrandir wrote:
Firewall blocking HTTP Referer


Thanks for the fast answer

That means I have to contact the hoster, an update will not help?

Correct?

Matangi

4
Mithrandir
Re: Could not register new user.

No, it means that you should allow your firewall to send the HTTP referer to that site.

5
tedsmith
Re: Could not register new user.
  • 2004/9/30 13:01

  • tedsmith

  • Home away from home

  • Posts: 1151

  • Since: 2004/6/2 1


For full description and explanation of this problem read this post

https://xoops.org/modules/newbb/viewto ... 6&forum=7#forumpost107356.

It is especially prominent with Norton Personnal Firewall.

You have to tell the firewall to allow the HTTP referral, i.e. remember where the user came from page by page. To disable the check all together by hard coding, look at Dave_L's posting.

Hope this helps.

Ted

6
matangi
Re: Could not register new user.
  • 2004/9/30 20:30

  • matangi

  • Just popping in

  • Posts: 31

  • Since: 2002/4/13


Quote:

tedsmith wrote:
For full description and explanation of this problem read this post

https://xoops.org/modules/newbb/viewto ... 6&forum=7#forumpost107356.

It is especially prominent with Norton Personnal Firewall.

You have to tell the firewall to allow the HTTP referral, i.e. remember where the user came from page by page. To disable the check all together by hard coding, look at Dave_L's posting.

Hope this helps. Ted


Thank for that,

tried to change the file >> functions.php << like recommended, just to check out if it helps.

But it does not.

The request I recieved was from a user that uses an internetcafe in hungary, so technical explanation to her will not help.

Is there anything else that I can do to make it run? Beside of that I tried it with and without firewall, but I do not use Norton firewall. No change.

If there is something else that I can try I will be happy to hear from

Matangi



7
tedsmith
Re: Could not register new user.
  • 2004/10/1 8:15

  • tedsmith

  • Home away from home

  • Posts: 1151

  • Since: 2004/6/2 1


If the problem is definately the same as the problem described in the thread above, then try this (as suggested by Dave_L - it worked for me)

To disable the HTTP_REFERER check, add the following code lines at the beginning of the function xoops_refcheck in the file :

include/functions.php


function xoops_refcheck($docheck=1)
{

return true; // disable HTTP_REFERER check
$ref = xoops_getenv('HTTP_REFERER');
if ($docheck == 0) {
...
}

Save the file, and try again.

8
matangi
Re: Could not register new user.
  • 2004/10/1 15:23

  • matangi

  • Just popping in

  • Posts: 31

  • Since: 2002/4/13


Thanks again,

will try it again, maybe it was too late yesterday.

Matangi

9
matangi
Re: Could not register new user.
  • 2004/10/9 23:14

  • matangi

  • Just popping in

  • Posts: 31

  • Since: 2002/4/13


Quote:

matangi wrote:
Thanks again,

will try it again, maybe it was too late yesterday.

Matangi


Sorry, I use the multilanguage hack and I forgot a field in the user table, so the register-process never finished.

Thanks Matangi

Login

Username:
Password:

Lost Password? Register now!

Who's Online

59 user(s) are online (28 user(s) are browsing Support Forums)


Members: 0


Guests: 59


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits