1
Whoa9090
forum posts = blank pages
  • 2004/8/20 9:36

  • Whoa9090

  • Just popping in

  • Posts: 13

  • Since: 2004/2/1 6


i get a blank page when i try to view forum posts
heres what debug has to say about it:

Fatal error: Cannot pass parameter 4 by reference in .../modules/newbb/viewtopic.php on line 256

2
Dave_L
Re: forum posts = blank pages
  • 2004/8/20 9:47

  • Dave_L

  • XOOPS is my life!

  • Posts: 2277

  • Since: 2003/11/7


Which versions of Xoops, newBB and PHP are you using?

3
Anonymous
Re: forum posts = blank pages
  • 2004/8/20 13:48

  • Anonymous

  • Posts: 0

  • Since:


TRy to change lines 256:

if ( $viewmode == "thread" ) {
    
$postsArray ForumPosts::getAllPosts($topic_id"ASC"$total_posts0);


in

if ( $viewmode == "thread" ) {
    
$start 0;
    
$postsArray ForumPosts::getAllPosts($topic_id"ASC"$total_posts$start);

4
tedsmith
Re: forum posts = blank pages
  • 2004/8/27 11:12

  • tedsmith

  • Home away from home

  • Posts: 1151

  • Since: 2004/6/2 1


I have this problem too but the details (using PHP Debug mode) are as follows:

Notice [PHP]: Undefined index: nohtml in file d:\cms.fct\modules\newbb\post.php line 165
Notice [PHP]: Undefined index: nosmiley in file d:\cms.fct\modules\newbb\post.php line 166
Notice [PHP]: Undefined index: icon in file d:\cms.fct\modules\newbb\post.php line 167
Notice [PHP]: Undefined index: attachsig in file d:\cms.fct\modules\newbb\post.php line 168
PHP Fatal error: Cannot redeclare newbb_notify_iteminfo() (previously declared in d:\cms.fct\modules\newbb\include\notification.inc.php:28) in D:\cms.fct\modules\newbb\include\notification.inc.php on line 28

With me it is when my users try to post an article. It still gets posted, but they don't get redirected automatically. I'm on an Intranet by the way, not standard website.

It was working fine before I turned the 'register_globals' value in php.ini to 'on' so that I could get the ZenTrack module to work. So I tried putting it back to off and re-started the service but it is still doing it.

I'm using 2.0.7 and the version of newbb that ships with it. Would updating the module in Sys\Admin help and if I did that would my postings be kept or would I loose them?

Thanks, and please HELP!!

Login

Who's Online

78 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 78


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits