Anyone gotten MultiMenu to work?
  • 2004/3/27 2:40

  • pkidion

  • Just popping in

  • Posts: 11

  • Since: 2004/2/12

It will not let me add links. There is no error message, no anything.

It simply blinks the screen like its writing to the database and PRESTO no link added. When I say no link added, I mean on the administration page where it says "MULTIMENU 1" and is supposed to display the links in that section.

Am I missing something simple?

Re: Anyone gotten MultiMenu to work?
  • 2004/3/27 4:46

  • Stewdio

  • Community Support Member

  • Posts: 1560

  • Since: 2003/5/7 1

Numerous people including myself have this running on their site. Did you turn on PHP/SQL debug in the admin to see if any hidden errors pop up?

The more details the better. This module works like a charm for me.

Re: Anyone gotten MultiMenu to work?
  • 2004/3/27 8:24

  • carnuke

  • Home away from home

  • Posts: 1955

  • Since: 2003/11/5

I use multimenu on 2.0.5. It worked straight away out of the box. You do have to set group permissions for each menu, or else they don't show. Try re-installing. It's a good module and worth getting to work


Re: Anyone gotten MultiMenu to work?
  • 2004/3/27 8:33

  • meme

  • Quite a regular

  • Posts: 271

  • Since: 2002/12/10

tested with XOOPS 2.0.6 without error

Re: Anyone gotten MultiMenu to work?
  • 2004/3/27 9:18

  • mikeh

  • Just popping in

  • Posts: 70

  • Since: 2002/1/18

there are different versions knocking around
one i tried gave me problems
the one tagged 1.1 works fine for me

Re: Anyone gotten MultiMenu to work?
  • 2004/3/27 16:50

  • pkidion

  • Just popping in

  • Posts: 11

  • Since: 2004/2/12

That's what I thought, I someone had to get it working.

But I am having trouble generating any kind of error, so I don't know where to look to fix it. No SQL errors that I can find, but then again, that could be me forgetting something simple.

I turned on group permissions for all four menus. It installed correctly as far as I can tell, no error messages anywhere: it just won't let me add links.

iMenu works like a dream - I thought that might be an issue (i menu and multimenu not playing well together). I'll try the 1.1 version instead of 1.2.

I'm certain it's something simple I'm forgetting, I just have no idea because of a complete lack of error messages. Any ideas?

Version 1.1 and not 1.2
  • 2004/3/27 17:33

  • pkidion

  • Just popping in

  • Posts: 11

  • Since: 2004/2/12

Turns out that version 1.1 is the one I can get to work without a hitch. Go figure, 1.2 doesn't seem to like me.

It took a bit of doing to find it, but it worked fine. Hmmm. The guys that made it are dropping xoops, so who knows if they'll fix it.

But I'd still like to know if it's a simple fix. That's just me.

Thanks for the help.

Now, I wonder if it will work with iMenu... (I want more than 4 submenus)

Re: Version 1.1 and not 1.2
  • 2004/3/27 18:26

  • Marco

  • Home away from home

  • Posts: 1256

  • Since: 2004/3/15

same problem for me
i use 1.1 instead of 1.2, under XOOPS 2.6x

Re: Version 1.1 and not 1.2
  • 2004/3/27 20:24

  • sol812

  • Just popping in

  • Posts: 75

  • Since: 2002/9/4 1

You absolute right, but if look other places in the forum , I begin Post warning about this subject - but the only reply we get " HEY IT WORK ON MY SITE" good , fine, thank you - but is not a solution, problem is " imenu and multimenu" not work on sevral xoops2.06 systems - and there are maybe many more out there who have same problem but no like post message in forum -

maybe we can get a list of the modules from some people who have imenu working, so we can compair the list and see if maybe there is a confligt with a module who block the system to work with the 2 menu moduls - ( just 1 idea ) maybe you have another to track this problem

I hope we will get some intelligent serious programmers to look into it, with so many users claim it is not working we simpley need act professional and look more deep into the problem - I do what I can to help ... but I am not a programmer - I am more a program editor ...

so let us try find this error -

Thank you

Re: Version 1.1 and not 1.2
  • 2004/3/28 2:05

  • Maracas

  • Just popping in

  • Posts: 66

  • Since: 2004/2/18

Like Sol, I can't get either iMenu or MultiMenu to work on my site with 2.0.6. They worked with 2.0.5, though. My problem is that neither even shows up as an installable mod. They just are not there. I will try MultiMenu 1.1 if I can find it because I am not sure offhand which version I have been trying.

These two menu systems are highly recommended as solutions to a lot of people's menu problems. But many can't get either MultiMenu or iMenu to work on their installations and others seem to run them fine. The answers to people's posts about what to do when they can't get them to work always seem to be (a) it works fine for me, or (b) you must be doing something wrong.

If the problem is simply that there are too many versions about, then perhaps we could figure out which ones are viable and post them somewhere. It does appear to be a problem that has surfaced with 2.0.6 judging by the posts in this matter. I'd try but I can't even get them to show up, lol.


Who's Online

58 user(s) are online (30 user(s) are browsing Support Forums)

Members: 0

Guests: 58



Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits