1
chapi
table background is missing sometimes ..
  • 2002/6/6 8:42

  • chapi

  • Theme Designer

  • Posts: 611

  • Since: 2002/1/22


Sometimes the backgroundcolor of the Recent Discussions Block on the start site is missing. The darker blue behind >>> visit forums and the lines between the table fields doesnt show up. If i select one topic and then hit the back button of my browser everything looks alright? Strange thing ?

P.S. I'm using IE 6

2
sunsnapper
Re: table background is missing sometimes ..

I have the same result with my custom block using IE 5.5 and a phpkaox derivative. I find that when I go to my URL by typing it in, the background color for my custom block does not appear. However, if I browse my site and click into my home page (or, as you did, hit the back button), the background color shows up fine.

This was happening in RC2 for me, as well, so I don't think it's an RC3-specific issue. My guess had been that it's either a flaw in CSS rendering of IE, OR the CSS file for the theme was doing something that IE could only understand when it was in the mood.

I can't think of anything that XOOPS would be doing to impact the issue. However, I am digging into CSS to polish my theme... so perhaps something will turn up in the process.

Summary:
-This happens in both IE 5.5 and IE 6
-This happens in the phpkaox theme as well as yours
-This happens in RC2 and RC3

As I dig into CSS, some useful sites I've found are in this thread.




<small>[ Edited by sunsnapper on 2002/6/9 22:03:03 ]</small>

3
sunsnapper
Re: table background is missing sometimes ..

One thing to look at if you are having this problem is whether or not you are using both HTML bgcolor and CSS class to specify your background color.

If you are then look to see if they are consistent.

In other words, if in the table code you specify a bgcolor of light blue, but in your CSS you specify a bgcolor of white... you can get these odd results as the browser tries to choose which to use.

Probably these days, with CSS1 being around for a number of years, it's safe to set all of your bgcolor in a CSS file... and remove your outdated HTML references. Of course, that is just one approach.

4
Frootloop
Re: table background is missing sometimes ..
  • 2002/6/26 2:53

  • Frootloop

  • Just popping in

  • Posts: 1

  • Since: 2002/6/23


Another thing to watch out for is if you've removed any classes from the css file that elements of XOOPS are still calling to. For instance, I removed ".bg2" in my css file because I didn't need it anymore, but the mydownloads files "viewcat.php" and "dlformat.php" were making calls to it. I simply edited those files and removed the the class='bg2' calls and never had any more problems with the tables filling in like you describe.

Best of luck solving your problem!

-Frootloop

5
Eddo
Re: table background is missing sometimes ..
  • 2002/10/6 1:16

  • Eddo

  • Just popping in

  • Posts: 37

  • Since: 2002/9/6 3


I have had a simlar problem like this.

I have found it is related to the import command used by includes/functions.php file to import the stylesheet.

<style type='text/css' media='all'><!-- @import url($themecss); --></style>

For some reason IE can be a little buggy with the import function. It would not display certain elment if i went directly to the page, but if i use the back button it would and some other problems (on IE 6)

So i just used a hard link to the stylesheet in the functions.php files and worked prefect for me then.

Hope it helps


6
w4z004
Re: table background is missing sometimes ..
  • 2002/10/6 3:47

  • w4z004

  • XOOPS Advisor

  • Posts: 340

  • Since: 2001/12/13


Can reproduce this here ?? in xoops.org ??

or in me site ?? www.xoops.sytes.net

xoops.org and me site are using the new Xoopsbb with smarty.

7
w4z004
Re: table background is missing sometimes ..
  • 2002/10/6 3:49

  • w4z004

  • XOOPS Advisor

  • Posts: 340

  • Since: 2001/12/13


the bg1 to bg4 and the fg1 to fg3 are used for all the modules :) if you remove of the css you go to have visual errors.

We are working in a new CSS standard for the new XOOPS RC3.1 replacing the obsolete bg and fg for a really complete pack of CLASS !

8
swisslyons
Re: table background is missing sometimes ..
  • 2003/2/27 14:49

  • swisslyons

  • Just popping in

  • Posts: 43

  • Since: 2002/6/23


i am having a similar issue with a new theme i am working on.

Also, on this site, the center block sometimes shows white BG and sometimes colored.

oh yeah, here is the site in question:

http://www.glycerinesport.ch/index.php

I wonder is it cookie related? nah...couldn't be, could it?reason I say is becuase at home, my IE cookie 'red eye' was showing that it blocked cookies form all sorts of graphic files from this site that are in my theme! weard!

[edited by swisslyons]
*nevermind*..its called css

Login

Username:
Password:

Lost Password? Register now!

Who's Online

65 user(s) are online (35 user(s) are browsing Support Forums)


Members: 0


Guests: 65


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits