1
macnoludo
Flat by default when clicking on "recent comments"'s link
  • 2004/2/17 10:00

  • macnoludo

  • Just popping in

  • Posts: 24

  • Since: 2002/9/18


Hello,
Is someone know how to change code to have the thread flat by default when the user is clicking on a link of the "recent comments" s' block ?
For example on the homepage when i clik on the link :
----------------------
"Recent Comments"
Re : xcGallery - Release 1.1
(https://xoops.org/modules/news/article ... _mode=thread&#comment6009)
----------------------
I would have :
"Recent Comments"
Re : xcGallery - Release 1.1
(https://xoops.org/modules/news/article ... &com_order=1&storyid=1090)

Thank you for your help

2
m0nty
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/2/18 2:02

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


u can set default mode in admin/ preferences.. either general settings or user info settings (can't remember which 1)

the user shud be able to choose in their profile too i believe..

3
macnoludo
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/2/18 8:49

  • macnoludo

  • Just popping in

  • Posts: 24

  • Since: 2002/9/18


Thanks to your help but, no : the admin preferences doesn't works here. By default u can have the flat option for the comments when u choose an article, one download or anything else, it will appear under.. But not for the block "recent comments", the link u click point to this comment and only this comment. if there are another comments in the native download or article u don't have access first.. And it is what i want if it's possible !!!


4
mikeh
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/2/18 10:02

  • mikeh

  • Just popping in

  • Posts: 70

  • Since: 2002/1/18


goto system module
in blocks dir
in the system blocks file
search for thread and replace it with flat
so its as below
&com_mode=flat&

bit rushed but hope helps

5
Cheeze
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/12/14 16:48

  • Cheeze

  • Just popping in

  • Posts: 38

  • Since: 2004/11/16


Hi, I checked the file out but I found no such variable. I'm using XOOPS 2.0.7. Maybe the advice is outdated?

6
irmtfan
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/12/14 17:16

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


upgrade to 2.0.7.3 for solve this problem

7
Cheeze
Re: Flat by default when clicking on "recent comments"'s link
  • 2004/12/15 13:04

  • Cheeze

  • Just popping in

  • Posts: 38

  • Since: 2004/11/16


Hi, sorry, I'm using 2.0.7.3.

Let me see if I got this correct. Go to modules directory, go to system directory, go to blocks directory, edit the file system_blocks.php?

A search in the file doesn't show &com_mode=flat&, thread, or flat.

Login

Who's Online

60 user(s) are online (31 user(s) are browsing Support Forums)


Members: 0


Guests: 60


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits