1
campbell
Upgrading from v1 RC 3.0.4 to v2.05
  • 2003/11/12 5:24

  • campbell

  • Just popping in

  • Posts: 11

  • Since: 2001/12/20


I have been running XOOPS since it was first released in early January 2002 and have had absolutely no problems with it whatsoever.

The time has come, however, for me to upgrade my site to Version 2 but I don't see an upgrade script anywhere. Am I mistake or does the installation detect a previous installation?

I have almost 2 years worth of postings etc and about 50 members which I am not willing to lose.

Can anyone tell me which download I must take that will enable me to upgrade my site.

thanks

2
Lodgrien
Re: Upgrading from v1 RC 3.0.4 to v2.05
  • 2003/12/9 15:35

  • Lodgrien

  • Just popping in

  • Posts: 3

  • Since: 2003/12/9


I have the same Problem. The version.php says, I have version 1.0 RC3.0.4
Now I want to upgrade to version 2.0. But I found only a upgrade script from 1.3.4 (RC 3.0.4) to 1.3.5(RC3.0.5) (ok, and then the other ones). My question is, is this the right beginning upgrade script?

thanks


3
Herko
Re: Upgrading from v1 RC 3.0.4 to v2.05
  • 2003/12/9 15:38

  • Herko

  • XOOPS is my life!

  • Posts: 4238

  • Since: 2002/2/4 1


First of all, make a full backup of ALL your files, and your complete database. Just in case, you can restore your site easily.

XOOPS 2 comes with a built in installer/upgrading script. If you give the XOOPS 2 install the directions to your XOOPS 2 database, it will detect it as a XOOPS 1 database, and migrate it to XOOPS 2. So there's no extra migration/upgrade script needed

Herko

4
Lodgrien
Re: Upgrading from v1 RC 3.0.4 to v2.05
  • 2003/12/9 15:51

  • Lodgrien

  • Just popping in

  • Posts: 3

  • Since: 2003/12/9


Thanks for super sonic help. (I hope thats the right explenation for this quick anwser, I'm from Germany)

This converts the database. And what's about the PHP files? I understand it in this way: I backup all and make a completly new installation. And then the database converts automaticly. But I have some Modules installed. Must I install these also new?

thanks

5
Lodgrien
Re: Upgrading from v1 RC 3.0.4 to v2.05
  • 2003/12/9 19:12

  • Lodgrien

  • Just popping in

  • Posts: 3

  • Since: 2003/12/9


Now I tryed it and everythings seemed to be ok. The database was updated without any error. But if I navigate to the index.php it shows an empty site.

Has anybody an idea, what is going wrong?

thanks

Login

Username:
Password:

Lost Password? Register now!

Who's Online

74 user(s) are online (50 user(s) are browsing Support Forums)


Members: 0


Guests: 74


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits