Re: problem check list
  • 2005/3/13 4:42

  • abhinav

  • Just popping in

  • Posts: 2

  • Since: 2005/3/13

I have the same problem too...


Everything installed OK but at the end, I get a blank screen

Re: problem check list
  • 2005/7/31 22:14

  • koertzen

  • Just popping in

  • Posts: 79

  • Since: 2003/10/22

Great idea on the questions. Two more questions for the standard setup:

Are you on a hosted system?
Do you have shell access?
Be the change you wish to see in the world.

Re: problem check list
  • 2005/9/16 17:42

  • xiaoding

  • Just popping in

  • Posts: 1

  • Since: 2005/9/16

I'd the same blank screen problem after I upgraded PHP to 5.0.4. Later on, I found out that my PHP5 was not built with the MySQL option on "--with-mysql=/dir". Once I recompiled the PHP5, the problem went away.

Hope it helps.

Re: problem check list
  • 2005/9/21 20:30

  • chlockett

  • Just popping in

  • Posts: 29

  • Since: 2005/9/10

I also have a blank page. It seems this is a recurring problem, so someone should be working on a fix.

Re: problem check list
  • 2005/9/27 20:42

  • Joeerhea

  • Just popping in

  • Posts: 3

  • Since: 2005/9/27

I had the same problem until I changed the cache,uploads and template_c directories to chmod 777. Now it appears that everything works except the images, buttons, banners, and avatars. They are not displaying. I had the same problem with a BB I was trying to install. I gave up and deleted it after the problem stumpped the support staff.

call it XOOPS Troubleshooter
  • 2006/2/21 12:20

  • jsdev2006

  • Just popping in

  • Posts: 8

  • Since: 2006/2/18

great idea!!
A good name would be XOOPS Troubleshooter.
The other idea of extending it further into an intelligent help system is also quite good. If anyone as the patience or time, you can make it a module which will take you to the right page depending on what error you have and what config you have!

(p.s. Or maybe we could just use the search on the docs )

Re: problem check list

Okay, here is the "Blank White Page" Help - see the quote below.

Somebody else provided the links were provided, but there are so many questions about it, lets just post the text here. Save folks from going to look it up.

The last time I upgraded {havent' tried 2.3 yet}, the blank white page was caused by the a script error. The script crashes before finishing leaving a blank white page.

The reason my script was crashing was because not ALL of the files uploaded.

So before trying to turn on the script debugging program, do a files check.

Upload the file checking files to root directory.
checksum.md5 and

Then run the php file to find the missing files

Then upload the missing files.
That will probably fix most blank white pages.

If not, turn on the script debugging fix below. Last time I messed up so badly, I had to edit the database manually to turn it on. Then you can identify the line with the script error.

Why do I have a blank white page on my site?

All so-called "blank pages" in XOOPS are caused by an error which terminates the script early. The goal of this page is to help you turn some debugging features on so you can get a more meaningful picture of what is going wrong, preferably some error messages. Please keep in mind, there is always an error which is causing the "blank page -- it may just be hard to get at.

You will not get a response in the forums if you just type "Help me, I get a blank page" because there is no way for anyone to tell what is wrong. If you can also give a list of the error messages you see, your chances for solving the problem are much better. (Also don't forget to specify which version of XOOPS you are running, whether it was an upgrade from a previous version, also your versions of mysql, apache/other webserver, PHP, and which theme and template set you are using. If you are using a lot of non-standard modules, it would be a good idea to list those too.)

A: To turn on debugging try the following things:
1. If you can get to admininstration menu, go to Preferences, select 'Main', and find the section on debugging options. Choose "PHP Debugging"

2. If you can't get to the administration page, but have access to mysql, try the query "UPDATE xoops_config SET conf_value=1 WHERE conf_name = 'debug_mode'". Be sure to make sure "xoops_config" matches the name of the config table in your installation. (NOTE: This does not work with XOOPS 2.2, see 2a)

2a. In XOOPS 2.2, go to your site's root file "recovery.php" and set the debug settings through the interface here

3. If you can't get to the administration page, and don't want to mess with mysql, but don't mind messing with PHP, then edit the file "include/common.php". Near line 83, change "error_reporting(0);" to "error_reporting(E_ALL);".

4. If this still doesn't work, your server or hoster may have turned off debugging in "/etc/php.ini" (linux) or "WIN_DIRECTORY/php.ini" (windows). Make sure there is a line in there "display_errors On".

5. If you don't have access to change this file (e.g. on shared hosting), then if the server uses the "apache" webserver, you can create a file called ".htaccess" to override the settings locally. This file should contain the line: "php_flag display_errors on". The tricky part is WHERE to put this file. Look at the URL you are having problems with. Put the file in the corresponding directory. e.g. If it is "someplace.com/xoops/" or "someplace.com/xoops/index.php" then you need to put the file in the main XOOPS directory. If it is something like "someplace.com/xoops/modules/system/admin.php" then put it in "modules/system" subdirectory of your XOOPS installation. etc.

B: Common Error Messages (and fixes)

Once you produce an error message you can begin to diagnose your particular problem. Generally you can ignore any 'Notice' or 'Warning' that you see. Be on the lookout for 'Fatal Error' as this is the most important one.

If you have been unable to produce an error message, proceed to section "C: Possible Fixes" and you can try some of the suggestions there.

Following is a list of error messages that you might see, along with steps you can take to remedy the problem. (Please feel free to add to this list, or correct the message so it more accurately reflects what PHP says.)

1. "Failed opening required..." or "Undefined function..."

This most likely indicates that a required file could not be loaded. First check if the file is there and in the correct location; if it is, then check the permissions of the file to make sure the webserver can READ it. It is also possible that the file is corrupted, or that your FTP program changed file/directory names. Check your FTP program settings (make sure you "preserve directory structure", and do NOT "force lowercase", etc...) and try again installing/uploading the files again.

2. "Call to a member of a non-object"

Very frequently this is caused by failure to connect to the database. If you get this error occurring near line 286 in kernel/configitem.php, then the database is to blame. Check your database settings in mainfile.php, and also make sure you have setup MySQL permissions correctly, and that the database is actually running. In particular, try and access the database directly - if possible using the same user/password that you specified in the XOOPS installation. Note that after you change permissions for users within mysql, you must perform "flush privileges" and/or restart your database server before the new settings will be applied.

This error can be caused by other problems as well. If you know PHP, check that file and line number and see which object is the culprit. e.g. If you see "$xoopsDB->query('blah');" on that line, then $xoopsDB is not an object, indicating the the database was not successfully connected. You may have to do a little digging to solve these problems.

3. "Cannot redeclare class ..."

The most frequent cause of this error is the installation of non-standard modules. Some modules are still in very early stages and have not been fully adapted to XOOPS 2 or have not been properly tested with XOOPS 2 and with other modules. Probably the module author has used "include" where she/he should have used "include_once". Usually the file identified in the error message will indicate which module is at fault. This module can then be deactivated.
* Or you can go to the line # specified and change the line from include('yourfile'); to include_once('yourfile'); - ackbarr

C. Possible Fixes (Compiled off of the XOOPS Forums)

Below is a list of various methods that have corrected the issue for different users on the XOOPS forums. Which one, if any, that will work for you is highly dependent on your particular installation. The list is not intended to be followed in order, but rather you should focus on what seems most relevant given your error message.

[1] In the php.ini, make sure that register_globals=on. You can check this by creating a test script with this single line of code:

NOTE: The XOOPS core should work without changing this to ON, but some modules may not and thus will give blank pages. Turning on the debugging options outlined earlier in this page will help you track down which section or module is causing the error.

[2] Sometimes the PHP GZIP module is not added or correctly compiled with PHP, go into the XOOPS admin (system>preferences) and turn off support for GZIP.

[3] Make sure that you have installed XOOPS according to the installation directions by CHMODing the cache dirs on a UNIX server.

[4] Re-upload the theme files for whichever theme you're using. Sometimes things get corrupted via FTP upload. First upload phpkaox and set your system preferences to use this theme.

[5] Make sure that your running PHP 4.12 or later (preferably 4.22 due to security fixes in PHP)

[6] Make sure that you dont have another CMS interferring with XOOPS like PHPNuke, PostNuke, etc.

[7] Make sure that the cache, uploads, templates_c directories are CHMOD 777 (anonymous r/w permission on Windows)

[8] Try turning Safe Mode off on the server. (Not recommended as it is less secure).

[9] Double-check the following permissions:

755 - all directories which dont require writing from the web server
777 - all directories which do require writing from the web server
644 - all files which dont require writing from the web server
666 - all files which do require writing from the web server
444 - mainfile.php

[10] Try switching to the default theme. Several themes are meant for XOOPS 1 or have not been properly converted to XOOPS 2, causing a variety of problems. If this fixes your problem, at least you've identified the source of the problem. If you find a problem with a theme, please post on xoops.org forums and/or notify the author of the theme.

[11] Try disabling all non-standard (i.e. anything not included with XOOPS download) modules. If you cannot get to your admin menu, you can do this by editing the xoops_modules table via MySQL or phpmyadmin. Several modules are in early stages and have not been properly tested with XOOPS 2, sometimes causing problems. If this fixes your problem, try re-enabling one at a time, to determine exactly which module(s) are causing problems. If you find a problem with a module, please post on xoops.org forums and/or notify the author of the module

[12] Added by carnuke ... ifhttp://mysite.com/user.php returns a blank page, see this FAQ here

[13] Check if MySQL extension is loaded in php.ini:

--- Additional details submitted by Max-Realms on 2005/3/26 1:06:34

In my case, I got blank pages without debug errors showing. After a while of troubleshooting, I found that my database "user" had exceeded max_questions (50,000 per hour).

My server is hosted, so I can't change anything there. However, I found that if I created several more database users and gave them each full access to the XOOPS database, this problem was fixed. I don't know anything about Mysql, but perhaps when a db has multiple users, they share the load.

If this is in fact true, then it would be great if the mainfile.php and/or core files could be setup to skip to the next available database user when the default one exceeds these limts.

David Goodman
Nicholas James
President - LaDads

Re: problem check list

another cause of the 'white page' is that the PROTECTOR module has identified you as a hacker and locked you out of the site.

You may want to run the PROTECTOR recovery module and verify that you are not locked out.

You can also check the SQL database to find out if you are on the list.
Nicholas James
President - LaDads

Re: problem check list
  • 2009/1/19 20:52

  • alFReD_N

  • Just popping in

  • Posts: 6

  • Since: 2009/1/16

System Module items(banners, blocks, groups, …) are blank pages in admin.php page. I have no errors. I install XOOPS with no error. I can login. Ican see index.php.

This is my checksum.php report. No file is missing. I think these are for Persian language that I have on my site.
./footer.php content invalid
./mainfile.dist.php content invalid
./class/xoopslists.php content invalid
./class/xoopseditor/tinymce/formtinymce.php content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/langs/fa.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/advhr/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/advimage/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/advlink/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/emotions/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/fullpage/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/media/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/paste/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/searchreplace/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/style/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/table/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/template/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/plugins/xhtmlxtras/langs/fa_dlg.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/themes/advanced/langs/fa.js content invalid
./class/xoopseditor/tinymce/tinymce/jscripts/themes/advanced/langs/fa_dlg.js content invalid
./images/image.gif content invalid
./images/logo.gif content invalid
./images/s_poweredby.gif content invalid
./images/icons/delete.gif content invalid
./images/icons/edit.gif content invalid
./images/icons/profile.gif content invalid
./images/icons/reply.gif content invalid
./install/install_tpl.php content invalid
./modules/system/class/gui/default/images/bg_content.gif content invalid
./modules/system/class/gui/default/images/bg_menu.gif content invalid
./modules/system/class/gui/default/images/hbar_left.gif content invalid
./modules/system/class/gui/default/images/hbar_right.gif content invalid

PHP : 5.2.6
MySQL : 5.0.51b-community-nt
Server API : isapi

register_globals - Off

Re: problem check list
  • 2009/1/20 0:19

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1

You have some files that are not OK.
For the fa*.js files, I can understand you have adapted Persian Farsi language files. Same goes for the image files.

If you did not some intented alteration to the following files, you should correct them.

With /install/install_tpl.php I have two problems:
-After the install this directory should be removed.
-While flagged with content invalid, it might that something during the installation of your XOOPS site did not go as expected, because this file has not the content (=program) as intended. A file compare with the correct file might indicate what has possible got wrong with the install.
After correcting following files, you should update your system module.
/footer.php content invalid
/class/xoopslists.php content invalid
/class/xoopseditor/tinymce/formtinymce.php content invalid

Following file is normally not used.
/mainfile.dist.php content invalid


Who's Online

124 user(s) are online (95 user(s) are browsing Support Forums)

Members: 0

Guests: 124



Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits