1
csloh
Problem with template set manager
  • 2004/5/17 21:26

  • csloh

  • Just popping in

  • Posts: 20

  • Since: 2003/12/17


This issue has occured a few time before, if anyone can suggest why it's happening and how to fix it, I will be grateful. (In the past I have reinstall XOOPS to fix the issue.)

When I login to check on the template, athttp://[mysite]/modules/system/admin.php?fct=tplsets

I will see a partial box/table, like this
Resized Image
with nothing below it. I know there should be a box for me to add new template or something like that, but it appear the php files is "corrupted" after the Forzen Bubble entry...

This has happen 3-4 times before, always with a partial Templates column, and a blank Action column.

Am I the only one with the problem? Urggh

Please help...

2
tl
Re: Problem with template set manager
  • 2004/5/17 21:34

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


Turn MySQL/Block and php debugging on and post your error messages here. I suspect corrupted files under modules/system/

3
csloh
Re: Problem with template set manager
  • 2004/5/18 1:11

  • csloh

  • Just popping in

  • Posts: 20

  • Since: 2003/12/17


okay, PHP Debug showed:

Fatal error: Call to a member function on a non-object in /home/virtual/site27/fst/var/www/html/room/modules/system/admin/tplsets/main.php on line 93

MYSQL/BLOCK showed:
SELECT * FROM xoops_config WHERE (conf_modid = 0 AND conf_catid = 1) ORDER BY conf_order ASC
SELECT sess_data FROM xoops_session WHERE sess_id = 'xxx I removed this xxx'
SELECT * FROM xoops_users WHERE uid=3
SELECT * FROM xoops_modules WHERE dirname = 'system'
SELECT * FROM xoops_modules WHERE dirname = 'system'
SELECT * FROM xoops_group_permission WHERE (gperm_name = 'module_admin' AND gperm_modid = 1 AND (gperm_groupid = 1 OR gperm_groupid = 2))

Did i do it right?

4
tl
Re: Problem with template set manager
  • 2004/5/18 1:27

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


MySQL/Block debug seems to be fine.

can you try to re-upload
modules/system/admin/tplsets/main.php
file?

or you can check if line 93 of your file looks like the following
Quote:

echo '<li>'.$module->getVar('name').' [<a href="admin.php?fct=tplsets&op=listtpl&tplset='.$tplsetname.'&moddir='.$moddir.'">'._LIST.'</a> (<b>'.$filecount.'</b>)]</li>';



5
tl
Re: Problem with template set manager
  • 2004/5/18 1:43

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


If re-uploading the file does not help. You may want to read this thread

cannot clone templates

Don't know if he's solved his problem and you may want to check with him. Good luck.

6
csloh
Re: Problem with template set manager
  • 2004/5/18 3:05

  • csloh

  • Just popping in

  • Posts: 20

  • Since: 2003/12/17


Thanks, will check on line 93.

Read the thread you suggested, it's probably the XCgallery, I had it installed then uninstalled it. Probably took my line 93 with it! Bad gallery.

Thanks for the help.

7
zubaa
Re: Problem with template set manager
  • 2004/5/21 7:06

  • zubaa

  • Just popping in

  • Posts: 41

  • Since: 2004/5/15


I've had the same problem Tried line 93 and everything is normal. The modules I have installed is news, games, polls, forums, sections, downloads, headlines, web links, member list, contact, partners and wffaq. I also had xcomics and myalbum P installed but unistalled them but it's still like that.
Can anyone help me?

8
zubaa
Re: Problem with template set manager
  • 2004/5/21 8:35

  • zubaa

  • Just popping in

  • Posts: 41

  • Since: 2004/5/15


Anyone?

9
tl
Re: Problem with template set manager
  • 2004/5/21 12:06

  • tl

  • Friend of XOOPS

  • Posts: 999

  • Since: 2002/6/23


You may have a wholly different set of problems. What did you get when you turn php and mysql/block debug on?

10
zubaa
Re: Problem with template set manager
  • 2004/5/21 22:48

  • zubaa

  • Just popping in

  • Posts: 41

  • Since: 2004/5/15


Hi tl

PHP debug:
Fatal errorCall to a member function on a non-object in /home/ufamily/public_html/modules/system/admin/tplsets/main.php on line 93


mysql/block debug:
SELECT FROM xoops_config WHERE (conf_modid AND conf_catid 1ORDER BY conf_order ASC 
SELECT sess_data FROM xoops_session WHERE sess_id 
'af023f3d6284467c7ad3ffdff48d6476' 
SELECT FROM xoops_users WHERE uid=
SELECT 
FROM xoops_modules WHERE dirname 'system' 
SELECT FROM xoops_modules WHERE dirname 'system' 
SELECT FROM xoops_group_permission WHERE (gperm_name 'module_admin' AND gperm_modid AND (gperm_groupid OR gperm_groupid 2))

Login

Who's Online

126 user(s) are online (65 user(s) are browsing Support Forums)


Members: 0


Guests: 126


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits