1
user999
ImageMagick and XCgallery
  • 2004/4/26 6:01

  • user999

  • Just popping in

  • Posts: 28

  • Since: 2004/3/12


Hi,

I installed ImageMagick in my Windows 2000 webserver to use it with the xcgallery module. But the module doesn't recognize the location of ImageMagick. I also used XOOPS Gallery to check ImageMagick configuration but it gave me the following errors

"....

You told the config wizard that your ImageMagick binaries live here:

C:\ImageMagick-6.0.0-Q16
If that is not right (or if it is blank), re-run the configuration wizard and enter a location for ImageMagick.


We are going to test each ImageMagick binary individually. If you see errors, you should click here to see more details
Checking C:\ImageMagick-6.0.0-Q16\identify.exe
Error! (Expected status: 0, but actually received status: -1)

Checking C:\ImageMagick-6.0.0-Q16\convert.exe
Error! (Expected status: 0, but actually received status: -1)

Checking C:\ImageMagick-6.0.0-Q16\composite.exe
Error! (Expected status: 0, but actually received status: -1)
... "

Can someone tell me how to resolve this error. If possible pls show me how to set up ImageMagick on Windows 2000 so that I can use with XCgallery.

Just a thought, could this problem be related to my PHP configuration? If so, how can I resolve it.

Looking for a solution ASAP. Help appreciated.

Thanks


2
user999
Re: ImageMagick and XCgallery
  • 2004/4/29 1:39

  • user999

  • Just popping in

  • Posts: 28

  • Since: 2004/3/12


I hope someone has a reply to my question above. I am really looking for some help here. I have checked the xcgallery site too to get info but haven't received any reply there.

Pls help.

Thanks

3
itcenter
Re: ImageMagick and XCgallery
  • 2004/4/29 7:53

  • itcenter

  • Just popping in

  • Posts: 16

  • Since: 2004/3/8 0


If you want to use imagemagick with xcgal in win2000,you have to give correct right(executive right) of the file "C:\WINDOWS\system32\cmd.exe" to user "IUSER_COMPUTERNAME" so that imagemagick.exe can be run by xcgal;

4
user999
Re: ImageMagick and XCgallery
  • 2004/4/30 6:04

  • user999

  • Just popping in

  • Posts: 28

  • Since: 2004/3/12


Thanks for the reply. I made the changes you suggested. Now XOOPS seems to recognize Imagemagic but when I try to upload some picture using xcgallery I get the following msg :

"The picture 'albums/userpics/10001/logo.gif' can't be inserted in the album

Error executing ImageMagick - Return value: 1

Cmd line :
C:\ImageMagick-6.0.0-Q16convert -quality 80 -antialias -geometry 99x99 "D:\Inetpub\wwwroot\..."

The convert program said:
'C:\ImageMagick-6.0.0-Q16convert' is not recognized as an internal or external command,
operable program or batch file."

Can you tell why I get this error. I can't upload any images. Pls Help

Thanks

5
itcenter
Re: ImageMagick and XCgallery
  • 2004/5/3 0:23

  • itcenter

  • Just popping in

  • Posts: 16

  • Since: 2004/3/8 0


have you given the correct path name for imagemagick program?have you set correct file permissions?

6
Stewdio
Re: ImageMagick and XCgallery
  • 2004/5/3 0:32

  • Stewdio

  • Community Support Member

  • Posts: 1560

  • Since: 2003/5/7 1


CHMOD your directory to 777 and see if that helps. On IIS you will have to allow read/write/execute to the right groups as well.

If that fails, you may need to use GD version 1 or 2

Login

Who's Online

45 user(s) are online (27 user(s) are browsing Support Forums)


Members: 0


Guests: 45


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Oct 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits