1
Grumpy
Templates not updating??!!??
  • 2004/5/2 6:02

  • Grumpy

  • Just popping in

  • Posts: 10

  • Since: 2003/7/18


I'm sure there is a simple answer, but I have yet to find it.

I just installed the new I-Stats module and one of the steps is to add this:

<script type="text/Javascript">
<!--
istat = new Image(1,1);
istat.src = "http://www.ladeda.com/modules/istats/include/counter.php?sw="+screen.width+"&sc="+screen.colorDepth+"&refer="+document.referrer+"&page="+location.href;
//-->
</script>

To the "Meta Tags and Footer" section. Well when I do this, it doesn't update. The footer information doesn't change on any of my pages...

I have cleared the template_c folder
Checked file/folder permissions
I have installed XOOPS again
I have tested this on another XOOPS site running on the same server and it updated fine, once you clear the template_c folder.
I reset my site back to the default template set (the one I run is just a clone of the default anyways) and the theme is the default.
I tried cloning the default theme set and using that one

If if just add some text to any of the fields, it doesn't update. It claims it's added to the database, but doesn't seem to pull it, the data is there when I go back and check...

Anyone have any ideas?

2
myc1229
Re: Templates not updating??!!??
  • 2004/5/2 6:37

  • myc1229

  • Just popping in

  • Posts: 30

  • Since: 2004/4/10


In themes/your-theme directory, find file theme.html, then find the following code at the end of the file:
<table cellspacing="0">
    <
tr id="footerbar">
      <
td><a href="https://xoops.org/" target="_blank"><img src="<{$xoops_imageurl}>poweredby.gif" alt="" /></a></td>
    </
tr>
  </
table>

and change it to:
<table cellspacing="0">
    <
tr id="footerbar">
      <
td><a href="your-site-address" target="_blank"><{$xoops_footer}></a></td>
    </
tr>
  </
table>

3
Mithrandir
Re: Templates not updating??!!??

When modifying code in your theme, enable the update in XOOPS System Admin -> Preferences -> General Settings -> "Update module templates from theme folder[...]"

When you are done modifying, turn it off again.

4
sylvainb
Re: Templates not updating??!!??
  • 2004/5/2 8:05

  • sylvainb

  • Not too shy to talk

  • Posts: 168

  • Since: 2003/2/11


Well, first hello everybody.
I find very funny to make support to some modules I adapted here, but do you know I have a forum too??
It'll be (sometimes) easier to give you some advices.
But, as myc1229 says and as I said into xoops2_install.txt, you have to put this portion of code nor into meta-tags/footer in the XOOPS administration section, but in the theme.html file include into your XOOPS themes folder.
Once it's done, you can do what Mithrandir said or simply go (throught FTP) into the templates_c folder and delete the theme_name^theme.html file.
I only let the original documentation in it, because of other things you can do with the code, but to simply install the module just read the xoops2_install.txt.

Friendly Yours

5
Grumpy
Re: Templates not updating??!!??
  • 2004/5/2 17:05

  • Grumpy

  • Just popping in

  • Posts: 10

  • Since: 2003/7/18


Thanks myc1229.

My only question now is was this an error in the theme.html or...

?

Seems to be working fine now.

sylbainv

No offence, the reason I didn't post this in your forum is because I felt this was an XOOPS issue, not anything to do with your fine istats module.

Or it was an issue with me

Thanks again

6
sylvainb
Re: Templates not updating??!!??
  • 2004/5/2 17:20

  • sylvainb

  • Not too shy to talk

  • Posts: 168

  • Since: 2003/2/11



Don't worry Grumpy, I didn't take any offence.
I really find this situation very funny and I like to make some support into this forum.

Login

Who's Online

73 user(s) are online (47 user(s) are browsing Support Forums)


Members: 0


Guests: 73


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits