11
catalin
Re: Blank Page after login - only users
  • 2003/12/20 18:33

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


k, one more clue

if mysite/user.php?op=logout

after loging in and the blank page apears, this is a succes, i mean it logs me out and displayes the page

when logining in, it redirect to index.php, but doesn`t show a thing, nothin, none, 0, nema, PUFF

this is weird ... anyone ... any ideas ?!

12
wtravel
Re: Blank Page after login - only users

Also I doubt that it is your xoopsjs file causing the problems, since that one has only general code for the site.

Regards,

Martijn

13
catalin
Re: Blank Page after login - only users
  • 2003/12/21 5:32

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


nope, nothing

come on guys ... help me here ... BTW i think this is a general XOOPS problem ( i think )

i know php ( for crying out loud ) but this is over my limits ...

14
catalin
Re: Blank Page after login - only users
  • 2003/12/21 6:16

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


so here is the gig

being a normal user ... i can`t login

being and Adm or Mod ... i can login ...

were is the GIG ?!?

15
catalin
Re: Blank Page after login - only users - Succes
  • 2003/12/21 7:18

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


k, i managed, i`m happy :) :) :) :)

in checklogin.php

$user_theme = $user->getVar('theme');
if (in_array($user_theme, $xoopsConfig['theme_set_allowed'])) {
$HTTP_SESSION_VARS['xoopsUserTheme'] = $user_theme;

changed to

$user_theme = $user->getVar('theme');
if (in_array($user_theme, $xoopsConfig['theme_set_allowed'])) {
$HTTP_SESSION_VARS['xoopsUserTheme'] = seo12;

i`ve changed the $user_theme to seo12 ( the site theme ). On regoster normal users don`t chose a theme when they register, and that makes the blank pages. Now, when they login this makes seo12 the default theme for theme. Wel this is bad because the christmas theme i have in mind ... well will fall because i haven`t the time to configure the hole XOOPS for it ...

16
wtravel
Re: Blank Page after login - only users - Succes

Hi Catalin,

Glad to see that you worked around the problem . Still this is a weird problem. I have multiple themes and never had problems with that part of the code.

I checked my user table and even one of my test accounts has no theme in the table, yet logging in is no problem. It automatically selects the default theme in general settings. Can you verify if that value is set to seo12?

Regards,

Martijn


17
catalin
Re: Blank Page after login - only users - Succes
  • 2003/12/21 17:58

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


log in again ... k ... this time ... enable cookies ... o and BTW ... IT IS ... i made another account and tested it ...

18
wtravel
Re: Blank Page after login - only users - Succes

I see an error message upon login. Maybe it is better to define the constant first. You can try this instead.

//$user_theme = $user->getVar('theme');
$user_theme = seo12;
if (in_array($user_theme, $xoopsConfig['theme_set_allowed'])) {
$HTTP_SESSION_VARS['xoopsUserTheme'] = $user_theme;

Regards,

Martijn

19
catalin
Re: Blank Page after login - only users - Succes
  • 2003/12/21 19:28

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


the message is displayed ... but ban you login ?!

i can with those 2 test accounts ...

the message will be gone in a while

20
wtravel
Re: Blank Page after login - only users - Succes

I was able to login with the test account you posted.

Martijn

Login

Username:
Password:

Lost Password? Register now!

Who's Online

74 user(s) are online (51 user(s) are browsing Support Forums)


Members: 0


Guests: 74


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits