1
zivXP
wgevents
  • 2023/6/27 19:02

  • zivXP

  • Not too shy to talk

  • Posts: 113

  • Since: 2006/2/9 1


Why are there "crooked" modules marked as "Stable" in the repository?

Downloaded and installed the wgevents-1.0.6-stable module. And templates are a solid error : SmartyCompilerException: Syntax error in the template.

People (especially beginners) are trying to install such modules. They see that it doesn't work. And the reputation of xoops is falling.

For example , it was prescribed:<{xoAppUrl /modules/system/admin.php?fct=blocksadmin&op=edit&bid=}><{$block.id}>" title="<{$smarty.const.THEME_TOOLBAR_EDIT_THIS_BLOCK}>">

, and you need: <{xoAppUrl '/modules/system/admin.php?fct=blocksadmin&op=edit&bid='}><{$block.id}>" title="<{$smarty.const.THEME_TOOLBAR_EDIT_THIS_BLOCK}>">

And other errors that cause the site not to load.

P.S. It probably depends on the version of xoops.

2
Mamba
Re: wgevents
  • 2023/6/27 23:11

  • Mamba

  • Moderator

  • Posts: 11373

  • Since: 2004/4/23


Thanks for the testing and for reporting the error.

But please include the version of XOOPS and your PHP version, so the module developers can try to reproduce the error.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
goffy
Re: wgevents
  • 2023/6/28 8:18

  • goffy

  • Just can't stay away

  • Posts: 535

  • Since: 2010/12/27


hi

1.0.6 stable is running only under 2.5.11 Beta1 or 2.5.11 Beta2, because 1.0.6 include Smarty2

if you are testing 2.5.11 RC1 or RC2 then you must take the last version from github (1.0.7 RC1) which includes Smarty3

as soon as 2.5.11 is released as stable I will release alson a stable version of wgevents

4
zivXP
Re: wgevents
  • 2023/6/28 11:20

  • zivXP

  • Not too shy to talk

  • Posts: 113

  • Since: 2006/2/9 1


Quote:

goffy wrote:
hi

1.0.6 stable is running only under 2.5.11 Beta1 or 2.5.11 Beta2, because 1.0.6 include Smarty2

if you are testing 2.5.11 RC1 or RC2 then you must take the last version from github (1.0.7 RC1) which includes Smarty3

as soon as 2.5.11 is released as stable I will release alson a stable version of wgevents


Thank you! It turns out that this is the problem. And I kept trying to edit the templates. wtgevents 1.0.7 RC1 has been installed and I am testing it.

You have a lot of interesting modules. Will other modules be updated as well?

5
goffy
Re: wgevents
  • 2023/7/3 11:28

  • goffy

  • Just can't stay away

  • Posts: 535

  • Since: 2010/12/27


yes, of course :)

Login

Who's Online

627 user(s) are online (74 user(s) are browsing Support Forums)


Members: 0


Guests: 627


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits