xoops forums

Mamba

Moderator
Posted on: 2015/11/16 10:25
Mamba
Mamba (Show more)
Moderator
Posts: 10760
Since: 2004/4/23
#1

XOOPS NewBB 4.33 RC-10 available for testing

We would like to finalize NewBB module for XOOPS 2.5.7.1

Therefore we're making the current version NewBB 4.33 RC-10 available for testing.

You can download it from GitHub:

https://github.com/XoopsModules25x/newbb/releases

Please help us with testing, and most importantly, go ahead and fork it, and help us with development. This will be also a good practice for you on how to work with GitHub!

This is a testing and bug fixing phase, i.e. we don't anticipate any new features being added. But we would like to make it as solid as possible.

This release, as well as upcoming releases for all other modules, are focusing on and will be certified for XOOPS 2.5.7.1 and PHP 5.4+
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Roby73

Friend of XOOPS
Posted on: 2015/11/24 0:35
Roby73
Roby73 (Show more)
Friend of XOOPS
Posts: 262
Since: 2011/6/15
#2

Re: XOOPS NewBB 4.33 RC-10 available for testing

Thank you Mamba!.
I have installed the module and i obtained this error:

Array to string conversion nel file /modules/newbb/include/module.php at line 52

Is impossible add new moderator after first selection.
In admin_forum_manager.php there this deprecated class:
Class 'XoopsTree' is deprecated, check 'XoopsObjectTree' in tree.php

Mamba

Moderator
Posted on: 2015/11/24 2:10
Mamba
Mamba (Show more)
Moderator
Posts: 10760
Since: 2004/4/23
#3

Re: XOOPS NewBB 4.33 RC-10 available for testing

PHP and XOOPS version?

Quote:
Array to string conversion nel file /modules/newbb/include/module.php at line 52

I assume, it's the same as this in GitHub. It has been just closed.

Quote:
Is impossible add new moderator after first selection.

Can you check this report on GitHub, because I couldn't replicate it. I need to understand the issue better, and need the steps to replicate it.

Quote:
Class 'XoopsTree' is deprecated, check 'XoopsObjectTree' in tree.php

Ignore it
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

CBung

Just popping in
Posted on: 2016/2/13 19:09
CBung
CBung (Show more)
Just popping in
Posts: 14
Since: 2009/3/4 5
#4

Re: XOOPS NewBB 4.33 RC-10 available for testing

How does one upgrade a module? I have CBB 3.08 is NewBB the same thing?

Edit 1: I see that the CBB 3.08 folder in my modules/ is "newbb/" so I guess it is indeed the same thing.

Edit 2: I found the readme in the zip on how to upgrade (which btw should be in the new https://mambax7.gitbooks.io/xoops-newb ... ent/en/book/1install.html ).... Here goes nothing...

Mamba

Moderator
Posted on: 2016/2/14 17:47
Mamba
Mamba (Show more)
Moderator
Posts: 10760
Since: 2004/4/23
#5

Re: XOOPS NewBB 4.33 RC-10 available for testing

Thanks for the feedback.

I'll add a section on "Upgrading a module"
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

user2222

Just popping in
Posted on: 12/10 10:44
user2222
user2222 (Show more)
Just popping in
Posts: 6
Since: 2007/1/22
#6

Re: XOOPS NewBB 4.33 RC-10 available for testing

Hi Mamba, and other Xoops Contributors,

I have 2 site on the same server, with different version of the FORUM. I need a working Forum which is the most important module in my site.

1 - http://vps555516.ovh.net/djsite/modules/newbb/ uses the Xoops Forum module.
This site was very active until 2011, and the forum (newbb 1) does not work anymore (13 000 members).
We can not navigate in conversations, and we can not create discussions.
Xoops was upgrade to 2.5.9 and is uses PHP 7 (the former site in 2011 used and also version of PHP).
The Xoops/Php migration make the forum stop working.

2 - http://vps555516.ovh.net/xoopstest/modules/newbb/ uses the lasted Xoops Forum (newbb 4.33) on Xoops 2.5.9.
The forum has important bugs that are not solved. I created an issue here:
https://github.com/XoopsModules25x/newbb/issues/57
It was installed 2 months ago.

I need a working Forum on Xoops 2.5.9, while keeping the conversions that existed in 2011.

Please, What solution do I have to have a working forum?
What kind of information can I provide to you or any member who want to help?

Thank you for you support.
Kind Regards
Eddy Cingala