xoops forums

djsherren

Just popping in
Posted on: 10/3 0:41
djsherren
djsherren (Show more)
Just popping in
Posts: 11
Since: 2010/11/18
#1

Having Trouble Installing xmcontent 0.31on WAMP server

Having a curious problem when trying to install xmcontent 0.31 on a test site on a local WAMP server

In the admin control panel on the 'modules' page when clicking 'Install modules' button to get to the page to select the module to install, an error occurs. The error reports are as follows:

PHP 7.0.0

Error : Error: Call to a member function getHandler() on boolean

PHP 5.6.16

Fatal error: Call to a member function getHandler() on boolean in C:\localhost\testsite\modules\xmcontent\xoops_version.php on line 123

If the xmcontent folder is removed from the site 'modules' folder, then installation of other xoops modules occurs with no errors. However as long as xmcontent is in the folder you can not get past the 'Install modules' to select a module to install without the site having an error.

We have been able to install xmcontent 0.21 on the local server with no issue and are eager to get a look at the latest version. We removed version 0.21 before attempting to install version 0.31. This problem also occurs on a fresh xoops installation which has not had version 0.21 previously installed.

Info on our local server is as follows.

WAMP Server 3.0.0 running on Windows 10 Home, version 1803, 64 bit

XOOPS Version XOOPS 2.5.9
PHP Version 5.6.16 / 7.0.0
mySQL Version 5.7.9
Server API apache2handler
OS WINNT
fsockopen On
post_max_size 50M
max_input_time 60
output_buffering 4096
max_execution_time 120
memory_limit 256M
file_uploads On
upload_max_filesize 50M

Comments and suggestions would be appreciated.

Mage

Core Developer
Posted on: 10/3 7:31
Mage
Mage (Show more)
Core Developer
Posts: 171
Since: 2009/8/2 1
#2

Re: Having Trouble Installing xmcontent 0.31on WAMP server

Thank you for this return, I reproduced the bug. I publish in the day a corectif

Mage

Core Developer
Posted on: 10/3 8:04
Mage
Mage (Show more)
Core Developer
Posts: 171
Since: 2009/8/2 1
#3

Re: Having Trouble Installing xmcontent 0.31on WAMP server

Fixed:
https://github.com/GregMage/xmcontent/releases/tag/V0.32

djsherren

Just popping in
Posted on: 10/3 10:40
djsherren
djsherren (Show more)
Just popping in
Posts: 11
Since: 2010/11/18
#4

Re: Having Trouble Installing xmcontent 0.31on WAMP server

The module is properly installing now. Looks great so far! Thank you very much for the quick fix!

Merci beaucoup!