xoops forums

blackrx

Quite a regular
Posted on: 2017/8/2 5:42
blackrx
blackrx (Show more)
Quite a regular
Posts: 227
Since: 2008/2/5 1
#1

Help with extcal today's event and upcoming event block

XOOPS extCal 2.39 RC-1
XOOPS Version XOOPS 2.5.9
PHP Version 5.6.31
mySQL Version 5.6.35


Is it possible to show something like

No Today's event or No Upcoming event if theres no event for today or upcoming event

right now if theres no event ..both block will not appear

moss

Just popping in
Posted on: 9/12 14:57
moss
moss (Show more)
Just popping in
Posts: 37
Since: 2009/10/28
#2

Re: Help with extcal today's event and upcoming event block

I have the same problem
Blocks don't work... No errors in debug....

Any idea ?

XOOPS extCal 2.39 Final
XOOPS Version XOOPS 2.5.9
PHP Version 7.1.21
Mysqlnd 5.0.12-Dev

Mamba

Moderator
Posted on: 9/12 15:19
Mamba
Mamba (Show more)
Moderator
Posts: 10610
Since: 2004/4/23
#3

Re: Help with extcal today's event and upcoming event block

New installation?

Existing one? If yes, did it work before?
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

moss

Just popping in
Posted on: 9/12 15:35
moss
moss (Show more)
Just popping in
Posts: 37
Since: 2009/10/28
#4

Re: Help with extcal today

New installation.

I have an old xoops 2.5.0
So I install a fresh xoops 2.5.9, and new updated module. I just import my content from my old table in the new one.

When I edit block in admin, I have no module option block (only classical block option), and when I activate block, It doesn't appear on my homepage

Mamba

Moderator
Posted on: 9/12 15:47
Mamba
Mamba (Show more)
Moderator
Posts: 10610
Since: 2004/4/23
#5

Re: Help with extcal today

What old version of extcal did you have?

Where did you download the new version from? What version is it?
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

moss

Just popping in
Posted on: 9/12 15:55
moss
moss (Show more)
Just popping in
Posts: 37
Since: 2009/10/28
#6

Re: Help with extcal today

It was 2.38 with xoops 2.5.0

I install 2.39b Final from here : https://github.com/mambax7/extcal/releases

Mamba

Moderator
Posted on: 9/12 16:17
Mamba
Mamba (Show more)
Moderator
Posts: 10610
Since: 2004/4/23
#7

Re: Help with extcal today

Email me your data and I'll take a look. Check your PM - I just sent you my email address.
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

Mamba

Moderator
Posted on: 9/13 18:20
Mamba
Mamba (Show more)
Moderator
Posts: 10610
Since: 2004/4/23
#8

Re: Help with extcal today

Thanks for sending the data.

The potential problem that I saw is that you need to set the permissions for the categories in the "Permissions" tab.

You import the data for the categories for the module, but the permissions are set at the XOOPS level, therefore they are not imported.

Let me know if that helped to resolve it...
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

moss

Just popping in
Posted on: 9/13 21:48
moss
moss (Show more)
Just popping in
Posts: 37
Since: 2009/10/28
#9

Re: Help with extcal today's event and upcoming event block

Unfortunately no.
I set permissions then I created a New categorie, and New event. I checked after that permission is always ok. And it doesn’t work. I don’t think that problem comes from import but more from blocks itself. Because when i try to edit block, i don’t have any options as before. And this is for all block of extcal.

Mamba

Moderator
Posted on: 9/14 10:10
Mamba
Mamba (Show more)
Moderator
Posts: 10610
Since: 2004/4/23
#10

Re: Help with extcal today's event and upcoming event block

I tried again, and it works for me.

These are the steps that I did:

1) I installed fresh extCal

2) In your data file that you emailed me, I have removed all the "CREATE TABLE" parts, etc. and only left the "INSERT INTO" parts

3) I changed the prefix of the tables in all "INSERT INTO" to the one I have in my database:
Quote:
INSERT INTO `xa79_extcal_cat`

4) I imported the data into the DB

5) I went to "Permissions" tab and adjusted the permission for all categories in the sub-sections:
- View permission
- Submit permission
- Auto-approve permission
- Edit permission

6) Went to the blocks and activated them

7) The result in the front page:

Resized Image

Can you follow these steps and tell me if it worked?
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs