51
Mamba
Re: animal pedigree database, problems moving to new server
  • 2016/7/9 2:32

  • Mamba

  • Moderator

  • Posts: 11209

  • Since: 2004/4/23


Thank you so much for reporting the fix.

Pedigree is still on my TODO list
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

52
supergran
Re: animal pedigree database, problems moving to new server
  • 2016/7/9 23:33

  • supergran

  • Friend of XOOPS

  • Posts: 25

  • Since: 2011/6/6 1


Sorry also that it's taking me so long. Once I have the site up I'll get into the generic code and start on the tutorial. At least I'l learning more about xoops and appreciating it's differences to other CMSs. I really like it. Much more important that you concentrate on the core. I'm looking forward to 2.6.
Jan

53
Delen
Re: animal pedigree database, problems moving to new server
  • 2017/3/27 11:13

  • Delen

  • Just popping in

  • Posts: 2

  • Since: 2017/3/27


Hi,

I am currently maintaining a large animal pedigree database on a very aged XOOPS installation with one of the oldest modules of animal pedigree. Everything is working well, but now my host forces us to update Cpanel, MySQL and PHP on our VPS, which is of course correct with regard to security. However, I'm afraid the old module and XOOPS installation won't be able to work properly on a newer PHP and MySQL.

We currently have a server with:

PHP 5.2.17
MySQL 5.0.96-community
CPanel 56.0 (build 46)
Apache Version 2.2.19
XOOPS Version - XOOPS 2.3.0

The module:

Programming : James Cotton
Design & Layout : Ton van der Hagen
Version : 1.29

Could you tell us what modules you have running on which forms of XOOPS and with which PHP etc versions and which function without problems? Or, the other way around, up to which PHP/Cpanel/MySQL versions can I have our server updated, before this old module and XOOPs version will grind to a halt?

The database, as of now, is behind a firewall and password screen, accessible only to people working on it, and kept in its own sandbox, so that nothing much can happen if security is breached. I have been following the threads here, waiting for a signal that animal pedigree has finally been firmly and successfully married to an up to date version of XOOPS.

If I could I would pour some money into this, but we're not rich. What I can tell you however is that animal pedigree is the very last functional, animal pedigree oriented openly available database software a database maintainer can host in a self-determined manner on their own server.

ALL other such software is run as a hosting service on the servers of software providers at a monthly rent, with data being in the hands of the providers. Or there are business-level solutions sold to the big breeding organisations. There is no solution left - other than animal pedigree - which caters to the small breeding organisation or pedigree researcher. I know this, because I have been looking, and looking hard. There is none except this.

So, should you actually bring animal pedigree up to date, should you manage to add several much needed functions and calculations to it on top of it (which I am sure other users and I can help you find out about), then this module would make XOOPS the go-to solution for animal breeders all over the world. Wouldn't that be something helpful for XOOPS?

Cheers,

Delen

54
Mamba
Re: animal pedigree database, problems moving to new server
  • 2017/3/27 13:10

  • Mamba

  • Moderator

  • Posts: 11209

  • Since: 2004/4/23


I am working on upgrading a Pedigree module for one of my clients, which has several customizations, so it won't be available for public.

There are still few conversion issues to be resolved, but it runs currently on:

PHP 7.1.3
XOOPS 2.5.9 Beta 2

I hope to have more time in the summer, so hopefully I'll be able to get back to the generic module we have here.

Check you email...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

55
Delen
Re: animal pedigree database, problems moving to new server
  • 2017/3/28 5:02

  • Delen

  • Just popping in

  • Posts: 2

  • Since: 2017/3/27


Hi,

thank you for that offer, but if I could invest money in any larger amount, I would have long ago bought a proprietory system made to measure to spare us the fear of losing data. I'm unfortunately not rich, nor are any of the enthusiasts rich who're trying to research the breed database we're maintaining.

Proprietory solutions are available galore, fully instrumentalised with state of art calculations. The intrigue of Animal Pedigree is that it was open to everyone and could be so again.

Cheers,

Delen

56
Mamba
Re: animal pedigree database, problems moving to new server
  • 2017/3/28 11:51

  • Mamba

  • Moderator

  • Posts: 11209

  • Since: 2004/4/23


The Pedigree module is Open Source, i.e. you or anybody else can jump in and make the required changes. Or you can hire somebody.

I wish I would have the money in order to spend all my time to program for free. Unfortunately, I also have to pay bills for food and housing

Right now I'm very busy with other projects, incl. paid ones, so maybe during summer I'll be able to look at the module.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

57
abfed
Compatibility
  • 2018/5/6 23:10

  • abfed

  • Just popping in

  • Posts: 3

  • Since: 2018/5/6 2


James -

This is an absolutely incredible module and it will be invaluable to us.

However, I am getting all kinds of errors after installing the module.

Running php 7.2

Xoops 2.5.9 fresh install with no add-ons.
Have tried both Pedigree Master Alpha 6 as well as Alpha 8.

With Alpha 8 getting this error:
Error: Error: Call to a member function getVar() on boolean in file /modules/pedigree-master/index.php line 52

With Alpha 6 was getting an error about Module Handler "trash" as not defined - can't recall exact wording. Probably this - $pedigreeTrashHandler = xoops_getModuleHandler('trash', $thisDirname);

Could you let me know which combination of Xoops version and Pedigree Master versions are currently compatible?

Thank you so much!

58
abfed
Re: Compatibility
  • 2018/5/7 1:48

  • abfed

  • Just popping in

  • Posts: 3

  • Since: 2018/5/6 2


Micheal - sorry I called you James erroneously.

59
Bleekk
Re: Compatibility
  • 2018/5/7 6:13

  • Bleekk

  • Theme Designer

  • Posts: 937

  • Since: 2002/12/14


Can you deinstall the module, then rename the folder from "pedigree-master" to "pedigree".
This "-master" part is generated when you download the module from github

60
abfed
Re: Compatibility
  • 2018/5/14 3:58

  • abfed

  • Just popping in

  • Posts: 3

  • Since: 2018/5/6 2


Thank you. That has helped resolve some issues . Capitalization of files seems to be all over the place and fixing that has further allowed more things to actually function. This module seems to have so much potential if it would actually just work..... I've tried to understand some of the problems but have not been able to find a go-to resource that explains the various functions so that I could try to debug some of this myself.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

85 user(s) are online (64 user(s) are browsing Support Forums)


Members: 0


Guests: 85


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits