1
LonesomeTwin
Just not good enough?

Hello everybody.

I'm looking to upgrade my old forum site so that it has more web content and more importantly works well on a smartphone. It's currently V2.5.1a, is it safe/possible to upgrade it to a newer version and then install a responsive theme over it without losing all the posts? While I'm at it would also like an auto-resizer so that people don't keep downloading 2M pics because they can't resize them themselves. One option I've been exploring is redoing the whole thing in Wordpress and then trying to port the database over, but WP forums are pretty rubbish.

Many thanks for any input - Steve

The Lonesome Twin

ps. On previewing this post the text box spread over the edge of the screen, doesn't inspire confidence.

2
geekwright
Re: Just not good enough?

We spend a great deal of effort in our coding and testing to make sure that there is a path forward from version to version. There will be hicups from time to time, but in the end, things work.

As an example, this site is running our current development branch of XOOPS 2.5.9, currently still in a beta stage. It is near release, but not quite. This site has data preserved over many years, moving forward with each new version. We have a great deal of confidence in our product.

Here are a few things to keep in mind as you plan your upgrade.

Make backups of your full site and your database before starting. You can always restore service by restoring you backups if things don't work as expected.

Check for more current versions of the modules you use. Newer versions of modules may fix issues that occur because of changing technologies, or be tailored specifically to support newer versions of XOOPS. Start with upgrading XOOPS, and then update the modules individually. Most modules have the same attention paid to upgrades as XOOPS does.

As a community, we have a lot of experience in upgrading, and most of us are happy to share our expertise and help out.

Looking at your site (BTW, that is an awesome topic focus!) it looks like it should go smoothly. XOOPS 2.5.1 is old, but no where near the oldest we've seen. And the modules you use are still maintained and have recent updates.

If you decide to go ahead with an upgrade, your site could be responsive and mobile ready fairly quickly.


PS - regarding the long lines on preview, there seems to be a simple template issue in newbb, nothing to serious and it should be resolved soon.


Quote:

LonesomeTwin wrote:
Hello everybody.

I'm looking to upgrade my old forum site so that it has more web content and more importantly works well on a smartphone. It's currently V2.5.1a, is it safe/possible to upgrade it to a newer version and then install a responsive theme over it without losing all the posts? While I'm at it would also like an auto-resizer so that people don't keep downloading 2M pics because they can't resize them themselves. One option I've been exploring is redoing the whole thing in Wordpress and then trying to port the database over, but WP forums are pretty rubbish.

Many thanks for any input - Steve

The Lonesome Twin

ps. On previewing this post the text box spread over the edge of the screen, doesn't inspire confidence.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

70 user(s) are online (42 user(s) are browsing Support Forums)


Members: 0


Guests: 70


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits