1
Zirafka
ImageManager and group permissions
  • 2015/5/21 16:14

  • Zirafka

  • Just popping in

  • Posts: 70

  • Since: 2008/8/9 1


I solves the problem with ImageManager.
On my web registered user are have permission for imagemanager. It's OK. I want to anonymous users could not access imagemanager, but anonymous have access.
All groups have permission like this:

Resized Image


But anonymous see imagemanager like this:

Resized Image


Interestingly, the category XOOPS (cat_id=10) is working properly.

Do you have an idea for a solution?


XOOPS: XOOPS 2.5.7.1
PHP: 5.3.2-1ubuntu4.30
mySQL: 5.1.73-0ubuntu0.10.04.1-log
API: apache2handler
OS: Linux
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen On
fsockopen On
post_max_size 100M
max_input_time 60
output_buffering 4096
max_execution_time 30
memory_limit 128M
file_uploads On
upload_max_filesize 100M

2
JulioNC
Re: ImageManager and group permissions
  • 2015/5/22 16:06

  • JulioNC

  • Quite a regular

  • Posts: 239

  • Since: 2004/10/8


Please. Update the system module and groups section.
Also, turn on debug mode to see what happen.

3
Zirafka
Re: ImageManager and group permissions
  • 2015/5/22 19:30

  • Zirafka

  • Just popping in

  • Posts: 70

  • Since: 2008/8/9 1


Update system module - OK
Update group section - how?

Turn on debug mode - OK
How to turn debug mode for anonymous access?

debug_mode = 1 - debug on page, but only for administrator
debug_mode = 2 - debug on window, but only for administrator
debug_mode = 3 - smarty debug, for all

Sorry for my questions, but I "begginer" :)

4
JulioNC
Re: ImageManager and group permissions
  • 2015/5/23 0:49

  • JulioNC

  • Quite a regular

  • Posts: 239

  • Since: 2004/10/8


/modules/system/admin.php?fct=groups

Module > system > Groups

Editing the Anonymous group you want according to the permissions.
Check it. Then, turn on debug-mode (option 3) to see log.

5
Zirafka
Re: ImageManager and group permissions
  • 2015/5/23 3:47

  • Zirafka

  • Just popping in

  • Posts: 70

  • Since: 2008/8/9 1


Edit anonymous group - OK, but without effect

Smarty Debug Console

included templates 
config files (load time in seconds)
db:system_imagemanager.html (0.00061) (total

assigned template variables
{$SCRIPT_NAME}    /imagemanager.php
{$cat_options}    <option value="0" selected="selected"...
{
$lang_add}    Přidat
{$lang_align}    Zarovnání
{$lang_close}    Zavřít okno
{$lang_go}    Provést
{$lang_imgmanager}    Správce obrázků
{$show_cat}    0
{$sitename}    Žirafoviny.cz
{$target}    com_text
{$xoops_charset}    UTF-8
{$xoops_langcode}    cs
{$xoops_rootpath}    /home/zirafoviny/html
{$xoops_upload_url}    http://www.zirafoviny.cz/uploads
{$xoops_url}    http://www.zirafoviny.cz
{$xoops_version}    XOOPS 2.5.7.1
{$xsize}    1000
{$ysize}    700

assigned config file variables 
(outer template scope)
{
#files#}    Array (0)
{#vars#}    Array (0)

6
Zirafka
Re: ImageManager and group permissions
  • 2015/5/23 14:15

  • Zirafka

  • Just popping in

  • Posts: 70

  • Since: 2008/8/9 1


Problem is not in imagemanager, but in database.

/modules/system/admin.php?fct=groups do not write permission to database.

I don´t know why :-/

Login

Who's Online

893 user(s) are online (84 user(s) are browsing Support Forums)


Members: 0


Guests: 893


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits