11
timgno
Re: XOOPS 2.5.7 Final Release Issues
  • 2014/6/17 9:41

  • timgno

  • Module Developer

  • Posts: 1504

  • Since: 2007/6/21


I'm sorry

I made a mistake!

But the download of the green button sourceforge leads to xoops 2.5.6, not 2.5.7

I did not realize was that the release list

12
geekwright
Re: XOOPS 2.5.7 Final Release Issues

Quote:

timgno wrote:
...
I made a mistake!

But the download of the green button sourceforge leads to xoops 2.5.6, not 2.5.7
...


I think we made the mistake. The green button now points to 2.5.7.

Thanks!

13
AngeloRocha
Re: XOOPS 2.5.7 Final Release Issues

Error in PM Module:

Quote:
Warning: include_once(C:\Users\Angelo Rocha\Documents\wamp\www\x257\modules\pm\admin../../../include/cp_header.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in C:\Users\Angelo Rocha\Documents\wamp\www\x257\modules\pm\admin\about.php on line 20


Quote:
( ! ) Fatal error: Call to undefined function xoops_load() in C:\Users\Angelo Rocha\Documents\wamp\www\x257\class\xoopsformloader.php on line 20


modules/pm/admin/about.php

Warning in Profile Module:
Quote:

Warning: include_once(C:\Users\Angelo Rocha\Documents\wamp\www\x257\modules\profile\admin../../../include/cp_header.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in C:\Users\Angelo Rocha\Documents\wamp\www\x257\modules\profile\admin\about.php on line 20


/modules/profile/admin/about.php


PHP 5.3.13

New Installation

14
geekwright
Re: XOOPS 2.5.7 Final Release Issues

Looks like there is a slash missing in line 20 of modules/pm/admin/about.php

I should read:
include_once dirname(__FILE__) . '/../../../include/cp_header.php';

Shouldn't take too long to get this patched.

15
bumpeboy
Re: XOOPS 2.5.7 Final Release Issues
  • 2014/6/18 0:03

  • bumpeboy

  • Friend of XOOPS

  • Posts: 170

  • Since: 2008/10/4


Thanks for this however i am stuck on install/page_dbconnection.php the installation is not going any further just getting back to the sam page after i enter the DB details.

I have noticed that my folder does not have mainfile.php and its not mentioned on the files to change permission. Is this something new or is it an error coz all the years i have installed xoops there is always mainfile.php that i change the permission to 777 but on this one its not there.

How else can i proceed with the instalment? Anyone with the same problem?

Thanks



Mamba
1) Please report all issues it the Support Forums (in this thread)

2) Quote:
Thanks for this however i am stuck on install/page_dbconnection.php the installation is not going any further just getting back to the sam page after i enter the DB details.

Mamba
What versions of PHP and MySQL do you use? Is it Linux? Is it a new installation of XOOPS?

3) Quote:
I have noticed that my folder does not have mainfile.php and its not mentioned on the files to change permission. Is this something new or is it an error coz all the years i have installed xoops there is always mainfile.php that i change the permission to 777 but on this one its not there.

Mamba
Yes, this is new - there were too many cases that people were overwriting their existing mainfile.php file, so we have removed it, and it is generated automatically, if needed.
Reply


REPLY:
1. Here i am thanks

2. Its a new installation

Server API cgi-fcgi
Apache
PHP version - 5.5.13
MySQL extension - 5.5.37-35.1
Session extension - Success
PCRE extension - Success
file_uploads - ON


3. Good idea but Mainfile.php was not generated so assume it was not needed.


Still Stuck.


16
geekwright
Re: XOOPS 2.5.7 Final Release Issues

Sounds like a permission issue, and it can't write the new mainfile.php.

The main xoops directory needs to be writeable by the web server php process. When mainfile.php exists, permission to write comes from the file itself. When it doesn't exist, the permission comes from the directory it is in. I'm guessing the server doesn't have permission to write to the xoops root directory.

Can you change the permissions of the root directory? If yes, you could try setting the main xoops directory writable long enough to run the install, and setting it back when you are done.

What type of OS is this running on?

17
bumpeboy
Re: XOOPS 2.5.7 Final Release Issues
  • 2014/6/18 1:12

  • bumpeboy

  • Friend of XOOPS

  • Posts: 170

  • Since: 2008/10/4


Quote:

geekwright wrote:
Sounds like a permission issue

Can you change the permissions of the root directory? If yes, you could try setting the main xoops directory writable long enough to run the install, and setting it back when you are done.

What type of OS is this running on?


Am on Linux i guess hostgator baby plan.


I have tried that but then i got
ERROR 500 - INTERNAL SERVER ERROR
Thats when i changed the xoops directory permission i get error 500.


18
geekwright
Re: XOOPS 2.5.7 Final Release Issues

The 500 error might be the server objecting to world write. A 775 permission might make it happy. But, I can't verify that.

Let's try this. Create a mainfile.php file with the following:
<?php
if (! defined('XOOPS_INSTALL')) {
    
header('Location: install/index.php');
}


Upload that to the root directory and set the file permission to 777, then retry the install.

If this works, we can add a file to extras, so we have a solution ready for problematic servers. I use Linux almost exclusively for development and production, and I don't have any environments where this is a problem. Even my Windows boxes seem happy with the changes. But there are always other ways to configure systems.

The whole reason for this change was to make it impossible to accidentally overwrite mainfile.php while upgrading a production system. If you've ever done that, it is a great way to induce panic and ruin an otherwise good day (OK, I am speaking from experience, I admit it, but I won't put a number on how many times I've done it.)

Sorry this is such a problem.


Edited to add this from support.hostgator.com:

Quote:
Most hosting companies now use suPHP servers, thus 755 will allow PHP to read, write and execute scripts just like 777 does. Because of this, most scripts work when you use 755.

suPHP solves the whole problem. Too bad they are not "most hosting companies"

19
brutalicuss
Re: XOOPS 2.5.7 Final Release Issues

guys, hostgator php 5.4 working fine on baby plan.
All my modules working fine, even weblinks and catads (old module)

But there is some king problem with caricafoto .js or somewhere in textsanitizer. The images wont resize and not clickable. I tried to return old files in textsanitizer/image but no luck cos module.textsanitizer.php is changed seriously... i dont know really :) Maybe something with the img path

Do you have any idea whats happen?

10x guys :)

20
bumpeboy
Re: XOOPS 2.5.7 Final Release Issues
  • 2014/6/18 16:38

  • bumpeboy

  • Friend of XOOPS

  • Posts: 170

  • Since: 2008/10/4


Quote:

geekwright wrote:
The 500 error might be the server objecting to world write. A 775 permission might make it happy. But, I can't verify that.

Let's try this. Create a mainfile.php file with the following:
<?php
if (! defined('XOOPS_INSTALL')) {
    
header('Location: install/index.php');
}


Upload that to the root directory and set the file permission to 777, then retry the install.

If this works, we can add a file to extras, so we have a solution ready for problematic servers. I use Linux almost exclusively for development and production, and I don't have any environments where this is a problem. Even my Windows boxes seem happy with the changes. But there are always other ways to configure systems.

The whole reason for this change was to make it impossible to accidentally overwrite mainfile.php while upgrading a production system. If you've ever done that, it is a great way to induce panic and ruin an otherwise good day (OK, I am speaking from experience, I admit it, but I won't put a number on how many times I've done it.)

Sorry this is such a problem.


Edited to add this from support.hostgator.com:

Quote:
Most hosting companies now use suPHP servers, thus 755 will allow PHP to read, write and execute scripts just like 777 does. Because of this, most scripts work when you use 755.

suPHP solves the whole problem. Too bad they are not "most hosting companies"



I tried to create mainfile.php and changed the xoops folder to 755 but still it didnt work.

Changed permission to 755 got error 500 and with that i could not tell the effect of the newly created mainfile.php

However on the same server, when i install 2.5.6 and then override those files with the new 2.5.7 i am able to upgrade to 2.5.7 that way without a problem. But to install a fresh 2.5.7 am stuck on the install/page_dbconnection.php


Login

Who's Online

53 user(s) are online (20 user(s) are browsing Support Forums)


Members: 0


Guests: 53


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits