11
mrphilong
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 10:28

  • mrphilong

  • Quite a regular

  • Posts: 351

  • Since: 2006/7/14


from 2.5.4 to 2.5.6

12
timgno
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 13:59

  • timgno

  • Module Developer

  • Posts: 1504

  • Since: 2007/6/21


Again!

It seems that the version 2.5.7 beta 1 is different from 2.5.7

With 2.5.7 I can install and uninstall any module, where as with version 2.5.7 beta 1 you are unable to communicate with the database.

Any submission is denied without errors, return to the sending page

13
slider84
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 15:50

  • slider84

  • Just popping in

  • Posts: 21

  • Since: 2013/8/16


On fresh install, icons of installed sections in Admin/System configuration are always show "disable" state by default.
To see it: Change state of a section then refresh page.
Apache 2.2.22-MySQL 5.5.31-Php 5.3.10

14
Mamba
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 18:50

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
On fresh install, icons of installed sections in Admin/System configuration are always show "disable" state by default.

Could you provide a screenshot? I am not sure I understand...

Quote:
Php 5.3.10

You need at least PHP 5.3.7
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

15
Mamba
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 18:53

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
It seems that the version 2.5.7 beta 1 is different from 2.5.7

Of course, the trunk is different from the Beta release, as we continue to improve and fix bugs
But I have changed the trunk version to RC1, so this will avoid confusion

Quote:
With 2.5.7 I can install and uninstall any module, where as with version 2.5.7 beta 1 you are unable to communicate with the database.

I'll check it. But since you installed the version from the trunk, how do you have still problems with the Beta version? Did you copy the Beta files over your installation?

What version of PHP and MySQL are you using? On WAMP server?

Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

16
Mamba
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 18:58

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
from 2.5.4 to 2.5.6

I assume, you have PHP 5.3.7+, correct?
Try to deactivate modules in phpMyAdmin, except the System, and see if it works. Then try to add one module at a time, and see if it still works or not. Maybe there is an issue with one of the modules you have.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

17
timgno
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 19:33

  • timgno

  • Module Developer

  • Posts: 1504

  • Since: 2007/6/21


Quote:
Mamba wrote:
I'll check it. But since you installed the version from the trunk, how do you have still problems with the Beta version? Did you copy the Beta files over your installation?

What version of PHP and MySQL are you using? On WAMP server?


I've created first a new installaction type xoops2.5.7.beta1 folder in WAMP SERVER

PHP from version 5.3.13 to version 5.4.9, try those available
MySQL to version 5.5.16 to version 5.6.12, try those available
Apache from version 2.2.21 to version 2.4.4, try those available

I think the cause was when I customized sessions, but putting everything in place before as I have not yet solved the problem.

18
Mamba
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/16 20:16

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
I think the cause was when I customized sessions, but putting everything in place before as I have not yet solved the problem.

That sounds like changing tires on a driving car and wondering why the car is not driving straight

I hope, everything works now for you
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

19
alain01
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/21 13:03

  • alain01

  • Just can't stay away

  • Posts: 519

  • Since: 2003/6/20


Found by lionhell (frxoops.org)

In /Frameworks/moduleclasses/moduleadmin/moduleadmin.php, line 258
replace
if (phpversion() < $this->_obj->getInfo('min_php')){

by
if (version_compare(phpversion(), $this->_obj->getInfo('min_php'), '<')) {

Trouble : PHP 5.3.7 and PHP 5.3.19 :
With old test :
Quote:
Minimal PHP version required : 5.3.7 (Your version is 5.3.19)


(5.3.19 :Released: 22 Nov 2012
5.3.7 :Released: 18 August 2011)

20
Mamba
Re: XOOPS 2.5.7 Beta 1 Released for Testing
  • 2014/3/21 14:00

  • Mamba

  • Moderator

  • Posts: 11254

  • Since: 2004/4/23


Quote:
In /Frameworks/moduleclasses/moduleadmin/moduleadmin.php, line 258 replace
if (phpversion() < $this->_obj->getInfo('min_php')){
by
if (version_compare(phpversion(), $this->_obj->getInfo('min_php'), '<')) {
Alan, this has been already changed on Feb. 24: Quote:
Revision: 12332 Author: beckmi Date: Monday, February 24, 2014 19:34:43 Message: fixed PHP minimum version comparison in ModuleAdmin ---- Modified : /XoopsCore/branches/2.5.x/2.5.7/docs/changelog.250.txt Modified : /XoopsCore/branches/2.5.x/2.5.7/htdocs/Frameworks/moduleclasses/moduleadmin/moduleadmin.php
Are we talking about the same Version? Cesag mentioned something about it, so I was going to look into it this weekend, by I just would like to make sure that we're talking about the same thing...
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Login

Who's Online

58 user(s) are online (31 user(s) are browsing Support Forums)


Members: 0


Guests: 58


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits