41
culex
Re: XOOPS 2.5.6 Final Release Issues
  • 2013/5/15 11:22

  • culex

  • Module Developer

  • Posts: 711

  • Since: 2004/9/23


Seems like one of my previous fixes to a jquery error in 2.5.0 (I think) is doing this and this no longer is an issue.

In modules/system/themes/default/js/tooltips.js

Remove
( function($) {


and the page's last instance of
)};


should render the html in admin correctly

42
SMEDrieben
Re: XOOPS 2.5.6 Final Release Issues
  • 2013/5/15 17:16

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


Thanks ! Much better solution than mine !

SMEDrieben

43
SMEDrieben
Re: XOOPS 2.5.6 Final Release Issues: special characters in pda.php
  • 2013/5/17 18:51

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


My site is on UTF-8: database tables, mainfile.php etc. Everything works correctly. All special characters are given correctly on my site, in blocks, even in news/print.php, rss and pdf output.

But not in......pda.php. I'am sure that in the past I didn't have this problem. I don't know when it started, but I noticed it after the upgrade to 2.5.6. I removed the "htmlspecialchars": doesn't solve the problem.

Is there a solution ?

SMEDrieben

44
irmtfan
Re: XOOPS 2.5.6 Final Release Issues
  • 2013/5/18 6:39

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


@culex:
I did what you described and clear caches but the issue still remained.
Is there anything else i could do? I dont know JQuery.

45
Cesagonchu
Re: XOOPS 2.5.6 Final Release Issues

I get an error when I go to /modules/profile/userinfo.php

NoticeUndefined indexuid in file /modules/profile/userinfo.php line 24


and please see here for another bug:

https://sourceforge.net/p/xoops/bugs/1270/


My config (dedicated server):
Php Version: 5.4.14-1~precise+1
MYSQL Version: 5.5.31-0ubuntu0.12.04.1

46
SMEDrieben
Re: XOOPS 2.5.6 Final Release Issues: special characters in pda.php
  • 2013/5/20 9:01

  • SMEDrieben

  • Not too shy to talk

  • Posts: 173

  • Since: 2009/6/17


Concerning the pda.php special characters issue:

If I add a line around line 23 (in the head section of the html-page):

<meta charset='UTF-8' />


the special characters are displayed correctly. However,

meta charset=<{$xoops_charset}> />


doesn't work. How can pda.php use the standard Xoops charset ?

SMEDrieben

47
irmtfan
Re: XOOPS 2.5.6 Final Release Issues: special characters in pda.php
  • 2013/5/20 11:01

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


try this:
$charset _CHARSET;
and
<meta charset='{$charset}' />
_CHARSET is defined in language/LANG/global.php

48
timgno
Re: XOOPS 2.5.6 Final Release Issues
  • 2013/5/21 19:09

  • timgno

  • Module Developer

  • Posts: 1504

  • Since: 2007/6/21


Could I please know where is the code to make the changes in 2.5.6 for xoopseditor like this?

because, I using bootstrap, and have the same problem.

Thank you!

49
Cesagonchu
Re: XOOPS 2.5.6 Final Release Issues

The changes are now on XOOPS 2.5.7 here.

50
timgno
Re: XOOPS 2.5.6 Final Release Issues
  • 2013/5/22 17:25

  • timgno

  • Module Developer

  • Posts: 1504

  • Since: 2007/6/21


Quote:

The changes are now on XOOPS 2.5.7 here.


I downloaded and installed xoops 2.5.7 but the problem is the same, the changes have not been made.

I made changes to the file bootstrap.css, unfortunately without success and then eliminating changing what concerns both input[type="radio"] and input[type="checkbox"] conditions: inline or inline-block.

Login

Who's Online

74 user(s) are online (44 user(s) are browsing Support Forums)


Members: 0


Guests: 74


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits